Home Forums HDP on Linux – Installation After install Ambari login page just says …Loading…

This topic contains 36 replies, has 4 voices, and was last updated by  Dave 10 months ago.

  • Creator
    Topic
  • #36776

    Mike Faria
    Member

    Any ideas? Running on Oracle Enterprise Linux 5.6.

Viewing 30 replies - 1 through 30 (of 36 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #37221

    Dave
    Moderator

    Hi Vikas,

    This is probably your repository. If you issue the command:

    yum -d 0 -e 0 -y install ganglia-gmond-3.5.0-99

    It will probably fail.

    Can we move to another thread as this one is already very long and to add more to it will just add to confusion.

    Thanks

    Dave

    Collapse
    #37183

    Vikas Madaan
    Member

    Hi Dave, During the cluster configuration every thing goes well except Gangila Monitor installation
    Below is the error i am getting
    notice: /Stage[1]/Hdp::Snappy::Package/Hdp::Snappy::Package::Ln[32]/Hdp::Exec[hdp::snappy::package::ln 32]/Exec[hdp::snappy::package::ln 32]/returns: executed successfully
    err: /Stage[2]/Hdp-ganglia::Monitor/Hdp::Package[ganglia-monitor]/Hdp::Package::Process_pkg[ganglia-monitor]/Package[ganglia-gmond-3.5.0-99]/ensure: change from absent to present failed: Execution of ‘/usr/bin/yum -d 0 -e 0 -y install ganglia-gmond-3.5.0-99′ returned 1: Error: Nothing to do

    notice: /Stage[2]/Hdp-ganglia::Monitor/Hdp::Package[ganglia-monitor]/Hdp::Package::Process_pkg[ganglia-monitor]/Anchor[hdp::package::ganglia-monitor::end]: Dependency Package[ganglia-gmond-3.5.0-99] has failures: true
    warning: /Stage[2]/Hdp-ganglia::Monitor/Hdp::Package[ganglia-monitor]/Hdp::Package::Process_pkg[ganglia-monitor]/Anchor[hdp::package::ganglia-monitor::end]: Skipping because of failed dependencies
    notice: /Stage[2]/Hdp-ganglia::Monitor/Hdp::Package[ganglia-gmond-modules-python]/Hdp::Package::Process_pkg[ganglia-gmond-modules-python]/Anchor[hdp::package::ganglia-gmond-modules-python::begin]: Dependency Package[ganglia-gmond-3.5.0-99] has failures: true
    warning: /Stage[2]/Hdp-ganglia::Monitor/Hdp::Package[ganglia-gmond-modules-python]/Hdp::Package::Process_pkg[ganglia-gmond-modules-python]/Anchor[hdp::package::ganglia-gmond-modules-python::begin]: Skipping because of failed dependencies
    notice: /Stage[2]/Hdp-ganglia::Monitor/Hdp::Package[ganglia-gmond-modules-python]/Hdp::Package::Process_pkg[ganglia-gmond-modules-python]/Package[ganglia-gmond-modules-python-3.5.0-99]: Dependency Package[ganglia-gmond-3.5.0-99] has failures: true
    warning: /Stage[2]/Hdp-ganglia::Monitor/Hdp::Package[ganglia-gmond-modules-python]/Hdp::Package::Process_pkg[ganglia-gmond-modules-python]/Package[ganglia-gmond-modules-python-3.5.0-99]: Skipping because of failed dependencies
    notice: /Stage[2]/Hdp-ganglia::Monitor/Hdp::Package[ganglia-gmond-modules-python]/Hdp::Package::Process_pkg[ganglia-gmond-modules-python]/Hdp::Java::Package[ganglia-gmond-modules-python]/Anchor[hdp::java::package::ganglia-gmond-modules-python::begin]: Dependency Package[ganglia-gmond-3.5.0-99] has failures: true
    warning: /Stage[2]/Hdp-ganglia::Monitor/Hdp::Package[ganglia-gmond-modules-python]/Hdp::Package::Process_pkg[ganglia-gmond-modules-python]/Hdp::Java::Package[ganglia-gmond-modules-python]/Anchor[hdp::java::package::ganglia-gmond-modules-python::begin]: Skipping because of failed dependencies
    notice: /Stage[2]/Hdp-ganglia::Monitor/Hdp::Package[ganglia-gmond-modules-python]/Hdp::Package::Process_pkg[ganglia-gmond-modules-python]/Hdp::Java::Package[ganglia-gmond-modules-python]/Exec[mkdir -p /tmp/HDP-artifacts/ ; curl -kf --retry 10 http://localhost.localdomain:8080/resources//jdk-6u31-linux-x64.bin -o /tmp/HDP-artifacts//jdk-6u31-linux-x64.bin ganglia-gmond-modules-python]: Dependency Package[g

    Collapse
    #37120

    Vikas Madaan
    Member

    i know how to move forward..thanks

    Collapse
    #37119

    Vikas Madaan
    Member

    there are no instructions in the document what do next once i have installed and started the ambari agent.

    Collapse
    #37118

    Vikas Madaan
    Member

    There are no instructions in the doucment what to do next once i have installed the ambari-agent and started it.

    Collapse
    #37114

    Dave
    Moderator

    Hi Vikas,

    You will run into issues if you do not use the hostname.
    To avoid the SSH keys you can run:

    yum install ambari-agent

    then run

    ambari-agent start

    Otherwise you need to follow ‘setting up passwordless ssh”

    Thanks

    Dave

    Collapse
    #37108

    Vikas Madaan
    Member

    Hi Dave,

    While configuring the cluster it is asking for the Host names and SSH Privarte keys in the insall option section. I have given Host name as localhost.localdomain as the host where i want to install HDP is same as the ambari server. I am little confused what to put for SSH Private keys. i used /root/.ssh/id_rsa.pub but i doubt this is right. The documentation is not clear on what information to give so just wanted to confirm with you about the right option to put.

    Thanks for your help.

    Regards
    Vikas Madaan

    Collapse
    #37087

    Dave
    Moderator

    Just confirming the issue was with Mozilla Firefox on localhost.
    Connected IE to the IP:8080 and ambari came up immediately

    Collapse
    #37085

    Vikas Madaan
    Member

    Probably i can share my screen with you and then you can see my screen to see how things look.

    My email if is vikas.madaan@compuware.com. Do you use Microsoft Lync? i can add your email and then i can share my screen

    Regards
    Vikas Madaan

    Collapse
    #37084

    Dave
    Moderator

    Hi Vikas,

    Can you ping me a mail and perhaps I can take a look at your system?

    Thanks

    Dave

    Collapse
    #37080

    Vikas Madaan
    Member

    Yes i did that is how i got the point where i could reach the log in page for Ambari..

    Collapse
    #37076

    Dave
    Moderator

    Hi Vikas,

    You did run:

    ambari-server setup

    Before you tried to start and login?

    Thanks

    Dave

    Collapse
    #37073

    Vikas Madaan
    Member

    i never got to a point where i could give any cluster information. During installation of Ambari on CentOS 6.2 it never asked me to input the cluster info.

    After installation i was trying to log in to the Ambari console and it is always stuck in loading state.

    Regards
    Vikas Madaan

    Collapse
    #37070

    Dave
    Moderator

    Hi Vikas,

    What did you name the cluster when you installed it?

    Thanks

    Dave

    Collapse
    #37068

    Vikas Madaan
    Member

    [root@localhost init.d]# psql -U ambari ambari
    Password for user ambari:
    psql (8.4.13)
    Type “help” for help.

    ambari=> select * from clusters;
    cluster_id | cluster_info | cluster_name | desired_cluster_state | desired_stack_version
    ————+————–+————–+———————–+———————–
    (0 rows)

    ambari=>

    Collapse
    #37067

    Dave
    Moderator

    Hi Vikas,

    One last thing,

    Can you log into psql, and run ‘select * from clusters;’ and attach the output here.

    What name did you call your cluster when you installed it?

    Thanks

    Dave

    Collapse
    #37065

    Vikas Madaan
    Member

    that did not help

    [root@localhost lib]# /etc/init.d/hdp-gmetad stop
    bash: /etc/init.d/hdp-gmetad: No such file or directory
    [root@localhost lib]# /etc/init.d/hdp-gmond stop
    bash: /etc/init.d/hdp-gmond: No such file or directory
    [root@localhost lib]# ambari-server stop
    Using python /usr/bin/python2.6
    Stopping ambari-server
    Ambari Server stopped
    [root@localhost lib]# rm -rf /var/lib/ganglia/rrds/*.
    [root@localhost lib]# /etc/init.d/hdp-gmond start
    bash: /etc/init.d/hdp-gmond: No such file or directory
    [root@localhost lib]# /etc/init.d/hdp-gmetad start
    bash: /etc/init.d/hdp-gmetad: No such file or directory
    [root@localhost lib]# ambari-server start
    Using python /usr/bin/python2.6
    Starting ambari-server
    Ambari Server running with ‘root’ privileges.
    Checking iptables…
    iptables is disabled now. please reenable later.
    Server PID at: /var/run/ambari-server/ambari-server.pid
    Server out at: /var/log/ambari-server/ambari-server.out
    Server log at: /var/log/ambari-server/ambari-server.log
    Ambari Server ‘start’ completed successfully.
    [root@localhost lib]#

    Collapse
    #37063

    Dave
    Moderator

    Hi Vikas,

    I meant you need to stop the services. The commands are:

    /etc/init.d/hdp-gmetad stop
    /etc/init.d/hdp-gmond stop

    Then stop the ambari server

    rm -rf /var/lib/ganglia/rrds/*.

    Then start hdp gmond and gmetad (above command but start instead of stop) and then start the ambari server

    Thanks

    Dave

    Collapse
    #37061

    Vikas Madaan
    Member

    it did not help

    [root@localhost lib]# stop hdp-gmond
    stop: Unknown job: hdp-gmond
    [root@localhost lib]# stop hdp-gmetad
    stop: Unknown job: hdp-gmetad
    [root@localhost lib]# rm -rf /var/lib/ganglia/rrds/*.

    I restarted the server using command ambari-server restart and tried to open the ambari portal it is still in loading state as previously.

    Regards
    Vikas Madaan

    Collapse
    #37060

    Dave
    Moderator

    Hi Vikas,

    Can you try the following:

    stop hdp-gmond, hdp-gmetad on the Ambari server,
    rm -rf /var/lib/ganglia/rrds/*.
    Start up those stopped services, restart Ambari Server

    Let me know if that helps,

    Dave

    Collapse
    #37058

    Vikas Madaan
    Member

    [root@localhost var]# curl -u admin:admin http://localhost:8080/api/v1/clusters
    {
    “href” : “http://localhost:8080/api/v1/clusters”,
    “items” : [ ]
    }[root@localhost var]#

    Collapse
    #37057

    Dave
    Moderator

    Hi Vikas,

    Can you attach the output of:

    curl -u admin:admin http://localhost:8080/api/v1/clusters

    Thanks

    Dave

    Collapse
    #37051

    Vikas Madaan
    Member

    looks like it connected.

    [root@localhost var]# psql -U ambari ambari
    Password for user ambari:
    psql (8.4.13)
    Type “help” for help.

    ambari=> help
    You are using psql, the command-line interface to PostgreSQL.
    Type: \copyright for distribution terms
    \h for help with SQL commands
    \? for help with psql commands
    \g or terminate with semicolon to execute query
    \q to quit
    ambari=>

    Collapse
    #37050

    Dave
    Moderator

    Hi Vikas,

    Can you run ‘psql -U ambari ambari’ the password is bigdata

    Does this successfully log you in?

    Thanks

    Dave

    Collapse
    #37049

    Vikas Madaan
    Member

    IP tables are disabled? YES
    How much space does /var have left?

    [root@localhost var]# df -h .
    Filesystem Size Used Avail Use% Mounted on
    /dev/sda1 52G 2.8G 49G 6% /
    [root@localhost var]#

    Is this a single node? YES
    Can you telnet to the Hostname : Port for postgresql database?

    [root@localhost data]# telnet localhost 5432
    Trying 127.0.0.1…
    Connected to localhost.
    Escape character is ‘^]’.
    Connection closed by foreign host.

    What version of HDP did you install and on what OS? i am trying to install HDP 1.3.2 on CentOs 6.2

    Collapse
    #37048

    Dave
    Moderator

    Hi Vikas,

    Can you confirm :

    IP tables are disabled?
    How much space does /var have left?
    Is this a single node?
    Can you telnet to the Hostname : Port for postgresql database?

    Also, can you please keep all your information in 1 post, as I see you are responding to other posts about the same issue. This makes it difficult to see where you are at with the issue.

    What version of HDP did you install and on what OS?

    Thanks

    Dave

    Collapse
    #37046

    Vikas Madaan
    Member

    the exact message that came out is

    [root@localhost data]# telnet localhost 5432
    Trying 127.0.0.1…
    Connected to localhost.
    Escape character is ‘^]’.
    Connection closed by foreign host.
    [root@localhost data]#

    Collapse
    #37039

    Vikas Madaan
    Member

    looks like i was using the wrong syntax to tel net.

    [root@localhost data]# telnet localhost 5432
    Trying 127.0.0.1…
    Connected to localhost.
    Escape character is ‘^]’.

    looks like the telnet is working

    Collapse
    #37036

    Vikas Madaan
    Member

    looks like there is some issue

    [root@localhost var]# telnet localhost:5432
    telnet: localhost:5432: Name or service not known
    localhost:5432: Host name lookup failure
    [root@localhost var]#

    Let me know how to fix this

    Collapse
    #37033

    Dave
    Moderator

    Hi Vikas,

    IP tables are disabled?
    How much space does /var have left?
    Is this a single node?
    Can you telnet to the Hostname : Port for postgresql database?

    Thanks

    Dave

    Collapse
Viewing 30 replies - 1 through 30 (of 36 total)