Home Forums Hortonworks Sandbox Allow access to hadoop ports other than locally.

This topic contains 2 replies, has 1 voice, and was last updated by  Rupert Bailey 1 year, 2 months ago.

  • Creator
    Topic
  • #32412

    Rupert Bailey
    Participant

    netstat -a shows that some hadoop ports can only be accessed from localhost
    [root@sandbox ~]# netstat -a | grep LISTEN | grep “:5″
    tcp 0 0 sandbox:50090 *:* LISTEN
    tcp 0 0 *:57034 *:* LISTEN
    tcp 0 0 *:50060 *:* LISTEN
    tcp 0 0 sandbox:50030 *:* LISTEN
    tcp 0 0 localhost.localdomain:50070 *:* LISTEN
    tcp 0 0 *:50010 *:* LISTEN
    tcp 0 0 *:50075 *:* LISTEN
    tcp 0 0 sandbox:50300 *:* LISTEN
    tcp 0 0 *:50111 *:* LISTEN
    tcp 0 0 sandbox:51111 *:* LISTEN

    This means that some ports I can access remotely using the hostname, IP or localhost.
    How do I change hadoop to allow (for example) access to port 50070 from outside the local machine
    currently i can only call “curl localhost:50070″ and not “curl sandbox:50070″
    Naturally this is not an iptables question but a, I assume, program setup question yes?

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #32420

    Rupert Bailey
    Participant

    Oddly however the process is not a “catch all” did the same to 50470 the https port and it didn’t work.

    Collapse
    #32418

    Rupert Bailey
    Participant

    Just figured it out – it’s a program configuration setting for the dfs.http.address
    You need to change “localhost” to “0.0.0.0”
    [root@sandbox ~]# vim /etc/hadoop/conf/hdfs-site.xml

    dfs.http.address
    0.0.0.0:50070

    Collapse
Viewing 2 replies - 1 through 2 (of 2 total)