Home Forums Ambari ambari agent issue

This topic contains 5 replies, has 4 voices, and was last updated by  varun kumar kalluri 4 months, 4 weeks ago.

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #54397

    varun kumar kalluri
    Participant

    Patel,
    Thanks for information, I will try that upgrade and see if that resolves my issue.

    Collapse
    #52292

    Patel
    Participant

    Hi,
    Was able to resolve the issue by upgarding openssl version from 1.0.1e to 1.0.1g

    Collapse
    #50718

    Seth Lyubich
    Keymaster

    Hi Patel,

    Can you please check to make sure that IP in URL string you see in logs is reachable over IPv4? Looks like Ambari server ports are open on IPv6 network. Can you please verify? You can probably fully disable IPv6 as Hadoop does not support this yet.

    Please let us know if this is helpful.

    Thanks,
    Seth

    Collapse
    #50490

    Patel
    Participant

    i am using ambari 1.4.4 package which bulids rpms using maven and the version it shows is 1.3.0
    [root@localhost ~]# rpm -qa |grep ambari
    ambari-agent-1.3.0-SNAPSHOT20140306102633.x86_64
    ambari-server-1.3.0-SNAPSHOT20140306102149.noarch
    firewall is disabled.
    yes netstat confirms port are listening
    tcp 0 0 :::8441 :::* LISTEN 1880/java
    tcp 0 0 :::8440 :::* LISTEN 1880/java

    Collapse
    #50473

    Jeff Sposetti
    Moderator

    What version of Ambari are you running?

    Can you confirm the following ports are listening on the ambari server?

    netstat -anp| grep 8441
    netstat -anp| grep 8440

    Also, that those ports are reachable from the ambari agent host? Perhaps on restart, your iptables started and is blocking ports?

    Collapse
Viewing 5 replies - 1 through 5 (of 5 total)