Home Forums HDP on Linux – Installation Ambari agent registration failed

This topic contains 2 replies, has 2 voices, and was last updated by  NewBe Lee 7 months, 3 weeks ago.

  • Creator
    Topic
  • #51341

    NewBe Lee
    Participant

    Hi guys,

    First time try to install HDP using Ambari, when at the step of registering agents with server it failed, got error message below:

    Controller.py:100 – Cannot register host with not supported os type, hostname=bidw-hdp-02.priv.zulily.com, serverOsType=redhat6, agentOstype=centos linux6

    which doesn’t make sense that all nodes installed with same OS, centos6.0, tried few times even reinstalled Ambari still not working. Looked into some Python scripts but don’t see a clue where to fix it, anyone has any idea to fix it??? it’s quite frustrating…

    thanks a ton!
    newBe

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #51370

    NewBe Lee
    Participant

    Thanks for reply. I got it fixed myself by modifying a piece of code on Ambari Agent servers, Facter.py, the part of detecting OS, I forced it to return same OS type of Ambari server, and registration succeeded. This seems a bug to me and not sure I make a right change….scary

    Collapse
    #51351

    Jeff Sposetti
    Moderator

    Looks like someone else had a similar issue and has posted a workaround:

    http://hortonworks.com/community/forums/topic/confirm-hosts-failed-in-ambari-installation/

    Can you confirm: are you running Ambari 1.5.0? “ambari-server –version”

    Collapse
Viewing 2 replies - 1 through 2 (of 2 total)