Home Forums Hue ambari and hue

Tagged: 

This topic contains 12 replies, has 3 voices, and was last updated by  Dave 7 months ago.

  • Creator
    Topic
  • #49992

    Kevin
    Participant

    Hello,

    I am having an issue configuring HDP for hue as described in http://docs.hortonworks.com/HDPDocuments/HDP1/HDP-1.3.2/bk_installing_manually_book/content/rpm-chap-hue.html

    They say that I shouldn’t configure the file manually if I use ambari and I should edit it directly in ambari. So I did. But I’m not confident of what I actually put there.
    I found the tickbox for enabling webhdfsin HDFS. And in all the Custom Config (HDFS/Oozie/WebCat) I added those lines:

    hadoop.proxyuser.hue.groups=users
    hadoop.proxyuser.hue.hosts=evl2400469

    More than that, for the hue config file I am not sure of what I should changed to:
    http_host=0.0.0.0
    I decided to put the hostname of the server I installed Hue, evl2400469.

    The documentation is not very clear for a beginner like me :)
    Can you advice/help me ?

Viewing 12 replies - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #50409

    Dave
    Moderator

    Hi Kevin,

    That cluster is hugely out of date.
    The Ambari version is 1.4.4 and the stack version is 2.0.6

    Please use this documentation for 2.0:

    http://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.0.9.1/bk_using_Ambari_book/content/ambari-chap1-1.html

    Thanks

    Dave

    Collapse
    #50386

    Kevin
    Participant

    Hello,

    I just compared, with the documentation I printed when I installed ambari-server, the rpm are differents! There has been an update of the documentation in the past month :)

    I will unsintall and reinstall all services. I’ll let you know if I have further problems to install hue.

    Regards,
    Kevin

    Collapse
    #50385

    Kevin
    Participant

    Hello,

    # rpm -qa | grep ambari
    ambari-agent-1.2.0.1-1
    ambari-log4j-1.0-1
    ambari-server-1.2.0.1-1

    # hadoop version
    Hadoop 1.1.2.21
    Subversion -r
    Compiled by jenkins on Thu Jan 10 12:34:48 PST 2013

    I used the rpm given in the documentation :http://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.0.9.1/bk_using_Ambari_book/content/ambari-chap2-1.html

    RHEL, CentOS, and Oracle Linux 5
    wget http://public-repo-1.hortonworks.com/ambari/centos5/1.x/updates/1.4.4.23/ambari.repo

    cp ambari.repo /etc/yum.repos.d

    ….

    So, it looks like I should use :
    https://cwiki.apache.org/confluence/display/AMBARI/Install+Ambari-1.4.4+from+public+repositories ?

    Thank you

    Regards,
    Kevin.

    Collapse
    #50353

    Dave
    Moderator

    Hi Kevin,

    You are not causing any inconvenience, I am just confused why your ambari does not look anything like mine out of the box.
    Also I am concerned as changing properties in different files instead of the ones which I have given to you is not going to bode well.

    Can you run the following command and paste the output here:

    rpm -qa | grep ambari
    hadoop version

    Thanks

    Dave

    Collapse
    #50345

    Kevin
    Participant

    Hello,

    Sorry for the inconvenience I am causing.

    Here are the screenshot of what I have in /#/main/services/HDFS/configs.

    hdfs site2<br />hébergeur images<br /><br />
    hdfs site3<br />heberger une image<br /><br />
    hdfs site4<br />hebergeur d image<br /><br />
    hdfs site5<br />Hébergeur d’images<br /><br />

    and here is the part I can edit, the hdfs-site. Note that the I can’t edit the one above.

    hdfs site<br />hebergeur d image<br /><br />

    Regards,

    Kevin.

    Collapse
    #50342

    Dave
    Moderator

    Hi Kevin,

    You need to edit core-site.xml not hdfs-site.xml
    Above “Custom hdfs-site.xml” in Ambari there is “Custom core-site.xml”
    Please send me a screenshot of where you are looking in Ambari, otherwise I would suggest running the sandbox to get familiar with things or maybe have a look at some of the training which we offer,

    Thanks

    Dave

    Collapse
    #50331

    Kevin
    Participant

    Hello,

    I didn’t find explicitly Custom core-site.xml in the config, so I edited the only field I could edit, Custom hdfs-site.xml
    I added
    hadoop.proxyuser.hue.hosts=*
    hadoop.proxyuser.hue.groups=*

    etc…
    I let the wildcard characters * exactly like in the documentation.

    I will tell you if that works when I can access my http://hue.server:8000 through this VPN + Firewall haha

    Thanks a lot !

    Regards,
    Kevin

    Collapse
    #50317

    Dave
    Moderator

    Hi Kevin,

    The core-site.xml is modified in Ambari under > HDFS > Configs > Custom core-site.xml

    Here you will enter the settings. You will not need to enter them as XML but simply the Name and the Value. Ambari will build the XML for you.

    You will need to save and then restart the service.

    Thanks

    Dave

    Collapse
    #50208

    Kevin
    Participant

    Hello,

    I already checked that it is working :
    netstat -an |grep 8000
    tcp 0 0 0.0.0.0:8000 0.0.0.0:* LISTEN

    I will investigate for the redirection.

    Still as I said in my first post, I tried to follow the documentation. But I don’t know where to edit the core-site in Ambari.
    I can easily find the others, webhcat, and oozie. but not the core-site. Is the core site the Custom configuration in HDFS service ?

    <property>
    <name>hadoop.proxyuser.hue.hosts</name>
    <value>*</value>
    </property>
    <property>
    <name>hadoop.proxyuser.hue.groups</name>
    <value>*</value>
    </property>

    I noticed that other configuration looks like different in ambari, it doesn’t look like XML, so in custom config I should put something similar to the other configurattions :
    hadoop.proxyuser.hue.hosts=*
    hadoop.proxyuser.hue.groups=*

    ?

    Thanks for helping :)
    Kevin.

    Collapse
    #50194

    Dave
    Moderator

    Hi Kevin,

    Port redirection would be up to you to configure.
    If Hue is listening on port 8000 (netstat -an | grep 8000) then you will be able to connect to it, however you will have to ensure your port redirection is working correctly.

    The hadoop.proxyuser.hue.groups should be entered into the core-site.xml as there are different values of WebHCat and Oozie which are in the documentation here:

    http://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.0.9.1/bk_installing_manually_book/content/rpm-chap-hue-2.html

    Core-Site you need to add the following via Ambari:

    <property>
    <name>hadoop.proxyuser.hue.hosts</name>
    <value>*</value>
    </property>
    <property>
    <name>hadoop.proxyuser.hue.groups</name>
    <value>*</value>
    </property>
    <property>
    <name>hadoop.proxyuser.hcat.groups</name>
    <value>*</value>
    </property>
    <property>
    <name>hadoop.proxyuser.hcat.hosts</name>
    <value>*</value>
    </property>

    WebHCat site:

    <property>
    <name>webhcat.proxyuser.hue.hosts</name>
    <value>*</value>
    </property>
    <property>
    <name>webhcat.proxyuser.hue.groups</name>
    <value>*</value>
    </property>

    Oozie site:

    <property>
    <name>oozie.service.ProxyUserService.proxyuser.hue.hosts</name>
    <value>*</value>
    </property>
    <property>
    <name>oozie.service.ProxyUserService.proxyuser.hue.groups</name>
    <value>*</value>
    </property>

    So using Ambari you would go to “Custom Configuration” click on add. Here you will enter the name and the value for each under core-site, webhcat-site and oozie-site

    Once these are added you will need to save, stop and start the components.

    Thanks

    Dave

    Collapse
    #50188

    Kevin
    Participant

    Hello,

    Thank you for your answer. I did enabled webhdfs via ambari.
    So, I should remove
    hadoop.proxyuser.hue.groups=users
    hadoop.proxyuser.hue.hosts=evl2400469
    from the Oozie/WebCat on Ambari ?
    Concerning the http_host I already switched back to 0.0.0.0.

    I am accessing the server through a VPN, so maybe I need a port redirection ?
    For example, to access Ambari I need to redirect the port 8080 on my computer with putty and put as proxy 127.0.0.1:8080 in my firefox.
    So if I want to access HUE server, I tried to redirect port 8000and change my proxy, but it seems it’s not working.

    Thanks,
    Kevin.

    Collapse
    #50184

    Kenny Zhang
    Moderator

    Hi Kevin,

    This seem like more like a hue configuration question than Ambari, so I moved it to the hue forum.
    1. Yes, you can enable webhdfs by checking the tickbox in Ambari.
    2. You only need to add hadoop.proxyuser.hue.groups/hosts to the HDFS Custom Config from Ambari.
    3. For http_host, it’s recommend to set it to 0.0.0.0, so hue service will listen on all ip address/NIC, but you must put the ip instead of hostname.

    Hope this helps.

    Thanks,
    Kenny

    Collapse
Viewing 12 replies - 1 through 12 (of 12 total)