Home Forums HDP on Linux – Installation Ambari installation Error

This topic contains 8 replies, has 3 voices, and was last updated by  Srinivas Nadella 9 months, 2 weeks ago.

  • Creator
    Topic
  • #44136

    Srinivas Nadella
    Participant

    We are running into a error when trying to install ambari 1.2.2.5.17 on a test system. Here is the error. Can some one please guide us how to resolve this.

    [root@PSWeb4 ~]# yum install ambari-server
    Loaded plugins: aliases, changelog, downloadonly, fastestmirror, presto, security, tmprepo, verify, versionlock
    Loading mirror speeds from cached hostfile
    Setting up Install Process
    Resolving Dependencies
    –> Running transaction check
    —> Package ambari-server.noarch 0:1.2.4.9-1 will be installed
    –> Processing Dependency: postgresql-server >= 8.1 for package: ambari-server-1.2.4.9-1.noarch
    –> Finished Dependency Resolution
    Error: Package: ambari-server-1.2.4.9-1.noarch (ambari)
    Requires: postgresql-server >= 8.1
    You could try using –skip-broken to work around the problem
    You could try running: rpm -Va –nofiles –nodigest

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #44833

    Srinivas Nadella
    Participant

    Once you add the repo, make sure to run “yum install postgres-server” before ambari install

    Collapse
    #44832

    Srinivas Nadella
    Participant

    You need to add following to the /etc/yum.repos.d/centos.repo(in case using local repo)

    name=centos
    baseurl=http://psweb1/hdp/centos
    gpgcheck=0
    enabled=1
    =========
    And you will have to add centos repo from following link. Make sure to download only postgres related rpms, there are lot of unnecessary rpms)

    ftp://ftp.redhat.com/pub/redhat/linux/enterprise/6Server/en/os/SRPMS/.

    If you do not want to have repo locally you will have to enable ftp on your server and edit the centos.repo file accordingly.

    Collapse
    #44807

    Vick R
    Participant

    Jeff/Srini,
    Where can I get repoisitory file for rhel 6?

    Vick

    Collapse
    #44799

    Srinivas Nadella
    Participant

    As Jeff suggested we added OS related repository to overcome this issue.

    Collapse
    #44798

    Vick R
    Participant

    I have run into similiar issue. I am trying to install on Redhat 6.1.
    Copied the ambari.repo from http://public-repo-1.hortonworks.com/ambari/centos6/1.x/updates/1.4.1.61/ambari.repo and copied to /etc/yum.repos.d.

    When I run the installer, I get the similiar error message-
    [root@hadoop1 yum.repos.d]# yum install ambari-server
    Loaded plugins: security
    Setting up Install Process
    Resolving Dependencies
    –> Running transaction check
    —> Package ambari-server.noarch 0:1.4.1.25-1 set to be updated
    –> Processing Dependency: postgresql-server >= 8.1 for package: ambari-server
    –> Processing Dependency: python26 for package: ambari-server
    –> Running transaction check
    —> Package ambari-server.noarch 0:1.4.1.25-1 set to be updated
    –> Processing Dependency: postgresql-server >= 8.1 for package: ambari-server
    —> Package python26.x86_64 0:2.6.8-2.el5 set to be updated
    –> Processing Dependency: libffi.so.5()(64bit) for package: python26
    –> Processing Dependency: libpython2.6.so.1.0()(64bit) for package: python26
    –> Running transaction check
    —> Package ambari-server.noarch 0:1.4.1.25-1 set to be updated
    –> Processing Dependency: postgresql-server >= 8.1 for package: ambari-server
    —> Package libffi.x86_64 0:3.0.5-1.el5 set to be updated
    —> Package python26-libs.x86_64 0:2.6.8-2.el5 set to be updated
    –> Finished Dependency Resolution
    ambari-server-1.4.1.25-1.noarch from Updates-ambari-1.4.1.25 has depsolving problems
    –> Missing Dependency: postgresql-server >= 8.1 is needed by package ambari-server-1.4.1.25-1.noarch (Updates-ambari-1.4.1.25)
    Error: Missing Dependency: postgresql-server >= 8.1 is needed by package ambari-server-1.4.1.25-1.noarch (Updates-ambari-1.4.1.25)
    You could try using –skip-broken to work around the problem
    You could try running: package-cleanup –problems
    package-cleanup –dupes
    rpm -Va –nofiles –nodigest
    The program package-cleanup is found in the yum-utils package.
    [root@hadoop1 yum.repos.d]#

    I also checked for postgre as a part of the repo –
    [root@hadoop1 yum.repos.d]# yum info postgresql-server
    Loaded plugins: security
    Error: No matching Packages to list

    The ambari.repo contents are-
    [ambari-1.x]
    name=Ambari 1.x
    baseurl=http://public-repo-1.hortonworks.com/ambari/centos6/1.x/GA
    gpgcheck=1
    gpgkey=http://public-repo-1.hortonworks.com/ambari/centos6/RPM-GPG-KEY/RPM-GPG-KEY-Jenkins
    enabled=1
    priority=1

    [HDP-UTILS-1.1.0.16]
    name=Hortonworks Data Platform Utils Version – HDP-UTILS-1.1.0.16
    baseurl=http://public-repo-1.hortonworks.com/HDP-UTILS-1.1.0.16/repos/centos6
    gpgcheck=0
    gpgkey=http://public-repo-1.hortonworks.com/ambari/centos6/RPM-GPG-KEY/RPM-GPG-KEY-Jenkins
    enabled=1
    priority=1

    [Updates-ambari-1.4.1.25]
    name=ambari-1.4.1.25 – Updates
    baseurl=http://public-repo-1.hortonworks.com/ambari/centos6/1.x/updates/1.4.1.25
    gpgcheck=1
    gpgkey=http://public-repo-1.hortonworks.com/ambari/centos6/RPM-GPG-KEY/RPM-GPG-KEY-Jenkins
    enabled=1
    priority=1

    Please advise.

    Collapse
    #44369

    Jeff Sposetti
    Moderator

    If you run “yum info postgresql-server”, what do you find?

    If it returns “Error: No matching Packages to list” then you need to make the OS repository available that includes postgres 8.x.

    Collapse
    #44365

    Srinivas Nadella
    Participant

    repos -epel,ambari,hdp and hdp-utils
    ambari.repo epel.repo HDP.repo HDP-UTILS.repo
    Os is centos 6 x86*64

    Content of ambari.repo
    ===========
    [ambari-updates]
    name=ambari-updates
    baseurl=http://psweb4/hdp/ambari/centos6/1.x/updates/1.2.5.17
    gpgcheck=0
    enabled=1
    =====================

    Collapse
    #44364

    Jeff Sposetti
    Moderator

    Hi
    1) What repositories do you have setup? What does your /etc/yum.repos.d/ambari.repo look like?
    2) What OS?

    Collapse
Viewing 8 replies - 1 through 8 (of 8 total)