Home Forums HDP on Linux – Installation Ambari installation fails on SUSE Linux 11 SP1

This topic contains 13 replies, has 6 voices, and was last updated by  Seth Lyubich 1 year, 4 months ago.

  • Creator
    Topic
  • #17895

    # zypper install ambari-server
    Loading repository data…
    Reading installed packages…
    Resolving package dependencies…

    The following NEW package is going to be installed:
    ambari-server

    The following package is not supported by its vendor:
    ambari-server

    1 new package to install.
    Overall download size: 31.9 MiB. After the operation, additional 42.4 MiB will be used.
    Continue? [y/n/?] (y): y
    Installing: ambari-server-1.2.1.2-1 [error]
    Installation of ambari-server-1.2.1.2-1 failed:
    (with –nodeps –force) Error: Subprocess failed. Error: RPM failed: error: /var/cache/zypp/packages/Updates-ambari-1.x/1.2.1.2/noarch/ambari-server-1.2.1.2-1.noarch.rpm: Header V4 RSA/SHA1 signature: BAD, key ID 07513cad
    error: /var/cache/zypp/packages/Updates-ambari-1.x/1.2.1.2/noarch/ambari-server-1.2.1.2-1.noarch.rpm cannot be installed

    Abort, retry, ignore? [a/r/i] (a): a

Viewing 13 replies - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #19087

    Seth Lyubich
    Keymaster

    Hi Jason,

    Thanks for letting us know. Yes, we seen other cases where zypper refresh command was required.

    Thanks,
    Seth

    Collapse
    #19085

    Jason Morse
    Participant

    Thanks for the updates guys. I am working with Subhankar on this. It looks like zypper refresh was needed to be run. After running zypper refresh we were able to get ambari-server installed.

    Collapse
    #18891

    Seth Lyubich
    Keymaster

    Hi Subhankar,

    This looks like that something is wrong with repositories.

    Can you please try to:

    - remove all Ambari repositories (check with zypper repos command)
    - rpm -ev ambari
    - download Ambari repo – rpm -Uvh http://public-repo-1.hortonworks.com/ambari/suse11/1.x/GA/ambari-1.x-1.noarch.rpm
    - run “zypper clean”
    - run “zypper refresh”
    - try installing HDP.

    Please let us know if this is helpful.

    Thanks,
    Seth

    Collapse
    #18885

    Peter Linnell
    Participant

    Looks like something is not right on the server hosting the packages, like the metdata needs refreshing or the gpg key is expired or is not accessible.

    NoSuchKeyThe specified key does not exist.ambari/suse11/1.x/GA34E3B10D531F54BEBeFHvE3yVhB1iHesRKyNUdWhCsjkNpMK07soKAFqxqNSCzZvb1LsF6WwuJgt3rAY

    Hope that helps.

    Collapse
    #18253

    tedr
    Member

    Hi Subhankar and Bruce,

    Ok, I am researching how to fix this short of re-installing the OS. Just for your information though I was able to get the bad key error by following the steps you guys did, but when I did the steps to fix that I posted earlier, the error went away. You may need to clean the repositories cache with ‘zypper clean.’

    Thanks,
    Ted.

    Collapse
    #17969

    bruce wang
    Member

    Hi, I encounted the same issue. I did the same thing that removing the ambari-1.2.0.1-1.noarch rpm and reinstalling ambari-server as Subhankar did. And there is no ambari-repo file in /etc/zypp/repos.d after removing the ambari-1.2.0.1-1.noarch rpm. The result was the same BAD key ID error.

    Collapse
    #17956

    tedr
    Member

    Hi Subhankar,

    After you did the removing of the ambari-1.2.0.1-1.noarch rpm, what were the contents of the /etc/zypp/repos.d folder? Make sure that there is no ambari-repo file still hanging around in there.

    Thanks,
    Ted.

    Collapse
    #17955

    Hi Ted,

    Thanks for your continued support. However, still no luck
    ———————————————————————————————————————————————————-
    xxxxxxxxxxxxx:/tmp # rpm -ev ambari-1.2.0.1-1.noarch
    xxxxxxxxxxxxx:/tmp # zypper repos
    # | Alias | Name | Enabled | Refresh
    –+————————————————–+————————————————–+———+——–
    1 | SUSE-Linux-Enterprise-Server-11-SP1 11.1.1-1.152 | SUSE-Linux-Enterprise-Server-11-SP1 11.1.1-1.152 | Yes | No
    xxxxxxxxxxxxx:/tmp # zypper remove ambari-server
    Loading repository data…
    Reading installed packages…
    ‘ambari-server’ not found.
    Resolving package dependencies…

    Nothing to do.
    xxxxxxxxxxxxx:/tmp # rpm -Uvh http://public-repo-1.hortonworks.com/ambari/suse11/1.x/GA/ambari-1.2.0.1-1.noarch.rpm
    Retrieving http://public-repo-1.hortonworks.com/ambari/suse11/1.x/GA/ambari-1.2.0.1-1.noarch.rpm
    Preparing… ########################################### [100%]
    1:ambari ########################################### [100%]
    xxxxxxxxxxxxx:/tmp # zypper install ambari-server
    Loading repository data…
    Reading installed packages…
    Resolving package dependencies…

    The following NEW package is going to be installed:
    ambari-server

    The following package is not supported by its vendor:
    ambari-server

    1 new package to install.
    Overall download size: 31.9 MiB. After the operation, additional 42.4 MiB will be used.
    Continue? [y/n/?] (y): y
    Installing: ambari-server-1.2.1.2-1 [error]
    Installation of ambari-server-1.2.1.2-1 failed:
    (with –nodeps –force) Error: Subprocess failed. Error: RPM failed: error: /var/cache/zypp/packages/Updates-ambari-1.x/1.2.1.2/noarch/ambari-server-1.2.1.2-1.noarch.rpm: Header V4 RSA/SHA1 signature: BAD, key ID 07513cad
    error: /var/cache/zypp/packages/Updates-ambari-1.x/1.2.1.2/noarch/ambari-server-1.2.1.2-1.noarch.rpm cannot be installed

    Abort, retry, ignore? [a/r/i] (a): a
    Problem occured during or after installation or removal of packages:
    Installation aborted by user

    Please see the above error message for a hint.

    Collapse
    #17949

    tedr
    Member

    Hi Subhankar,

    Ahh, I see what went wrong now, the columns in the table were meant for you to choose one or the other methods of installing the repo. To correct for this what you need to do is:
    1- rpm -ev ambari-1.2.0.1-1.noarch
    2- zypper remove ambari-server (just to make sure that your system doesn’t think that it’s installed)
    3- rpm -Uvh http://public-repo-1.hortonworks.com/ambari/suse11/1.x/GA/ambari-1.2.0.1-1.noarch.rpm
    4- zypper install ambari-server

    Thanks,
    Ted.

    Collapse
    #17905

    Hi Ted,

    The following steps were performed

    1) rpm -Uvh http://public-repo-1.hortonworks.com/ambari/suse11/1.x/GA/ambari-1.2.0.1-1.noarch.rpm
    This installed the ambari package ambari-1.2.0.1-1.noarch

    2) wget http://public-repo-1.hortonworks.com/ambari/suse11/1.x/GA/ambari.repo
    Downloaded the repo file

    3) cp ambari.repo /etc/zypp/repos.d
    Copied to the zypper repo directory

    4) zypper repos
    # | Alias | Name | Enabled | Refresh
    –+————————————————–+————————————————————–+———+——–
    1 | HDP-UTILS-1.1.0.15 | Hortonworks Data Platform Utils Version – HDP-UTILS-1.1.0.15 | Yes | No
    2 | SUSE-Linux-Enterprise-Server-11-SP1 11.1.1-1.152 | SUSE-Linux-Enterprise-Server-11-SP1 11.1.1-1.152 | Yes | No
    3 | Updates-ambari-1.x | ambari-1.x – Updates | Yes | No
    4 | ambari-1.x | Ambari 1.x | Yes | No

    Confirmed the downloaded repository

    5) zypper install ambari-server
    Tried installing Ambari bits with zypper when I encountered exceptions

    All the above steps were followed from Hortonworks Install Guide

    Collapse
    #17904

    tedr
    Member

    Hi Subhankar,

    Can you give us the complete list of steps you took to get to this point? I’m looking to find all of the steps necessary to replicate the issue.

    Thanks,
    Ted.

    Collapse
    #17901

    Hi Ted,

    I also tried with the –no-gpg-checks option but same result

    zypper –no-gpg-checks install ambari-server
    Loading repository data…
    Reading installed packages…
    Resolving package dependencies…

    The following NEW package is going to be installed:
    ambari-server

    The following package is not supported by its vendor:
    ambari-server

    1 new package to install.
    Overall download size: 31.9 MiB. After the operation, additional 42.4 MiB will be used.
    Continue? [y/n/?] (y): y
    Installing: ambari-server-1.2.1.2-1 [error]
    Installation of ambari-server-1.2.1.2-1 failed:
    (with –nodeps –force) Error: Subprocess failed. Error: RPM failed: error: /var/cache/zypp/packages/Updates-ambari-1.x/1.2.1.2/noarch/ambari-server-1.2.1.2-1.noarch.rpm: Header V4 RSA/SHA1 signature: BAD, key ID 07513cad
    error: /var/cache/zypp/packages/Updates-ambari-1.x/1.2.1.2/noarch/ambari-server-1.2.1.2-1.noarch.rpm cannot be installed

    Abort, retry, ignore? [a/r/i] (a): a

    Collapse
    #17899

    tedr
    Member

    Hi Subhankar,

    Thanks for trying out Hortonworks Data Platform.

    Try running the installer with this command: ‘zypper install ambari-server –no-gpg-checks’

    I hope this helps.
    Thanks,
    Ted.

    Collapse
Viewing 13 replies - 1 through 13 (of 13 total)