Home Forums HDP on Linux – Installation Ambari not able to register to nodes

This topic contains 7 replies, has 4 voices, and was last updated by  Seth Lyubich 1 year, 8 months ago.

  • Creator
    Topic
  • #21905

    Lance Fang
    Participant

    Hi,

    From the ambari node, I am able to ssh to all nodes, but from the wizard, it STDERR “Permission denied (publickey,password).”

    Thoughts?
    ===

    [root@dwbi-durl-gphd0 ~]# ssh dwbi-durl-gphd1.gso.lab.emc.com
    Last login: Tue Apr 16 18:46:04 2013 from dwbi-durl-gphd0.gso.lab.emc.com
    [root@dwbi-durl-gphd1 ~]# exit
    logout
    Connection to dwbi-durl-gphd1.gso.lab.emc.com closed.
    [root@dwbi-durl-gphd0 ~]# ssh dwbi-durl-gphd2.gso.lab.emc.com
    Last login: Tue Apr 16 18:52:31 2013 from dwbi-durl-gphd1.gso.lab.emc.com
    [root@dwbi-durl-gphd2 ~]# exit
    logout
    Connection to dwbi-durl-gphd2.gso.lab.emc.com closed.
    [root@dwbi-durl-gphd0 ~]# ssh dwbi-durl-gphd3.gso.lab.emc.com
    Last login: Tue Apr 16 19:09:17 2013 from dwbi-durl-gphd1.gso.lab.emc.com
    [root@dwbi-durl-gphd3 ~]# exit
    logout
    Connection to dwbi-durl-gphd3.gso.lab.emc.com closed.
    [root@dwbi-durl-gphd0 ~]# ssh dwbi-durl-gphd4.gso.lab.emc.com
    Last login: Tue Apr 16 18:53:26 2013 from dwbi-durl-gphd1.gso.lab.emc.com
    [root@dwbi-durl-gphd4 ~]# exit
    logout
    Connection to dwbi-durl-gphd4.gso.lab.emc.com closed.
    [root@dwbi-durl-gphd0 ~]# ssh dwbi-durl-gphd4.gso.lab.emc.com
    Last login: Tue Apr 16 19:16:27 2013 from dwbi-durl-gphd0.gso.lab.emc.com
    [root@dwbi-durl-gphd4 ~]# exit
    logout
    Connection to dwbi-durl-gphd4.gso.lab.emc.com closed.
    [root@dwbi-durl-gphd0 ~]# ssh dwbi-durl-gphd5.gso.lab.emc.com
    Last login: Tue Apr 16 18:53:52 2013 from dwbi-durl-gphd1.gso.lab.emc.com
    [root@dwbi-durl-gphd5 ~]# exit
    logout
    Connection to dwbi-durl-gphd5.gso.lab.emc.com closed.
    [root@dwbi-durl-gphd0 ~]#

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #22057

    Seth Lyubich
    Keymaster

    Thanks for letting us know Lance.

    Seth

    Collapse
    #22046

    Lance Fang
    Participant

    Seth,

    You are correct. I copied id_rsa and it is solved.

    Collapse
    #22045

    Seth Lyubich
    Keymaster

    Hi Lance,

    Looking on last comment I think you are copying id_rsa.pub file (“… cut and paste/download of the “id_dsa.put” …”). You need to use id_rsa file instead.

    Can you please trywith id_rsa file and let me know if this is helpful.

    Thanks,
    Seth

    Collapse
    #21992

    Lance Fang
    Participant

    Larry,

    Thank you for looking into this. I have tried both options, cut and paste/download of the “id_dsa.put” file without success.

    At the command line, the “-i” seem to be the cause of the problem, not the private key. I am able to ssh/copy to all nodes without problem, but when include with the “-i”, it has the

    Permission denied (publickey,password).
    lost connection

    Here is a bit more details of my environment:

    [root@dwbi-durl-gphd0 .ssh]# uname -a
    Linux dwbi-durl-gphd0 2.6.32-279.el6.x86_64 #1 SMP Wed Jun 13 18:24:36 EDT 2012 x86_64 x86_64 x86_64 GNU/Linux

    Collapse
    #21988

    Larry Liu
    Moderator

    Hi, Lance

    It is interesting since -i identity_file “Selects the file from which the identity (private key) for RSA authentication is read”. It seems a correct option.

    I tested with -i and I didn’t see the issue. Also I tested without -i, the key file is copied over to the other machine as well.

    I think you may double check your private key file to see if it is correct. If you copy paste the content to a file, you may want to download to your machine instead.

    Thanks
    Larry

    Collapse
    #21959

    Lance Fang
    Participant

    Ok … Here is more information.

    [root@dwbi-durl-gphd0 ambari-server]# scp -o ConnectTimeout=60 -o BatchMode=yes -o StrictHostKeyChecking=no /var/run/ambari-server/bootstrap/8/sshKey /etc/yum.repos.d/ambari.repo root@dwbi-durl-gphd1.gso.lab.emc.com:/etc/yum.repos.d
    sshKey 100% 609 0.6KB/s 00:00
    ambari.repo 100% 751 0.7KB/s 00:00
    [root@dwbi-durl-gphd0 ambari-server]# scp -o ConnectTimeout=60 -o BatchMode=yes -o StrictHostKeyChecking=no -i /var/run/ambari-server/bootstrap/8/sshKey /etc/yum.repos.d/ambari.repo root@dwbi-durl-gphd1.gso.lab.emc.com:/etc/yum.repos.d
    Permission denied (publickey,password).
    lost connection

    I looked in the logs and scp with the “i” option cause the permission denied. I tested without the “i” and it seems to work. The “i” option was generated from the ambari wizard.

    Collapse
    #21908

    Sasha J
    Moderator

    Lance,
    make sure you provide FQDN to the ambari UI and DNS resolve names to addresses correctly and names are all in lower case. Make sure you provide correct key in the UI.

    If this still not help, you can install ambari agents manually (refer to documentation).

    Thank you!
    Sasha

    Collapse
Viewing 7 replies - 1 through 7 (of 7 total)