Home Forums HDP on Linux – Installation Ambari – Problem of registration

This topic contains 5 replies, has 2 voices, and was last updated by  Gwenael Le Barzic 1 month, 4 weeks ago.

  • Creator
    Topic
  • #49029

    Gwenael Le Barzic
    Participant

    Hello everyone !

    I contact you because I have currently a problem installing an Hadoop cluster with Ambari.
    I would like to have the following architecture :
    - 1 master
    - 3 slaves
    All these servers are running on CentOS 6.5.

    I have followed this procedure :

    http://docs.hortonworks.com/HDPDocuments/HDP1/HDP-1.2.1/bk_using_Ambari_book/content/ambari-chap1.html

    The setup of Ambari is done with the default values (root as user, postgre with standard dbname, user, password).
    The setup of Ambari complete successfully.

    About the Password-Less SSH , on the master, I performed an ssh-keygen and put the public key on each of the three slaves.

    I started Ambari server on the master.
    I connected to the user interface of Ambari.
    - At the “select Stack” step, I chose HDP 2.0..6 and Red Hat 6, CentOS 6, Oracle Linux 6 f for the repository
    - At the Install option step, I put the 4 FQDN of my servers and I added the SSL private key of the master
    - WHen I click on Next, the progression on the four hosts appear, with the status “installing” and then “registering”, and then “failed”

    Here are some information I discovered in the /var/log/ambari-server/ambari-server.log. I modified the hostnames in this message. This message appears for the htree slaves.
    18:18:51,690 INFO [pool-2-thread-1] BSHostStatusCollector:62 – HostList for polling on [<MASTER>, <SLAVE1> <SLAVE2>, <SLAVE3>]
    18:18:54,782 WARN [qtp1447972804-94] nio:651 – javax.net.ssl.SSLHandshakeException: null cert chain
    18:18:54,852 INFO [qtp1447972804-94] CertificateManager:187 – Signing of agent certificate
    18:18:54,853 INFO [qtp1447972804-94] CertificateManager:188 – Verifying passphrase
    18:18:54,857 WARN [qtp1447972804-94] ShellCommandUtil:46 – Command openssl ca -config /var/lib/ambari-server/keys/ca.config -in /var/lib/ambari-server/keys/<SLAVE3>.csr -out /var/lib/ambari-server/keys/<SLAVE3>.crt -batch -passin pass:**** -keyfile /var/lib/ambari-server/keys/ca.key -cert /var/lib/ambari-server/keys/ca.crt was finished with exit code: 1 – an error occurred parsing the command options.

    Furthermore, on the agents log of the different slaves, I get the following type of messages :
    INFO 2014-02-20 18:18:48,166 security.py:56 – Insecure connection to https://master:8441/ failed. Reconnecting using two-way SSL authentication..
    INFO 2014-02-20 18:18:48,166 security.py:184 – Agent certificate not exists, sending sign request
    ERROR 2014-02-20 18:18:48,278 security.py:220 – Certificate signing failed.
    In order to receive a new agent certificate, remove existing certificate file from keys directory. As a workaround you can turn off two-way SSL authentication in server configuration(ambari.properties)
    Exiting..
    INFO 2014-02-20 18:18:48,

    I’m wondering when the problem comes from. Does anyone have any idea about this ?

    Best regards.

    Gwenael

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #49090

    Gwenael Le Barzic
    Participant

    Re Jeff.

    I come back here because we finally manage to complete the whole process.

    Here is what we did :
    - We cleaned the installation (ambari-server stop, ambari-server reset, removal of the content of the folder keys)
    - We removed ambari-server from the master and reinstalled the last version 1.4.4.23 with yum (yum install ambari-server)
    - During the installation, we modified all the paths from /boot/efi/hadoop to /hadoop, in order to avoid a problem of permission
    - We granted the user hive the right to connect to the database from the master and the 3 slaves hosts
    - We double checked the node name because it was strangely not well started, provoking a failure in the map-reduce function in hive, so we restarted it.

    I’m going to try to install hue now !

    Best regards.

    Gwenael

    Collapse
    #49089

    Jeff Sposetti
    Moderator

    Let’s see what repos are available: On the Ambari Server host, run “yum repolist”. And on one of the cluster host machines, do the same.

    Also, do you see /etc/yum.repos.d/ambari.repo on one the cluster host machines? As well, please provide output of “yum info python-rrdtool” from that machine.

    Collapse
    #49079

    Gwenael Le Barzic
    Participant

    Re Jeff.

    Somehow, I have the impression that my problem was coming from the Internet access, probably when it tries to get the packages. My repo file was not well set I think. One of my colleague launched the cntlm service in order to use the internet connection behind our proxy interprise server, and then when we retried the installation, we were able to successfully progress after the step which were failing.

    But now we have another problem at the final step :
    err: /Stage[2]/Hdp-ganglia::Server::Packages/Hdp::Package[rrdtool-python]/Hdp::Package::Process_pkg[rrdtool-python]/Package[python-rrdtool.x86_64]/ensure: change from absent to present failed: Execution of '/usr/bin/yum -d 0 -e 0 -y install python-rrdtool.x86_64' returned 1: Error: Package: rrdtool-1.4.5-1.el6.x86_64 (HDP-UTILS-1.1.0.16)
    Requires: ruby
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest

    I investigated on the forum and found this other topic :

    http://hortonworks.com/community/forums/topic/ruby-dependencies/

    On the master server, I performed the following commande : rpm -qa | grep ruby
    And I got no line in return.
    But, this topic is pretty old (2012) so what do you think of this ?

    Best regards.

    Gwenael

    Collapse
    #49073

    Gwenael Le Barzic
    Participant

    Hello Jeff !

    Thank you for your answer.

    I performed an ‘ambari-server –version’

    And here is my version of Ambari : 1.4.4.23

    Best regards.

    Gwenael

    Collapse
    #49041

    Jeff Sposetti
    Moderator

    Can you confirm which version of ambari you are using? “yum info ambari-server” or “ambari-server –version”?

    The latest is Ambari 1.4.4 and ships with two-way SSL off by default, which might be causing your issue.

    http://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.0.9.1/bk_using_Ambari_book/content/ambari-chap1-1.html

    Collapse
Viewing 5 replies - 1 through 5 (of 5 total)