The Hortonworks Community Connection is now live. A completely rebuilt Q&A forum, Knowledge Base, Code Hub and more, backed by the experts in the industry.

You will be redirected here in 10 seconds. If your are not redirected, click here to visit the new site.

The legacy Hortonworks Forum is now closed. You can view a read-only version of the former site by clicking here. The site will be taken offline on January 31,2016

HDP on Linux – Installation Forum

Ambari registration to host failing

  • #49744
    Kevin
    Participant

    Hello, I am having some troubles installing via ambari server, it seems the installation is going well, but the servers won’t registrate correctly.
    Could it be the ntpd is not setup correctly ?

    [...]
    Verifying Python version compatibility...
    Using python /usr/bin/python2.6
    Checking for previously running Ambari Agent...
    Starting ambari-agent
    Verifying ambari-agent process status...
    Ambari Agent successfully started
    Agent PID at: /var/run/ambari-agent/ambari-agent.pid
    Agent log at: /var/log/ambari-agent/ambari-agent.out
    ('hostname: ok evl2400470.eu.verio.net
    ip: ok xx.xx.xx.xx
    cpu: ok
    [...]
    disks: ok
    [...]
    os: ok Red Hat Enterprise Linux Server release 5.10 (Tikanga)
    iptables: ok
    Chain INPUT (policy ACCEPT 81171 packets, 29M bytes)
    pkts bytes target prot opt in out source destination

    Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
    pkts bytes target prot opt in out source destination

    Chain OUTPUT (policy ACCEPT 42431 packets, 7410K bytes)
    pkts bytes target prot opt in out source destination
    selinux: ok SELINUX=disabled
    SELINUXTYPE=targeted
    yum: ok yum-3.2.22-40.el5
    rpm: ok rpm-4.4.2.3-34.el5
    openssl: ok openssl-0.9.8e-27.el5_10.1
    openssl-0.9.8e-27.el5_10.1
    curl: ok curl-7.15.5-17.el5_9
    curl-7.15.5-17.el5_9
    wget: ok wget-1.11.4-3.el5_8.2
    net-snmp: ok net-snmp-5.3.2.2-20.el5
    net-snmp-utils: UNAVAILABLE
    ntpd: UNAVAILABLE
    ruby: ok ruby-1.8.7.374-2.el5
    puppet: ok puppet-3.4.2-1.el5
    nagios: UNAVAILABLE
    ganglia: UNAVAILABLE
    passenger: UNAVAILABLE
    hadoop: UNAVAILABLE
    yum_repos: ok
    AMBARI-1.x Ambari 1.x 5
    HDP-UTILS-1.1.0.15 Hortonworks Data Platform Utils Version - HDP-UTI 52
    zypper_repos: UNAVAILABLE
    ', None)
    (" u'responseId': 0,
    u'responseStatus': u'OK',
    u'statusCommands': []}
    INFO 2014-03-07 10:00:21,936 Controller.py:96 - Got status commands on registration []
    INFO 2014-03-07 10:00:21,936 Controller.py:116 - No commands from the server : []
    INFO 2014-03-07 10:00:21,936 Controller.py:224 - Response from server = OK
    INFO 2014-03-07 10:00:31,937 Heartbeat.py:59 - Heartbeat dump: {'componentStatus': [],
    'hostname': 'evl2400470.eu.verio.net',
    'nodeStatus': {'cause': 'NONE', 'status': 'HEALTHY'},
    'reports': [],
    'responseId': 0,
    'timestamp': 1394182831936}
    INFO 2014-03-07 10:00:31,998 Controller.py:150 - Got server response: {u'executionCommands': [],
    u'registrationCommand': None,
    u'responseId': 1,
    u'restartAgent': False,
    u'statusCommands': []}
    INFO 2014-03-07 10:00:31,998 Controller.py:116 - No commands from the server : []
    INFO 2014-03-07 10:00:31,998 Controller.py:116 - No commands from the server : []
    INFO 2014-03-07 10:00:31,998 Controller.py:177 - No commands sent from the Server.
    ", None)

    STDERR
    Connection to evl2400470 closed.
    Registering with the server...
    Registration with the server failed.

  • Author
    Replies
  • #49746
    Kevin
    Participant

    I am installing Haddop 2.0 and the automated install on ambari.
    I followed everystep on install documentation.
    iptables/selinux is desactived on all machines.
    Hosts is configured.
    Passwordless works.
    Then whatis missing ?
    NTP seems synchronised so I didnt touch it

    #49747
    Kevin
    Participant

    I synchronized my NTP at last in the ntp.conf i put on the lines
    server evl240070
    server evl240071
    server evl240078

    which are my others servers.
    Then i did service ntpd restart.

    Still, can’t go throught the registration process of confirming host.

    Thanks for helping :)

    #49777
    Jeff Sposetti
    Moderator

    Are you using FQDN? For example, what is returned from “hostname -f” on the machines? Is that what you put into the host list during register the hosts?

    #49827
    D Blair Elzinga
    Participant

    I’ve had this same issue as well – finally gave up on Ambari and went to manual installation of HDP – which is also very rocky. There are several missing things from the instructions. I’ve gotten most of the things working now, but still having permission and notification issues with oozie.

    #49990
    Kevin
    Participant

    Hello,
    Yes I used FQDN, solved this issue by changing evl240070 to evl240070.eu.something.net in the step where we choose the hosts.
    my hostname had lines like this:

    83.X.231.X evl2400469.eu.something.net evl2400469

    with ‘X’ being regular numbers of course.

    Having now some trouble with HUE, but this topic is not for it.

    Have a good day :)

    #58880
    Akshay Iyengar
    Participant

    I am not even using the FQDNs. I am using the IP addresses directly and they do not work. I used the FQDNs and they do not work as well. My /etc/hosts/ has:

    192.1XX.X.XX ambariserver.company.com ambariserver
    192.1XX.X.XX machine1.company.com machine1
    192.1XX.X.XX machine2.company.com machine2

    Regardless of whether I put the IP address, machine1/2 or machine1/2.company.com, it fails to register. I even tried the manually adding Ambari agents method and that fails too. If I do it the normal way, my error log is identical to yours. So, how exactly did you solve it?

    #58883

The forum ‘HDP on Linux – Installation’ is closed to new topics and replies.

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.