Home Forums HDP on Linux – Installation Ambari Server Proxy Authentication

This topic contains 6 replies, has 3 voices, and was last updated by  Peter Bulman 4 months ago.

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #55213

    Peter Bulman
    Participant

    thanks for the reply, I have set the properties as per the Jira AMBARI-5960:
    [root@reuxeuls517 etc]# echo $AMBARI_JVM_ARGS
    -Xms512m -Xmx2048m -Djava.security.auth.login.config=/etc/ambari-server/conf/krb5JAASLogin.conf -Djava.security.krb5.conf=/etc/krb5.conf -Djavax.security.auth.useSubjectCredsOnly=false -Dhttp.proxyHost=149.195.61.99 -Dhttp.proxyPort=8080 -Dhttp.proxyUser=userabcd -Dhttp.proxyPassword=password

    restarted ambari-server after setting the above args.

    however i am still getting HTTP response code: 407 for URL: http://public-repo-1.hortonworks.com/HDP/hdp_urlinfo.json)

    I have verified access to this page with Links using the same proxy configuration.

    Collapse
    #54892

    Jeff Sposetti
    Moderator

    For now, you’ll want to click “Skip validation” when you set the Base URLs.

    http://docs.hortonworks.com/HDPDocuments/Ambari-1.6.0.0/bk_using_Ambari_book/content/ambari-chap3-2a_2x.html

    You can also follow this JIRA:

    https://issues.apache.org/jira/browse/AMBARI-5960

    Collapse
    #54891

    Peter Bulman
    Participant

    Hello,

    Does anyone have a solution or work around to this?

    I have set the AMBARI_JVM_ARGS with -Dhttp.proxyHost=<host> -Dhttp.proxyPort=<port> -Dhttp.proxyUser=<user> -Dhttp.proxyPassword=<password>
    The credentials I’m using are valid and Yum is working with the same values.

    Ambari logs are showing: Server returned HTTP response code: 407 for URL

    thanks
    Pete

    Collapse
    #49779

    Jeff Sposetti
    Moderator

    You might want to also confirm yum can use the proxy too.

    http://docs.hortonworks.com/HDPDocuments/HDP2/HDP-2.0.9.1/bk_reference/content/deployinghdp_appendix_chap4_3_4_2.html

    Check the “skip url checking” in the Ambari wizard, and confirm your yum works thru the proxy and see how that goes.

    Collapse
    #49484

    Andreas Mahling
    Participant

    Jeff, thanks you for your support, but, sorry, proxyUser and proxyPassword did not work for me.
    I will proceed now with setting up local repositories. Still wondering, why HDP needs access to http URLs while all nodes have a fully operable yum setup, Hortonworks Repos included. Tried skipping URL checking in inital cluster configuration, but this beast came up later again…

    Best Regards, Andreas

    Collapse
    #49458

    Jeff Sposetti
    Moderator

    Believe you can add these args as well.

    “-Dhttp.proxyUser=someUserName -Dhttp.proxyPassword=somePassword”

    Collapse
Viewing 6 replies - 1 through 6 (of 6 total)