The Hortonworks Community Connection is now live. A completely rebuilt Q&A forum, Knowledge Base, Code Hub and more, backed by the experts in the industry.

You will be redirected here in 10 seconds. If your are not redirected, click here to visit the new site.

The legacy Hortonworks Forum is now closed. You can view a read-only version of the former site by clicking here. The site will be taken offline on January 31,2016

HDP on Linux – Installation Forum

Ambari Service Does not start properly

  • #33521

    I have installed ambari-server on centOS 6.4 virtual machine.
    When I use the command “ambari-server start” ,I get the following result.my first question is that,what does it mean?

    [root@CentOS-DM-VM ~]# ambari-server start
    Using python /usr/bin/python2.6
    Starting ambari-server
    Checking iptables…
    iptables is disabled now
    Running server: /usr/lib/jvm/jre-1.7.0-openjdk.x86_64/bin/java/bin/java -server -XX:NewRatio=3 -XX:+UseConcMarkSweepGC -XX:-UseGCOverheadLimit -XX:CMSInitiatingOccupancyFraction=60 -Xms512m -Xmx2048m -cp /etc/ambari-server/conf:/usr/lib/ambari-server/*:/usr/local/sbin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin:/usr/lib/ambari-server/* org.apache.ambari.server.controller.AmbariServer >/var/log/ambari-server/ambari-server.out 2>&1

    There is a command that they say it is used for checking which ambari processes are running.the command is: “ps ef | grep Ambari”

    but I get the following result!.what does it mean? besides,I use the “jps” command to check the running java processes and I get only “3075 jps”.is ambari stopped?!

    [root@CentOS-DM-VM ~]# ps ef | grep Ambari
    5073 pts/2 S+ 0:00 \_ grep Ambari HOSTNAME=CentOS-DM-VM SHELL=/bin/bash TERM=xterm HISTSIZE=1000 QTDIR=/usr/lib64/qt-3.3 USER=root LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36: SUDO_USER=hduser SUDO_UID=500 USERNAME=root PATH=/usr/local/sbin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin MAIL=/var/spool/mail/root PWD=/root LANG=en_US.UTF-8 SSH_ASKPASS=/usr/libexec/openssh/gnome-ssh-askpass HISTCONTROL=ignoredups SHLVL=1 SUDO_COMMAND=/bin/bash HOME=/root LOGNAME=root CVS_RSH=ssh LESSOPEN=|/usr/bin/lesspipe.sh %s SUDO_GID=500 DISPLAY=:0.0 G_BROKEN_FILENAMES=1 COLORTERM=gnome-terminal XAUTHORITY=/var/run/gdm/auth-for-hduser-CkRl1q/database _=/bin/grep

  • Author
    Replies
  • #33565
    Dave
    Moderator

    Hi Hesam,

    What do the Ambari logs show? (/var/log/ambari-server)

    ps -ef | grep Ambari should show a java process running Ambari, as should the jps

    If you do a netstat -an | grep 8080 is the machine listening on that port? If you go to :8080 does ambari show a web UI?

    Thanks

    Dave

    #33577

    Hi Dave!
    Thanks for your guidance.
    The problem was solved 😉

    for the sake of sharing experience I explain it:

    I checked the log file and it was said that: Java Home Path /usr/lib/jvm/jre-1.7.0-openjdk.x86_64/bin/java/bin/java is not a directory!
    So I checked the Ambari properties file (/etc/ambari-server/conf/ambari.properties) and I modified “java.home” value to this: /usr/lib/jvm/jre-1.7.0-openjdk.x86_64
    (it seems that it adds “/bin/java” to the JAVA_HOME path automatically)
    and then I ran the command: “ambari-server start” again.I got the same output result(that I mentioned in the question).but when I checked the server status by command “ambari-server status”,this time,it said that the server is running.And I can enter the web GUI now!
    the problem was solved 😉

    thanks for your assistance again 😉

    #33615
    Dave
    Moderator

    Hi Hesam,

    I’m glad you got it resolved and thanks for sharing the resolution.

    Thanks

    Dave

The forum ‘HDP on Linux – Installation’ is closed to new topics and replies.

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.