Home Forums HDP on Linux – Installation base url for HDP 2.0 stack not working

This topic contains 7 replies, has 3 voices, and was last updated by  Jeff Sposetti 3 months ago.

Viewing 7 replies - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #51626

    Jeff Sposetti
    Moderator

    Do you go thru a proxy to get to internet? If so, you have to enable ambari server to be able to reach the internet thru that proxy…

    http://docs.hortonworks.com/HDPDocuments/Ambari-1.5.0.0/bk_ambari_reference/content/Configure-Ambari-Server-for-Internet-Proxy.html

    Collapse
    #51613

    Rob McFeely
    Participant

    I am having the same issue with Ambari. The host system can access the internet via wget and the yum repos can download OK however ambari cannot connect on advanced repo opttions screen

    The error when I hover over the red mark is:

    400 Bad Request. Java.lang.IllegalArguementException: Could not access base url ”http://public-repo-1.hortonworks.com/HDP/centos6/2.x/updates/2.0.10.0″

    When I browse to this address I get the following xml indicating some sort of error NOoSUchKey

    <Error>
    NoSuchKey
    <Message>The specified key does not exist.</Message>
    <Key>HDP/centos6/2.x/updates/2.0.10.0</Key>
    <RequestId>A54886C2D60C79CA</RequestId>
    <HostId>e0I410ohTsJgnlu+JwuBzyDCd2dmIbjVYlaY4qTmb8l/A0gunJmrrYbniRCWqHDo</HostId>
    <head/>
    </Error>

    Is this the source of my problem, is the repo broken???

    Please help

    Collapse
    #51504

    Justin Rush
    Participant

    apparently restarting ambari-server has solved this problem. Maybe the URLs weren’t working originally and it cached that or something.

    Collapse
    #51503

    Justin Rush
    Participant

    When I try to proceed with selecting the stack it says all three of the URLs listed are invalid. It doesn’t give any actual error message but it puts one of those lovely red ! marks next to them and deactivates the next button.

    ambari-server-1.5.0.14-1.noarch

    Collapse
    #51496

    Jeff Sposetti
    Moderator

    That’s the correct base URL to use in the Ambari install wizard (under Select Stack > Advanced Repository Options).

    You can confirm by looking at this:

    http://public-repo-1.hortonworks.com/HDP/centos6/2.x/updates/2.0.10.0/hdp.repo

    You can see the base url for Updates-HDP-2.x is http://public-repo-1.hortonworks.com/HDP/centos6/2.x/updates/2.0.10.0/ and that’s what you use in the ambari wizard UI.

    It’s not going to be browsable w/o full path. You can browse to repodata metadata file if you want to confirm it’s a repo.

    http://public-repo-1.hortonworks.com/HDP/centos6/2.x/updates/2.0.10.0/repodata/repomd.xml

    What error are you getting? And confirm: what version of Ambari are you using?

    Collapse
    #51494

    Justin Rush
    Participant

    ambari. using the default public repos that are embedded in the installer

    Collapse
    #51493

    Jeff Sposetti
    Moderator

    Are you doing a manual HDP install or an Ambari install of HDP? And you want to use the public repositories in either case?

    Collapse
Viewing 7 replies - 1 through 7 (of 7 total)