The Hortonworks Community Connection is now live. A completely rebuilt Q&A forum, Knowledge Base, Code Hub and more, backed by the experts in the industry.

You will be redirected here in 10 seconds. If your are not redirected, click here to visit the new site.

The legacy Hortonworks Forum is now closed. You can view a read-only version of the former site by clicking here. The site will be taken offline on January 31,2016

Oozie Forum

Beginner question regarding Oozie & Hive

  • #22089
    Lars Schulte

    Hey guys,

    i am running the sandbox and i want to run some hive-scripts (first tiny question: can i just take working scripts from the Beeswax panel and upload them as .sql files?) with oozie.
    I just created a new workflow, added my hive-jobs and added all the files to the working directory.
    after submitting it only shows me
    “Error submitting workflow test – sandbox

    E0701: XML schema error, cvc-elt.1.a: Cannot find the declaration of element ‘workflow-app’.”
    which seems to me like i made a config error somewhere?

    workflow xml:

    i would appreciate your help,


  • Author
  • #22472
    Seth Lyubich

    Hi Lars,

    It is possible that line below is missing in workflow.xml file.

    <?xml version=”1.0″ encoding=”UTF-8″?>

    Can you please try to add this line and try again? You can try to run xmllint utility to verify formatting of your xml files.

    Hope this helps.


    Lars Schulte

    Yes, it is missing.
    I inserted it and ran it again, but it says it is missing due to the fact, that oozies generates it newly every time i run it.
    Is there a way to disable this behavior? Or do i have to run it manually?


    Hi Lars,

    It looks like you may have to run it manually to get past the error. In the mean time I’ll look into why the line is left out when oozie generates the workflow.



    Hello Everyone,
    I’m also new in Hive. I’m facing some issues while running hive script through oozie.

    When I run the following script (script.q), on oozie console I can see its ‘SUCCEEDED’.

    show tables;

    But when I ran the following query in the script, oozie console shows its “KILLED”

    select count(*) from session_steps;

    I’m able to run it separately, like:

    [ambari_qa@ip-10-0-0-91 hive-oozie]$ hive -f script.q

    Any idea what’s going on here? I have checked the log from the oozie console but haven’t seen any useful information there. Any information will be highly appreciate.

    Larry Liu

    Hi, Tanzir

    Can you privide the log for the job?



    Hi Larry,
    I have fixed the problem. Those tables were not present from oozie side that’s why it was throwing those errors. When it was running through oozie it was pointed to a wrong mysql database. After putting (in app path) the expected hive-site.xml and hive-default.xml fixed that problem. Thanks for your time.

    Seth Lyubich

    Hi Tanzir,

    Thanks for letting us know that you were able to resolve the issue.

    Lars, are you still having issue submitting the job?


The forum ‘Oozie’ is closed to new topics and replies.

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.