Ambari Forum

Build ambari using Maven

  • #49571
    Vinay Ch s k


    I am new to Apache Ambari. I am trying to build ambari using maven.
    I am following this link

    I am able to install ambari-server and agent as well.
    They are running too.
    But if try to open the WebUI it doesn’t work.
    I have server and agent both running but i can’t build a cluster.
    It doesn’t throw any error and i am stuck here with no help.

    Pleased if you can allow some time to troubleshoot it.

to create new topics or reply. | New User Registration

  • Author
  • #49682
    Yusaku Sako

    Hello Vinay,

    Sorry to hear that you are having trouble.
    Things to check:
    1. Are you seeing any errors when you hit the URL for the Web UI or does it just hang?
    2. Is firewall turned off (iptables, etc) on the host? To turn off iptables, you can run “service iptables stop”.
    3. Is Ambari server listening on port 8080? netstat -anp | grep 8080
    4. Does this work from the host itself? curl -uadmin:admin http://localhost:8080/api/v1/clusters
    5. Do you see any errors in /var/log/ambari-server/ambari-server.log?

    Vinay Ch s k

    Hi Yusaku saku,
    I admire your help.

    1.When i run the http://<myhost&gt;:8080/api/v1/clusters
    i get the following error

    “status”: 403,
    “message”: “Full authentication is required to access this resource”

    2.And normally if i run http://<myhost&gt;:8080 i see
    <b>Directory: /</b>
    on the screen.

    a.iptabels are disabled.
    b.firewall is disabled


    Thanks and Regards,

    Vinay Ch s k

    Hi Yusaku Sako

    I am doing it on Virtual Machine Linux CentOS6.5
    Is it a problem because of the VM.
    ’cause when i install CentOS in VM it install 908 packages where actual packages installed should be 1086 (On physical Machine).

    Vinay Ch s k

    Hi Yusaku Sako,

    Is there something to do with jetty server.
    Do i have to install it manually?
    But i see maven installing jetty.

    Thanks and Regards,

    Vinay Ch s k

    Hi Yusaku sako,
    Actually it is not generating files in /usr/lib/ambari-server/web/——
    I have manually copied the files from other server. then it works fine.
    but is this has to be done everytime?
    is there a way that i can tell maven to generate and copy them in particular location.

    Thanks and Regards,

    Vinay Ch s k

    Hi Yusaku sako
    Even though it shows that the build of ambari web is success but it is not proper.
    If we build the ambari-web individually it throws an error.
    The error is that it is searching for gcc-c++ package and it is not installed.
    and other thing was in the following path /ambari/ambari-web/ it is searching for ambari-project where it is not finding it.
    So i have created a symbolic link and tried to build it now it is working fine.

    Thanks and Regards,

You must be to reply to this topic. | Create Account

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.