Hortonworks Sandbox Forum

Can't connect to git repos to clone on Sandbox

  • #58725
    Chris Lee
    Participant

    Hello, tried to get started with Hadoop in 15 minutes. I think I’m in hour eight or nine at this point.. Anyway, I got the sandbox up and running. Tried to login and just clone the project we want to see will work on Hortonworks and nothing I do gets through the wall of w/e is making this image not want to connect to our git repos.

    Example (With redactions for privacy):
    [root@sandbox testingWork]# git clone httpGitRepoLocation
    Initialized empty Git repository in /home/testingWork/someRepo/.git/
    Password:
    error: Couldn’t resolve host ‘gitrepohtto’ while accessing httpGitRepoLocation
    fatal: HTTP request failed

    All right, then I tried to do it with ssh.

    [root@sandbox testingWork]# git clone ssh://gitRepoLocation
    Initialized empty Git repository in /home/testingWork/someGitRepo/.git/
    ssh: Could not resolve hostname gitRepoLocation: Name or service not known
    fatal: The remote end hung up unexpectedly

    So, I tried sshing into other machines on our network, or not on our network. I ping lots of websites. I even successfully sshed into the box running our Git repos. But for some reason, no matter what I try, what keys I use, what method I use to clone it, I cannot get git to clone a repository on my machine. I’m incredibly stumped because every mechanism I’d use (ssh, getting to other places on the net) works fine (i.e I can ssh all over the place and access web locations). So is there something I’m missing about how I need to configure this to work on the Hortonworks sandbox? Because as of now I’m a bit disappointed.

to create new topics or reply. | New User Registration

  • Author
    Replies
  • #58747
    Chris Lee
    Participant

    Managed to fix this on my own. Not sure which of the two solutions worked, but I regenerated all my ssh keys and ran verbose SSH and had to use the literal IP Address of our git repository (In lieu of the URL it’s set up on). Possible proxy issues? Not sure.

You must be to reply to this topic. | Create Account

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.