Home Forums HDP on Windows – Installation Can't Start on windows

This topic contains 4 replies, has 3 voices, and was last updated by  Yi Zhang 1 year, 4 months ago.

  • Creator
    Topic
  • #18106

    Anthony Mattas
    Participant

    I’m trying to fire up the Windows version. I run the start_remote_hdp_services.cmd from my master node and get the below error. I am however able to start up the local services on the master node with start_local_hdp_services.cmd. Any thoughts?

    PS C:\hdp\hadoop> .\start_remote_hdp_services.cmd
    Master nodes: start HDP-NameNode1.intranet.gsite.com
    0 Master nodes successfully
    1 Master nodes failed to -output.

    PSComputerName Service Message Status
    ————– ——- ——- ——
    Connecting to remote serve…

    StartStop-HDPservices : Manually start services on Master nodes then retry full cluster start. Exiting.
    At C:\hdp\hadoop\manage_remote_hdp_services.ps1:173 char:26
    + if ($mode -eq “start”) { StartStop-HDPservices($mode) }
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : NotSpecified: (:) [Write-Error], WriteErrorException
    + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,StartStop-HDPServices

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #18177

    Yi Zhang
    Moderator

    Hi Anthony,

    The start_remote_hdp_services of current beta does not work. It is a bug. As of this beta Hadoop services have to be started with start_local_hdp_services on each node.

    Thanks,
    Yi

    Collapse
    #18172

    Anthony Mattas
    Participant

    – cluster.properties file –

    #Log directory
    HDP_LOG_DIR=c:\hdp\logs

    #Data directory
    HDP_DATA_DIR=c:\hdp\data

    #Hosts
    NAMENODE_HOST=HDP-NameNode1.domain.com
    SECONDARY_NAMENODE_HOST=HDP-NameNode1.domain.com
    JOBTRACKER_HOST=HDP-NameNode1.domain.com
    HIVE_SERVER_HOST=HDP-NameNode1.domain.com
    OOZIE_SERVER_HOST=HDP-NameNode1.domain.com
    TEMPLETON_HOST=HDP-NameNode1.domain.com
    SLAVE_HOSTS=HDP-DataNode1.domain.com, HDP-DataNode2.domain.com

    #Database host
    DB_FLAVOR=derby
    DB_HOSTNAME=HDP-NameNode1.domain.com

    #Hive properties
    HIVE_DB_NAME=hive
    HIVE_DB_USERNAME=hive
    HIVE_DB_PASSWORD=hive

    #Oozie properties
    OOZIE_DB_NAME=oozie
    OOZIE_DB_USERNAME=oozie
    OOZIE_DB_PASSWORD=oozie

    Collapse
    #18171

    Anthony Mattas
    Participant

    Well that’s the limit of the logs, I’ve tried to do some debugging of the PowerShell scripts. So that’s the extent of the error. I’ll post some more detail in the next few posts that hopefully will help.

    Collapse
    #18169

    Seth Lyubich
    Keymaster

    Hi Anthony,

    Thank you for trying HDP.

    Can you please let us know if you have more logs? Also, can you let us know how you configured your name resolution – are you using DNS, or hosts file? If you are using hosts file can you please make sure that you are using FQDN for all nodes in the cluster and that nodes resolve to correct IPv4 address?

    Hope this helps,

    Thanks,
    Seth

    Collapse
Viewing 4 replies - 1 through 4 (of 4 total)