Home Forums HBase Change for zookeeper.znode.parent

This topic contains 6 replies, has 5 voices, and was last updated by  Francois BORIE 1 year, 2 months ago.

  • Creator
    Topic
  • #27376

    Francois BORIE
    Participant

    Hello,

    It looks like you’ve changed the Hbase parameter zookeeper.znode.parent since the last release of HDP.

    While with the previous release it was set to “hbase”, now it’s configured as “hbase-unsecure”.

    Consequently, some products like OpenTSDB don’t work anymore natively with HDP because they are looking at “hbase” zkbasedir when connecting to Zookeeper
    (although, you can specify a commandline parameter to opentsdb to specify this new directory : zkbasedir)

    The problem is that it’s not possible to change that parameter in Ambari Web UI, because it’s not listed. If you try the ” Advanced tab”, Ambari complains about the fact this parameter is already set and you’re not able to erase it.

    zookeeper.znode.parent
    /hbase-unsecure

    So my question is why did you change this default value, and is there any durable way to change it again ? (if I change it manually, modifications will be lost as soon as my hbase service will be restarted with Ambari)

    Many thanks in advance, and best regards,

    François

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #33514

    Francois BORIE
    Participant

    No, I didn’t change the parameter directly in hbase-site.xml, because I use the ambari API to manage my cluster. So modifications would have been lost.

    I just used the zkbasedir parameter for opentsdb daemon, in order to make it point to /hbase-unsecure.

    Regards,

    François

    Collapse
    #33254

    Bob May
    Member

    Hello,I want to know how do you solve this problem,whether you have a try like Sasha J said”change hbase-site.xml on all needed nodes and stop/start base manually, not through the Ambari UI.”

    Collapse
    #33178

    Brent Evans
    Member

    We had the same problem. Took a while guess what was up. This isn’t good for all cases but for Opentsdb you
    can modify the default trivially after downloading. – only 1 place.
    I would like to give some feedback here. I just spent 12 hours setting up a 2 node test cluster. I see a pattern
    that repeats itself. There are lots of great features that only work if you set it up properly at the beginning = first shot
    no screwups. Configuration tools generally provide for editing everything.
    LOTS of things can’t be modified or undone. I put in the wrong host name and now I can’t finish the setup or delete it!!’
    Ambari is convinced that there are 4 hosts but really only 2. The FQDN hostname thing is also still a problem for us.
    You need somebody who has made these tools before. Just my $.02

    Collapse
    #27643

    Sasha J
    Moderator

    François,
    bug filed for fixing this and allow change through Ambari.
    In a meantime, you can do workaround like this:
    change hbase-site.xml on all needed nodes and stop/start base manually, not through the Ambari UI.
    In this case change will be preserved, and all the rest of the UI finctionality will work as expected.
    Just do non t manage HBase services from UI, to prevent reverting this parameter to default settings.

    Hope this help!
    Thank you!
    Sasha.

    Collapse
    #27629

    Francois BORIE
    Participant

    Hi Tedr,

    Thank you for answering. I think you misread my previous post.

    As I said before, the problem is that it’s not possible to change that parameter in Ambari Web UI, because it’s not listed. If you try the ” Advanced tab ”, Ambari complains about the fact this parameter is already set and you’re not able to erase it (and if I change it manually, modifications will be lost as soon as my hbase service will be restarted with Ambari)

    Regards,

    François

    Collapse
    #27626

    tedr
    Moderator

    Hi Francois,

    Why it was changed I don’t know, but you can change it by adding it as a custom property on the HBase config page in Ambari. You may have to stop HBase to save the change, and then restart it once the property change has been saved.

    Thanks,
    Ted.

    Collapse
Viewing 6 replies - 1 through 6 (of 6 total)