Home Forums HBase Class not found error…

This topic contains 3 replies, has 3 voices, and was last updated by  tedr 1 year, 4 months ago.

  • Creator
    Topic
  • #19256

    eli vani
    Member

    Hi,
    i am doing my project in hadoop(singl node).i have to run my java code which containing map,reduce fuction on hadoop.while running i got the following error…please help me to clear this….thank you…

    ERROR
    2013-03-28 13:34:40 INFO JobClient:1317 – Task Id : attempt_201303281326_0003_m_000000_2, Status : FAILED
    Error: java.lang.ClassNotFoundException: org.apache.hadoop.hbase.HBaseConfiguration
    at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
    at apriori$CandidateGenMap.map(apriori.java:160)
    at apriori$CandidateGenMap.map(apriori.java:86)
    at org.apache.hadoop.mapreduce.Mapper.run(Mapper.java:144)
    at org.apache.hadoop.mapred.MapTask.runNewMapper(MapTask.java:621)
    at org.apache.hadoop.mapred.MapTask.run(MapTask.java:305)
    at org.apache.hadoop.mapred.Child.main(Child.java:170)

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #19383

    tedr
    Member

    Hi Eli,

    It looks like you used an installer other than that supplied by Hortonworks, possibly a manual installation. If you did install hadoop manually it looks like you didn’t set up your class path correctly. The reason I mention that it looks like you not using an installer that we provided is that our installers will install hadoop version 1.1 not hadoop 0.20.2. Also please try to keep you responses to a thread in that thread rather than creating a new thread for each response, it makes it difficult to get the history of your issue having to read through different threads.

    Thanks,
    Ted.

    Collapse
    #19379

    eli vani
    Member

    i installed hadoop 0.20.2….ya i was added some jar …after adding jar that error is cleared….but i am having the following error…the hadoop nodes itself not started….

    Collapse
    #19293

    Larry Liu
    Moderator

    Hi, Eli

    What version of HDP are you using? Can you please also provide your source code?

    This error is caused by missing jar in your classpath.

    Thanks
    Larry

    Collapse
Viewing 3 replies - 1 through 3 (of 3 total)