Home Forums HDP on Linux – Installation Cluster Deployment Fails

This topic contains 4 replies, has 2 voices, and was last updated by  Sasha J 2 years, 3 months ago.

  • Creator
    Topic
  • #8172

    After selecting the required services and moving ahead, cluster installation is failing during the deployment process.
    As suggested in another thread, I did pre-installation of all required services in both the machines of my cluster (running on CentOS 6.2). Gone through all steps in HMC console till the last step of cluster deployment. The deployment process fails at the second sub-step. The first sub-step “cluster install” is successful but fails at the second sub-step – HDFS start.
    Logs says that puppet kick failed in the second machine and inside /var/log/puppet_agent.log I see the below message –
    Puppet (err): Could not send report: SSL_connect returned=1 errno=0 state=SSLv3 read server certificate B: certificate verify failed. This is often because the time is out of sync on the server or client

    Please guide.

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #8208
    Collapse
    #8206

    Sasha J
    Moderator

    This still may be related to SSL certificates problem. May also be related to hosts naming resolution.
    Make sure all names are resolved correctly, as stated in our installation document.
    then do:

    yum -y erase hmc puppet
    yum -y install hmc
    service hmc start

    then connect to UI ind rerun installation.
    If still failed, use check script in sticky and upload results.

    Thank you!
    Sacha

    Collapse
    #8198

    Tried but problem persists. Earlier it failed at HDFS start step and this time it failed at cluster installation step itself. Error log shows that puppet kick failed in both the machines.

    [root@master ~]# selinuxenabled && echo enabled || echo disabled
    disabled
    [root@master ~]# service iptables status
    iptables: Firewall is not running.
    [root@master ~]# service ip6tables status
    ip6tables: Firewall is not running.

    [root@slave ~]# selinuxenabled && echo enabled || echo disabled
    disabled
    [root@slave ~]# service iptables status
    iptables: Firewall is not running.
    [root@slave ~]# service ip6tables status
    ip6tables: Firewall is not running.

    Collapse
    #8176

    Sasha J
    Moderator

    Check your network, make sure you do not have any firewall/SELinux running.
    Error clearly shows puppet communication problems.
    deinstall hmc and puppet, then install hmc back and rerun installation.

    Thank you!
    Sasha

    Collapse
Viewing 4 replies - 1 through 4 (of 4 total)