Home Forums Ambari Cluster installation failing

This topic contains 9 replies, has 3 voices, and was last updated by  Anup Ash 2 months, 1 week ago.

  • Creator
    Topic
  • #57061

    Anup Ash
    Participant

    Hi,

    I created a cent os 6.5 ambari server and 2 other slaves. I have added the necessary hosts. I gave the SSH key which i copied from the registered root to the local user so that ambari server can use it. when i try to register the slaves,
    it fails with below message

    STDOUT

    STDERR
    Permission denied (publickey,gssapi-keyex,gssapi-with-mic,password).
    lost connection

    option 2, i have registered the ambari agent manually and then tried it but again it fails saying cannot register with the server.

    I tried by recreating the keys + switching the fire walls off but does not help

Viewing 9 replies - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #57118

    Anup Ash
    Participant

    Collapse
    #57117

    Anup Ash
    Participant

    file:///home/anup/Desktop/Screenshot.png

    The process never exceeds its stuck over this itself

    Collapse
    #57113

    Jeff Sposetti
    Moderator

    to confirm:

    1) are you using Ambari 1.6.0? If not, can you upgrade / start there?
    2) What happened on Step 9, did a specific component fail to install? anything you can share from the ui log output? or maybe a screen shot?
    3) any JavaScript errors you can see in the browser?

    Collapse
    #57108

    Anup Ash
    Participant

    Thank you jeff.. I was able to configure but the step 9 of installing the components never worked.. it gives like trying to connect.. Refresh.. but it took longer time and did not work either. What to do

    Collapse
    #57072

    Anup Ash
    Participant

    Sure Jeff, I will try this..

    Ramesh, I am actually trying to set up a psuedo cluster, I have a single machine and allocate 4 gb to master and 2 to slave.. DNS is configured. I changed the hosts files with master and slave names.. I think this is what you want to know. I am not sure where to go now.. to resolve this.. Appreciate your help

    Collapse
    #57070

    Jeff Sposetti
    Moderator

    If you are having trouble with SSH in your environment, you could try manually registering the agents.

    http://docs.hortonworks.com/HDPDocuments/Ambari-1.6.0.0/bk_ambari_reference/content/ambari-chap6-1.html

    Also, what version of Ambari are you using? The latest release is Ambari 1.6.0.

    ambari-server –version

    Collapse
    #57065

    Ramesh Babu
    Participant

    how many nodes of cluster ? is iptables enabled ?
    dns is configured ? why its reffering localhost ?
    what are host names you are providing while registration?

    Collapse
    #57063

    Anup Ash
    Participant

    Thanks Ramesh
    I provided full permision but i missed to copy it to host. which i did manually but the new error came
    ==============================================================
    ‘, None)
    (‘INFO 2014-07-09 22:29:12,674 NetUtil.py:58 – Failed to connect to https://localhost:8440/cert/ca due to [Errno 111] Connection refused
    INFO 2014-07-09 22:29:12,674 NetUtil.py:77 – Server at https://localhost:8440 is not reachable, sleeping for 10 seconds…
    INFO 2014-07-09 22:29:22,675 NetUtil.py:44 – DEBUG:: Connecting to the following url https://localhost:8440/cert/ca
    INFO 2014-07-09 22:29:22,677 NetUtil.py:58 – Failed to connect to https://localhost:8440/cert/ca due to [Errno 111] Connection refused
    INFO 2014-07-09 22:29:22,678 NetUtil.py:77 – Server at https://localhost:8440 is not reachable, sleeping for 10 seconds…
    INFO 2014-07-09 22:29:32,689 NetUtil.py:44 – DEBUG:: Connecting to the following url https://localhost:8440/cert/ca
    INFO 2014-07-09 22:29:32,690 NetUtil.py:58 – Failed to connect to https://localhost:8440/cert/ca due to [Errno 111] Connection refused
    INFO 2014-07-09 22:29:32,690 NetUtil.py:77 – Server at https://localhost:8440 is not reachable, sleeping for 10 seconds…
    INFO 2014-07-09 22:29:42,701 NetUtil.py:44 – DEBUG:: Connecting to the following url https://localhost:8440/cert/ca
    INFO 2014-07-09 22:29:42,704 NetUtil.py:58 – Failed to connect to https://localhost:8440/cert/ca due to [Errno 111] Connection refused
    INFO 2014-07-09 22:29:42,705 NetUtil.py:77 – Server at https://localhost:8440 is not reachable, sleeping for 10 seconds…
    INFO 2014-07-09 22:29:52,717 NetUtil.py:44 – DEBUG:: Connecting to the following url https://localhost:8440/cert/ca
    INFO 2014-07-09 22:29:52,718 NetUtil.py:58 – Failed to connect to https://localhost:8440/cert/ca due to [Errno 111] Connection refused
    INFO 2014-07-09 22:29:52,718 NetUtil.py:77 – Server at https://localhost:8440 is not reachable, sleeping for 10 seconds…
    INFO 2014-07-09 22:30:02,729 NetUtil.py:44 – DEBUG:: Connecting to the following url https://localhost:8440/cert/ca
    INFO 2014-07-09 22:30:02,730 NetUtil.py:58 – Failed to connect to https://localhost:8440/cert/ca due to [Errno 111] Connection refused
    INFO 2014-07-09 22:30:02,730 NetUtil.py:77 – Server at https://localhost:8440 is not reachable, sleeping for 10 seconds…
    INFO 2014-07-09 22:30:12,736 NetUtil.py:44 – DEBUG:: Connecting to the following url https://localhost:8440/cert/ca
    INFO 2014-07-09 22:30:12,766 NetUtil.py:58 – Failed to connect to https://localhost:8440/cert/ca due to [Errno 111] Connection refused
    INFO 2014-07-09 22:30:12,766 NetUtil.py:77 – Server at https://localhost:8440 is not reachable, sleeping for 10 seconds…
    ‘, None)

    Collapse
    #57062

    Ramesh Babu
    Participant

    its bacause of id_rsa permissions. check the file permissions of id_rsa.

    Collapse
Viewing 9 replies - 1 through 9 (of 9 total)