Home Forums HDP on Linux – Installation Confirm Hosts failed

Tagged: 

This topic contains 5 replies, has 4 voices, and was last updated by  Seth Lyubich 1 year, 6 months ago.

  • Creator
    Topic
  • #22835

    lara jlk
    Member

    Hello, I have a problem installing the HDP, in the step 3 in the “Confirm Hosts” window I recieve “Failed” in the status of every host that I have. This is the log:

    10:25:39,997 INFO BootStrapImpl:97 – BootStrapping hosts localhost:192.168.198.96:192.168.198.97:
    INFO BSRunner:166 – Host= localhost,192.168.198.96,192.168.198.97 bs=/usr/lib/python2.6/site-packages/ambari_server/bootstrap.py requestDir=/var/run/ambari-server/bootstrap/15 keyfile=/var/run/ambari-server/bootstrap/15/sshKey server=hdp01
    INFO BSRunner:196 – Kicking off the scheduler for polling on logs in /var/run/ambari-server/bootstrap/15
    INFO BSHostStatusCollector:55 – Request directory /var/run/ambari-server/bootstrap/15
    INFO BSRunner:200 – Bootstrap output, log=/var/run/ambari-server/bootstrap/15/bootstrap.err /var/run/ambari-server/bootstrap/15/bootstrap.out
    INFO BSHostStatusCollector:62 – HostList for polling on [localhost, 192.168.198.96, 192.168.198.97]
    INFO BSRunner:212 – Script log Mesg

    INFO:root:BootStrapping hosts ['localhost', '192.168.198.96', '192.168.198.97']using /usr/lib/python2.6/site-packages/ambari_server with sshKey File /var/run/ambari-server/bootstrap/15/sshKey using tmp dir /var/run/ambari-server/bootstrap/15 ambari: hdp01
    INFO:root:Running scp command scp -o ConnectTimeout=60 -o BatchMode=yes -o StrictHostKeyChecking=no -i /var/run/ambari-server/bootstrap/15/sshKey /etc/yum.repos.d/ambari.repo root@localhost:/etc/yum.repos.d
    INFO:root:Running scp command scp -o ConnectTimeout=60 -o BatchMode=yes -o StrictHostKeyChecking=no -i /var/run/ambari-server/bootstrap/15/sshKey /etc/yum.repos.d/ambari.repo root@192.168.198.96:/etc/yum.repos.d
    INFO:root:Running scp command scp -o ConnectTimeout=60 -o BatchMode=yes -o StrictHostKeyChecking=no -i /var/run/ambari-server/bootstrap/15/sshKey /etc/yum.repos.d/ambari.repo root@192.168.198.97:/etc/yum.repos.d
    INFO:root:scp /etc/yum.repos.d/ambari.repo done for host 192.168.198.96, exitcode=1
    INFO:root:scp /etc/yum.repos.d/ambari.repo done for host 192.168.198.97, exitcode=1
    INFO:root:scp /etc/yum.repos.d/ambari.repo done for host localhost, exitcode=1
    INFO:root:Parallel scp returns for repo file. Failed hosts are: ['192.168.198.96', '192.168.198.97', 'localhost']
    INFO:root:Parallel scp returns for agent script. All failed hosts are: ['192.168.198.96', '192.168.198.97', 'localhost']. Failed on last step: []
    INFO:root:Copying files finished
    INFO:root:Running setup agent…
    INFO:root:Parallel ssh returns for setup agent. All failed hosts are: ['192.168.198.96', '192.168.198.97', 'localhost']. Failed on last step: []
    INFO:root:Running ssh command finished

    INFO BSHostStatusCollector:55 – Request directory /var/run/ambari-server/bootstrap/15
    INFO BSHostStatusCollector:62 – HostList for polling on [localhost, 192.168.198.96, 192.168.198.97]
    INFO QueryImpl:130 – Executing resource query: {Host=null}
    INFO ClusterControllerImpl:92 – Using resource provider org.apache.ambari.server.controller.internal.HostResource

    Thanks in advance.

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #23450

    Seth Lyubich
    Keymaster

    Hi Lara,

    I think if you are setting up hostname as ‘local’, you also should add it in the /etc/hosts file and make it resolves correctly (not localhost IP 127.0.01). Per your /etc/host file you can try set hostname to hdp01 and try to use non-localhost IP.

    Something like below could work:

    hostaname
    hdp01

    hostname -f
    hdp01

    cat /etc/hosts
    #remove local from first line
    127.0.0.1 localhost.localdomain localhost
    192.198.168.91 hdp01

    Hope this helps.

    Thanks,
    Seth

    Collapse
    #23400

    lara jlk
    Member

    Hi,

    I am trying install a single-node version. In the last reply (April 24, 2013 at 2:04 am) I pasted the results in the log.

    I have checked out the command scp and it works properly:
    scp -o ConnectTimeout=60 -o BatchMode=yes -o StrictHostKeyChecking=no -i /var/run/ambari-server/bootstrap/5/sshKey /etc/yum.repos.d/ambari.repo root@local:/etc/yum.repos.d

    I have setup passwordless in the host. If I run ‘ssh root@my_ip’ it connect without querying any password.

    ‘hostname -f’ and ‘hostname’, both of them return ‘local’ as I configured in /etc/sysconfig/network.

    The failure seems to be in “Parallel scp returns for repo file. Failed hosts are: ['local']“. ‘local’ is my machine. Then I don’t know if this is another problem => “QueryImpl:130 – Executing resource query: {Host=null}”. Shouldn’t the host be ‘local’?

    Thanks,

    Lara.

    Collapse
    #23164

    Larry Liu
    Moderator

    Hi, Lara

    The error said ‘ Failed hosts are: ['local']‘ at scp. I am wondering if you have setup passwordless on your host. Look like you have 2 nodes. Failed hosts are: ['192.168.198.96', '192.168.198.97', 'localhost']

    Another thing to check on both hosts:
    hostname -f
    hostname
    The output for above command should be identical.

    Hope this helps.
    Larry

    Collapse
    #23160

    lara jlk
    Member

    Hi,

    Thanks for your response,

    I still have the same problem, I tried out with only one node, using the same machine where ambari-server is installed. I am using a Proxy.

    ‘hostname -f’ command returns ‘local’
    My /etc/host file:
    127.0.0.1 localhost.localdomain localhost local
    192.198.168.91 hdp01

    INFO BootStrapImpl:97 – BootStrapping hosts local:
    INFO BSRunner:166 – Host= local bs=/usr/lib/python2.6/site-packages/ambari_server/bootstrap.py requestDir=/var/run/ambari-server/bootstrap/5 keyfile=/var/run/ambari-server/bootstrap/5/sshKey server=local
    INFO BSRunner:196 – Kicking off the scheduler for polling on logs in /var/run/ambari-server/bootstrap/5
    INFO BSRunner:200 – Bootstrap output, log=/var/run/ambari-server/bootstrap/5/bootstrap.err /var/run/ambari-server/bootstrap/5/bootstrap.out
    INFO BSHostStatusCollector:55 – Request directory /var/run/ambari-server/bootstrap/5
    INFO BSHostStatusCollector:62 – HostList for polling on [local]
    INFO BSRunner:212 – Script log Mesg

    INFO:root:BootStrapping hosts ['local']using /usr/lib/python2.6/site-packages/ambari_server with sshKey File /var/run/ambari-server/bootstrap/5/sshKey using tmp dir /var/run/ambari-server/bootstrap/5 ambari: local
    INFO:root:Running scp command scp -o ConnectTimeout=60 -o BatchMode=yes -o StrictHostKeyChecking=no -i /var/run/ambari-server/bootstrap/5/sshKey /etc/yum.repos.d/ambari.repo root@local:/etc/yum.repos.d
    INFO:root:scp /etc/yum.repos.d/ambari.repo done for host local, exitcode=1
    INFO:root:Parallel scp returns for repo file. Failed hosts are: ['local']
    INFO:root:Parallel scp returns for agent script. All failed hosts are: ['local']. Failed on last step: []
    INFO:root:Copying files finished
    INFO:root:Running setup agent…
    INFO:root:Parallel ssh returns for setup agent. All failed hosts are: ['local']. Failed on last step: []
    INFO:root:Running ssh command finished

    INFO BSHostStatusCollector:55 – Request directory /var/run/ambari-server/bootstrap/5
    INFO BSHostStatusCollector:62 – HostList for polling on [local]
    INFO QueryImpl:130 – Executing resource query: {Host=null}
    INFO ClusterControllerImpl:92 – Using resource provider org.apache.ambari.server.controller.internal.HostResourceProvider for request type Host
    INFO QueryImpl:130 – Executing resource query: {Host=null}
    INFO ClusterControllerImpl:92 – Using resource provider org.apache.ambari.server.controller.internal.HostResourceProvider for request type Host

    Collapse
    #22869

    tedr
    Moderator

    Hi Lara,

    Thanks for trying Hortonworks Data Platform.

    From the log you posted it looks like your trying to use localhost and the IP addresses as the host name you are installing to. This won’t work, as you have discovered. The host names chat you should enter are what you get when you run the command ‘hostname -f’ on each of the boxes you want to use in your cluster. If the afore mentioned command yields and unknown host error, that means that the hostname hasn’t been properly added to the /etc/hosts file.

    Thanks,
    Ted.

    Collapse
Viewing 5 replies - 1 through 5 (of 5 total)