Home Forums HBase connecting hbase using java

Tagged: , ,

This topic contains 1 reply, has 2 voices, and was last updated by  tedr 1 year, 5 months ago.

  • Creator
    Topic
  • #19685

    Hi all

    I am using hadoop-1.1.2 and hbase-0.94.6 in pseudo distributed mode on ubuntu 12.10 with openjdk7.

    I want to create a table and load data into it using java

    I tried to follow this link https://thinkasgeek.wordpress.com/2011/03/25/hbase-and-eclispe-ide-integration/
    but I am getting warning

    The constructor HBaseConfiguration() is deprecated

    you can see my imported external jar and warning at http://i.troll.ws/0f3b66a9.png

    also when I run this project as java application then I am getting option to select java application
    you can see that at http://i.troll.ws/d7340d3c.png

    I dont know what I have to select. but my java class name is sample so I am selecting sample
    then I am runtime errors

    Exception in thread “main” java.lang.
    NoClassDefFoundError: org/apache/commons/lang/ArrayUtils
    at org.apache.hadoop.hbase.HConstants.(HConstants.java:691)
    at org.apache.hadoop.hbase.HTableDescriptor.(HTableDescriptor.java:1144)
    at sample.main(sample.java:11)
    Caused by: java.lang.ClassNotFoundException: org.apache.commons.lang.ArrayUtils
    at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
    at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:423)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:356)
    … 3 more

    could you tell me where I am wrong and how to correct that warning?
    thank you

Viewing 1 replies (of 1 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #19754

    tedr
    Member

    Hi Alok,

    Thanks for your question.

    It is recommended that you move off of OpenJDK7 and install Sun/Oracle JDK1.6. There are some incompatibilities between Hadoop and JDK7 (Oracle or Open). If you still have this error after changing you java version let us know.

    Thanks,
    Ted

    Collapse
Viewing 1 replies (of 1 total)