The Hortonworks Community Connection is now live. A completely rebuilt Q&A forum, Knowledge Base, Code Hub and more, backed by the experts in the industry.

You will be redirected here in 10 seconds. If your are not redirected, click here to visit the new site.

The legacy Hortonworks Forum is now closed. You can view a read-only version of the former site by clicking here. The site will be taken offline on January 31,2016

Hortonworks Sandbox Forum

Connecting to Sanbox Problem

  • #34347

    I have a downloaded a 1.3 sandbox VM for vmware.It didn’t open up in vmware workstation and since I didn’t have any server,I used the Open Virtualization Format Tool,to convert it to a .vmx virtual machine.
    It runs successfuly.but when its is starting services.It shows an error:
    INFO ipc.Client: Retrying connect to server: sandbox/ Already tried 0 time(s); retry policy is RetryUpToMaximumCountWithFixedSleep(maxRetries=50, sleepTime=1 SECONDS)
    this error happened up to 4 times and then didn’t show up.

    After it is ready to use.It shows an ip address and says:
    To initiate your Hortonworks Sandbox session,please open a browser and enter this address in the browser’s address field:

    The ip address of my physical computer is in subnet
    and every where is said: “just enter the ip address ,shown by sandbox in browser to enter to webGUI”.
    but It doesn’t work!(since they are in different subnets!)
    what should I do?
    does it really work? 😀


  • Author
  • #34386

    I believe that “INFO ipc.Client:” warning is perfectly normal. It looks like it’s part of the normal startup process testing a connection as a service is starting up, thus the 50 retries. I might be a little off on the reason, but I get the exact same message (usually 5-6 times) and my sandbox works fine.

    For me, my IP subnet is and my sandbox is This works fine for me though, despite being on different subnets. I’m using VMWare and it looks like it creates 2 virtual network adapters. If I start command prompt and do “IPCONFIG /all” there is a VMnet1 and VMnet8.

    Maybe start by seeing if these virtual adapters were created on your physical machine. Without a virtual adapter, I can’t imagine how it would create a network connection to begin with. If those are there it may give you more insight into whats going on. My VMnet8 lists an IP address of so if I knew my VM box was somewhere in the 253 subnet, I could use an IP tool or make a quick script to ping all 255 IP addresses there and output the results. If one of them pings good you’ve found it.

    Another option is, once you log into the sandbox, run “ifconfig -a” which should tell you what network adapters are running (linux ipconfig /all equivalent). This should give you the ip address of your box on the second line, right after “inet addr:”. So you can double check that what the main sandbox screen is telling you is correct.


    hi Michael!
    You’re right! the problem was with the network adapters!
    I had disabled the network adapter of vmware(VMnet 8) for a while,but I had forgot to enable it again.
    I enabled it,and then It worked fine 😉


    I can’t count the number of times I’ve done something similar and it’s driven me nuts for days! Glad you found it and it was an easy fix.

The forum ‘Hortonworks Sandbox’ is closed to new topics and replies.

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.