Hortonworks Sandbox Forum

Connecting with HareDB Hbase client

  • #29221
    Calin M


    Im trying to connect to the sandbox with HareDB Hbase client. I’m trying to figure out the connection parameters, because it keeps saying “connection failed”

    Zookeeper Client Port: 2181
    fs.default.name: hdfs://sandbox:8020
    mapred.job.tracker: hdfs://sandbox:50300

    I got these by grepping through the config files, but they don’t work:

    The log file on the client says:

    “10:08:43 INFO org.apache.zookeeper.ZooKeeper: Initiating client connection, connectString=sandbox:2181 sessionTimeout=180000 watcher=hconnection
    “10:08:43 INFO org.apache.zookeeper.ClientCnxn: Opening socket connection to server /
    “10:08:43 INFO che.zookeeper.client.ZooKeeperSaslClient: Client will not SASL-authenticate because the default JAAS configuration section ‘Client’ could not be found. If you are not using SASL, you may ignore this. On the other hand, if you expected SASL to work, please fix your JAAS configuration.
    “10:08:43 INFO oop.hbase.zookeeper.RecoverableZooKeeper: The identifier of this process is 7560@THELAPTOP
    “10:08:43 INFO org.apache.zookeeper.ClientCnxn: Socket connection established to sandbox/, initiating session
    “10:08:43 INFO org.apache.zookeeper.ClientCnxn: Session establishment complete on server sandbox/, sessionid = 0x13fb1373d8101a8, negotiated timeout = 40000
    “10:08:43 ERROR nectionManager$HConnectionImplementation: Check the value configured in ‘zookeeper.znode.parent’. There could be a mismatch with the one configured in the master.

    Any suggestions?


to create new topics or reply. | New User Registration

  • Author
  • #29405
    Calin M

    I also tried connecting with another client (Hbase manager http://sourceforge.net/projects/hbasemanagergui/ ) and I get the same error:

    Exception in thread “AWT-EventQueue-0” java.lang.IllegalArgumentException: Check
    the value configured in ‘zookeeper.znode.parent’. There could be a mismatch wit
    h the one configured in the master.

    Any idea what this is? Is it possible to connect to the sandbox with a client such as http://sourceforge.net/projects/hbasemanagergui/




    Hi Calin,

    Are you trying to connect to HBase on the Sandbox from your host computer? If so what is the OS of your host computer? (so that I can more accurately help you)


    Calin M

    Yes, I’m trying to connect to the sandbox running in vmware workstation from my Windows 7 host. Network connectivity is fine (I can use the web access from my host computer and all the links work OK). I had no trouble doing the tutorial exercises.

    Thanks for looking into this!


    Calin M

    Since I get the same error for both third party clients, I’m thinking there’s something misconfigured in the sandbox, right?



    Hi Calin,

    Ok, I’ve got this to work. Here’s what you need to do:

    1- make sure that when you run a ‘ping sandbox’ on your host computer you get an ip addfress – you may need to modify your /etc/hosts file to get this part working
    2 – disable ipv6 on the sandbox:
        a – log into the sandbox vm either directly in the vm or via ssh
        b – edit the file /etc/sysctl.conf – append the following lines:
            net.ipv6.conf.all.disable_ipv6 = 1
            net.ipv6.conf.default.disable_ipv6 = 1
        c – save the file
    3 – edit the ‘hbase-site.xml’ file in /etc/hadoop/conf
        change the value of the property ‘zookeeper.znode.parent from ‘/hbase-unsecure’ to ‘/hbase’ and save the config file
    4 – restart the sandbox
    5 – set the connection in hareDB HBase client exactly like you have previously and hit test.

    I found in digging around that by default zookeeper client will listen on ipv6 if such is available, so it needs to be disabled. Also found that the zookeeper.znode.parent should point to the directory that is the base of the hbase file storage in hdfs, currently the sandbox has this set to ‘hbase-unsecure,’ which doesn’t exist.

    Happy HBase’ing :)

    Calin M

    It works now. The ipv6 one was a pretty obscure one to figure out, thanks a lot!



    Hi Calin,

    How I caught that was with a ‘netstat’. I noticed that prot 2181 was listening on :::8121 so that meant it was on ipv6 and could not find any thing in the zookeeper config files to set the ip it was supposed to be listening on. So I disabled it and tested again.

    Anyway thanks for letting us know that you are up and running now.


You must be to reply to this topic. | Create Account

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.