Home Forums Oozie Could not perform authorization operation

This topic contains 1 reply, has 2 voices, and was last updated by  Jakub Stransky 4 months, 1 week ago.

  • Creator
    Topic
  • #55252

    Patrick Alexander
    Participant

    Hi Friends,
    I’m not able to run any oosie job on my cluster, getting this:

    Error submitting workflow a1 – admin
    E0501: Could not perform authorization operation, User: oozie is not allowed to impersonate admin

    I also modified and added the following, but still no lick.

    sudo vim ./etc/hadoop/conf.empty/core-site.xml

    <property>
    <name>hadoop.proxyuser.oozie.groups</name>
    <value>*</value>
    </property>
    <property>
    <name>hadoop.proxyuser.oozie.hosts</name>
    <value>*</value>
    </property>

    sudo vim ./etc/oozie/conf.dist/oozie-site.xml

    <property>
    <name>oozie.service.ProxyUserService.proxyuser.oozie.hosts</name>
    <value>*</value>
    </property>

    <property>
    <name>oozie.service.ProxyUserService.proxyuser.oozie.groups</name>
    <value>*</value>
    </property>

    any idea how to fix ?

    Thanks in advance,
    Patrick

Viewing 1 replies (of 1 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #55724

    Jakub Stransky
    Participant

    Hi Patrick,

    I am not sure about wildcard char here. For classic settings:
    </property>
    <property>
    <name>hadoop.proxyuser.oozie.groups</name>
    <value>users</value>
    </property>

    And making sure that my submit user is a member of users group this works fine

    Collapse
Viewing 1 replies (of 1 total)