Datanodes not recognized after Ambari upgrade

to create new topics or reply. | New User Registration

This topic contains 4 replies, has 2 voices, and was last updated by  tedr 2 years, 1 month ago.

  • Creator
  • #26899

    We did an upgrade of our Ambari installation from version 1.2.0 to For the upgrade we follwed the instructions according to the manual

    The upgrade went fine and also the agent upgrade didn’t give any errors. When we log in into the console we see that all the services are up and running. The only thing we don’t see is hostnames. In the host section no hosts are listed. And also in the services section no hostnames are listed (NameNode, JobTracker, Hbase Master) everything is empty. When I click the link to go the namenode UI I get redirected to http://null:50070

    We checked the server logs and we do find some messages:

    Ambari-server log:
    09:49:22,033 WARN ServletHandler:514 – /api/v1/clusters/poc_adm/hosts/null/host_components/NAMENODE
    09:50:22,111 ERROR ReadHandler:82 – Caught a runtime exception executing a query

    We do see heartbeats from the datanodes coming into the log.

Viewing 4 replies - 1 through 4 (of 4 total)

You must be to reply to this topic. | Create Account

  • Author
  • #26926


    Hi Maik,

    Good to hear that you found the cause! Yeah, the error seems a bit strange as it misdirects you as to where to look for the config file.



    We solved it. The config of the ambari-agent running on the masternode wasn’t copied from to conf.

    Renaming it back to conf and starting the ambari-agent solved the problem (although the errors still seem strange)….



    We did some further investigating today. The agent on the master node refuses to start. When starting it fails with the follwing message:

    INFO 2013-06-04 18:38:33,211 – loglevel=logging.INFO
    WARNING 2013-06-04 18:38:33,211 – No config found, use default
    ERROR 2013-06-04 18:38:33,211 – Ambari prefix dir /tmp/ambari-agent does not exists, can’t continue

    When I check the postgres repository and query the hoststate table I see the following:

    ambari=> select * from hoststate;
    agent_version | available_mem | current_state | health_status | host_name | time_in_state
    {“version”:”1.3.0″} | 14879293 | INIT | {“healthStatus”:”HEALTHY”,”healthReport”:””} | had-03 | 1370352440205
    {“version”:”1.3.0″} | 14963179 | INIT | {“healthStatus”:”HEALTHY”,”healthReport”:””} | had-02 | 1370352453793
    {“version”:”1.3.0″} | 15288238 | INIT | {“healthStatus”:”HEALTHY”,”healthReport”:””} | had-04 | 1370352466228
    {“version”:”v1″} | 65137541 | INIT | {“healthStatus”:”UNKNOWN”,”healthReport”:””} | had-01 | 1370277913654



    Hi Maik,

    This is a strange bit. I’ll have to try and replicate it, to see if I can figure out how to recover from it.
    Will keep you posted on my progress.


Viewing 4 replies - 1 through 4 (of 4 total)
Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.