Home Forums HDP on Linux – Installation Dependency Issues with HDP 1.3.3

This topic contains 2 replies, has 2 voices, and was last updated by  Ray Roberts 2 weeks, 3 days ago.

  • Creator
    Topic
  • #56148

    Ray Roberts
    Participant

    I’m noticing the following yum errors when running yum update on a CentOS 6.5 box, where Ambari Server is installed:

    Error: Package: rrdtool-1.4.5-4.5.1.x86_64 (HDP-UTILS-1.1.0.16)
    Requires: dejavu
    Error: Package: yum-metadata-parser-1.1.2-119.6.x86_64 (HDP-UTILS-1.1.0.16)
    Requires: python = 2.6
    Installed: python-2.6.6-52.el6.x86_64 (@centos6_updates_x86_64)
    python = 2.6.6-52.el6
    Available: python-2.6.6-36.el6.i686 (centos6_base_x86_64)
    python = 2.6.6-36.el6
    Available: python-2.6.6-37.el6_4.i686 (centos6_updates_x86_64)
    python = 2.6.6-37.el6_4
    Available: python-2.6.6-51.el6.x86_64 (base)
    python = 2.6.6-51.el6
    Error: Package: rrdtool-1.4.5-4.5.1.x86_64 (HDP-UTILS-1.1.0.16)
    Requires: perl = 5.10.0
    Installed: 4:perl-5.10.1-136.el6.x86_64 (@base)
    perl = 4:5.10.1-136.el6
    Available: 4:perl-5.10.1-129.el6.x86_64 (centos6_base_x86_64)
    perl = 4:5.10.1-129.el6
    Available: 4:perl-5.10.1-130.el6_4.x86_64 (centos6_updates_x86_64)
    perl = 4:5.10.1-130.el6_4
    Available: 4:perl-5.10.1-131.el6_4.x86_64 (centos6_updates_x86_64)
    perl = 4:5.10.1-131.el6_4
    Error: Package: python-rrdtool-1.4.5-4.5.1.x86_64 (HDP-UTILS-1.1.0.16)
    Requires: python = 2.6
    Installed: python-2.6.6-52.el6.x86_64 (@centos6_updates_x86_64)
    python = 2.6.6-52.el6
    Available: python-2.6.6-36.el6.i686 (centos6_base_x86_64)
    python = 2.6.6-36.el6
    Available: python-2.6.6-37.el6_4.i686 (centos6_updates_x86_64)
    python = 2.6.6-37.el6_4
    Available: python-2.6.6-51.el6.x86_64 (base)
    python = 2.6.6-51.el6
    Error: Package: rrdtool-1.4.5-4.5.1.x86_64 (HDP-UTILS-1.1.0.16)
    Requires: libxcb-xlib.so.0()(64bit)

    As you can see, I have python and perl installed, it just happens to be a newer version than what is required. That shouldn’t be a problem should it?

    As for dejavu, why isn’t that made available via the HDP-UTILS repo?

    Thoughts?

Viewing 2 replies - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #57243

    Ray Roberts
    Participant

    William,

    Thanks for your response.

    After doing some more digging, I found the problem……I copied the wrong ambari.repo file to my /etc/yum.repos.d/

    I copied the repo file for suse instead of RHEL…whoops! :)

    Thanks again for your help.

    -Ray

    Collapse
    #56155

    William Degnan
    Participant

    Probably an easy fix…your config files were not updated to match the exact names of the setvices reported in the log. They are still the generic default. Check ambari settings first as ambari owns the configs and will overwrite if you attempt to update manually. Only if you cannot locate in ambari then update manually. I don’t remember for sure with your version.
    bill

    Collapse
Viewing 2 replies - 1 through 2 (of 2 total)