Home Forums Hortonworks Sandbox Disabling Hive Server2

This topic contains 6 replies, has 5 voices, and was last updated by  Bruce Nelson 1 year, 6 months ago.

  • Creator
    Topic
  • #21243

    Ece YILDIRIM
    Member

    Hi,

    Is there a way to disable HiveServer2 in sandbox ? I have tried editing /usr/lib/hive/conf/hive-site.xml file to change hive.server2.enable.doAs to false, but this didn’t help.
    I am having issues to connect to HiveServer2 via jdbc.

    Thank you

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #24526

    Bruce Nelson
    Participant

    ODI needs to be using hiveserver v1 – for hive 0.10.0 you should have hive metastore service running even for hiveserver2 – you can start up hiveserver v1 on a different port “hive –service hiveserver -p 11000″ and set your jdbc and thrift setting in ODi accordingly. Hiveserver2 can then be just left alone. Make sure that the hiveserver is running locally to where you want to load files – local oracle user for example.

    see http://docs.hortonworks.com/CURRENT/index.htm#Appendix/Configuring_Ports/Hive_Ports.htm

    Collapse
    #21751

    Larry Liu
    Moderator

    Hi, Ece,

    Let’s take this question offline. I will send you a separate email.

    Thanks
    Larry

    Collapse
    #21735

    Ece YILDIRIM
    Member

    Hi Seth,

    Thank you. I was wondering if I have the option to disable Hive Server2 and use Hive Server1 instead.
    I can connect to Hive Server 2 (test connection on several tools) , but I can’t get the metadata, and I receive errors while trying to navigate in hcatalog. Actually what I am trying to do is to integrate ODI with HDP , but reverse engineering simply don’t work work HDP. Maybe it is assumed that hive server 1 is used.
    I get the following errors when connecting with SQuirrel.

    2013-04-15 18:03:51,172 [Thread-4] ERROR net.sourceforge.squirrel_sql.client.session.schemainfo.SchemaInfo – Error occured creating keyword collection
    java.sql.SQLException: Method not supported
    at org.apache.hive.jdbc.HiveDatabaseMetaData.getSQLKeywords(HiveDatabaseMetaData.java:512)
    at net.sourceforge.squirrel_sql.fw.sql.SQLDatabaseMetaData.getSQLKeywords(SQLDatabaseMetaData.java:1183)
    at net.sourceforge.squirrel_sql.client.session.schemainfo.SchemaInfo.loadKeywords(SchemaInfo.java:857)
    at net.sourceforge.squirrel_sql.client.session.schemainfo.SchemaInfo.privateLoadAll(SchemaInfo.java:295)
    at net.sourceforge.squirrel_sql.client.session.schemainfo.SchemaInfo.initialLoad(SchemaInfo.java:187)
    at net.sourceforge.squirrel_sql.client.session.Session$1.run(Session.java:235)
    at net.sourceforge.squirrel_sql.fw.util.TaskExecuter.run(TaskExecuter.java:82)
    at java.lang.Thread.run(Unknown Source)
    2013-04-15 18:03:51,366 [Thread-4] ERROR net.sourceforge.squirrel_sql.client.session.schemainfo.SchemaInfo – Error occured creating data types collection
    java.lang.NullPointerException
    at net.sourceforge.squirrel_sql.client.session.schemainfo.CaseInsensitiveString.(CaseInsensitiveString.java:39)
    at net.sourceforge.squirrel_sql.client.session.schemainfo.SchemaInfo.loadDataTypes(SchemaInfo.java:904)
    at net.sourceforge.squirrel_sql.client.session.schemainfo.SchemaInfo.privateLoadAll(SchemaInfo.java:315)
    at net.sourceforge.squirrel_sql.client.session.schemainfo.SchemaInfo.initialLoad(SchemaInfo.java:187)
    at net.sourceforge.squirrel_sql.client.session.Session$1.run(Session.java:235)
    at net.sourceforge.squirrel_sql.fw.util.TaskExecuter.run(TaskExecuter.java:82)
    at java.lang.Thread.run(Unknown Source)

    Collapse
    #21446

    Seth Lyubich
    Keymaster

    Hi Ece,

    HiveServer2 is required for you to connect via jdbc on port 10000. If you disable it, you will not be able to connect. There should be two Hive related processes running on the Sandbox: hive metastore on port 9083, and Hive Server 2 on port 10000. Hive Server 2 is not second instance of Hive server running, but second version of Hive Server.

    It is possible that there are some other issue like firewall, or configuration causing it not able to connect.

    Hope this is helpful.

    Thanks,
    Seth

    Collapse
    #21298

    Ece YILDIRIM
    Member

    Hi Robert,
    Thank you. I was assuming when I disable hiveserver 2 , it will statrt former hive server
    Then there is no option to switch between to, is that right?

    Collapse
    #21294

    Robert
    Participant

    Hi Ece,
    Hiveserver2 needs to be up in order to connect via jdbc/odbc. To turn off the service, I believe you would just have to kill the process. The pid for that process is located here: /var/run/hive/hive-server.pid

    Hope that helps.
    Regards,
    Robert

    Collapse
Viewing 6 replies - 1 through 6 (of 6 total)