Home Forums HDP on Linux – Installation Error installing hive and hcatalog

Tagged: ,

This topic contains 18 replies, has 2 voices, and was last updated by  tedr 1 year, 10 months ago.

  • Creator
    Topic
  • #13214

    Trang Nguyen
    Member

    Hi,

    I’ve tried many times but cannot get Hive to pass the smoke test as part of HMC installation.

    I’ve also manually installed mysql-server and mysql-client on CentOS6. The main issues I’ve had:
    1. mysql-server does not appear to install correctly on centos6.I’ve had to manually install both the server and the client.As a result, it fails the dependency test for hive.
    2. It looks like the default Hive config installed on xdc-tst-mapre-003 does not use mysql, though the installing requires a running instance of mysql:

    hive-site.xml





    javax.jdo.option.ConnectionURL
    jdbc:derby:;databaseName=/var/lib/hive/metastore/metastore_db;create=true
    JDBC connect string for a JDBC metastore

    javax.jdo.option.ConnectionDriverName
    org.apache.derby.jdbc.EmbeddedDriver
    Driver class name for a JDBC metastore

    3. On a different bo (xdc-tst-mapre-004), I tried to manually install hive following your instructions and then ran HDP install.
    However, it also fails with the following error:

    -bash: export: `\u2013service': not a valid identifier

    I’m not sure how to resolve, so I’ve given up for now unless someone can provide some clues. I’ve also ftp’d the results of the check.sh to your ftp server on Jan 4 (checkHmc_hive_failure.out).

    Thanks,
    Trang

You must be logged in to reply to this topic.