Home Forums HDP on Linux – Installation Error installing hmc

This topic contains 1 reply, has 2 voices, and was last updated by  Robert 1 year, 10 months ago.

  • Creator
    Topic
  • #13135

    Trang Nguyen
    Member

    Hello,
    I get the following error when I try to install hmc on centOs 5:
    1:rubygem-passenger-native-libs-3.0.12-1.el5.centos_1.8.5.x86_64 from HDP-UTILS-1.1.0.15 has depsolving problems
    –> Missing Dependency: ruby = 1.8.5 is needed by package 1:rubygem-passenger-native-libs-3.0.12-1.el5.centos_1.8.5.x86_64 (HDP-UTILS-1.1.0.15)
    Error: Missing Dependency: ruby = 1.8.5 is needed by package 1:rubygem-passenger-native-libs-3.0.12-1.el5.centos_1.8.5.x86_64 (HDP-UTILS-1.1.0.15)
    You could try using –skip-broken to work around the problem
    You could try running: package-cleanup –problems
    package-cleanup –dupes
    rpm -Va –nofiles –nodigest
    Here are the installed ruby packages:
    yum list | grep installed | grep ruby
    libselinux-ruby.x86_64 1.33.4-5.7.el5 installed
    ruby.x86_64 1.8.7.370-1.el5 installed
    ruby-augeas.x86_64 0.4.1-2.el5.rf installed
    ruby-devel.x86_64 1.8.7.370-1.el5 installed
    ruby-irb.x86_64 1.8.7.370-1.el5 installed
    ruby-libs.x86_64 1.8.7.370-1.el5 installed
    ruby-mode.x86_64 1.8.5-24.el5 installed
    ruby-rdoc.x86_64 1.8.7.370-1.el5 installed
    ruby-shadow.x86_64 1.4.1-7.el5 installed
    rubygem-daemon_controller.noarch 0.2.5-1 installed
    rubygem-fastthread.x86_64 1.0.7-1.el5.rf installed
    rubygem-passenger.x86_64 1:3.0.12-1.el5.centos installed
    rubygem-rack.noarch 1:1.1.0-2.el5 installed
    rubygem-rake.noarch 0.8.7-2.el5.rf installed
    rubygems.noarch 1.8.10-1.el5 installed

    I tried to uninstall ruby and all its dependencies but it gave me similar errors.
    Could you please advise?
    Thanks.

Viewing 1 replies (of 1 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #13166

    Robert
    Participant

    Hi Trang,
    I saw that you have a few threads, I assume you got passed this already since your latest issue deals with starting services and not installation of HMC?

    Regards,
    Robert

    Collapse
Viewing 1 replies (of 1 total)