The Hortonworks Community Connection is now live. A completely rebuilt Q&A forum, Knowledge Base, Code Hub and more, backed by the experts in the industry.

You will be redirected here in 10 seconds. If your are not redirected, click here to visit the new site.

The legacy Hortonworks Forum is now closed. You can view a read-only version of the former site by clicking here. The site will be taken offline on January 31,2016

HDP on Linux – Installation Forum

Error installing libganglia

  • #5988
    Mark Philpot

    The libganglia rpm that’s in the HDP repo seems to be bad or corrupted. I tried it both remote and local mirror. When I try run the yum install manually, I get the following error:

    Error unpacking rpm package libganglia-3.2.0-99.x86_64
    error: unpacking of archive failed on file /usr/lib64/lib;4fe0c11e: cpio: read

  • Author
  • #5993
    Sasha J

    Hi Mark,

    Sorry to hear you are experiencing issues. Please let us know what OS version you are installing on and whether or not you have previously registered a HDP yum repository?


    Mark Philpot

    Running Centos 5.8 (Final)

    I tried both using the hortonworks repo1 and using a local internal mirror created using the documentation. They both failed at the same spot with libganglia


    Mark Philpot

    When I try to install libganglia using the horton works repo, the error is:

    [Errno -1] Package does not match intended download

    The cpio: read error was when I used my internal repo clone



    Could you please confirm the md5sum for the libganglia that you have in your local repo?
    It should be : aa81caf7d2df34e18c9cef137f920fd3 libganglia-3.2.0-99.x86_64.rpm

    Mark Philpot

    So I tested my local repo and one I just downloaded from public-repo-1:

    local: f19391b04c7d071414b5be4ddc00217b libganglia-3.2.0-99.x86_64.rpm
    public-repo-1: b29ab3948c42f09bc846834a2d88eb23 libganglia-3.2.0-99.x86_64.rpm

    Neither match the hash above… I’ll try it with the other version to see if that works, but that really doesn’t explain why what I download from public-repo-1 is different from what you posted…

    Mark Philpot

    I recreated my local repo from scratch and I got b29ab3948c42f09bc846834a2d88eb23 for the libganglia library. When I try to install it manually (yum install libganglia) I get the following error:

    Error unpacking rpm package libganglia-3.2.0-99.x86_64
    error: unpacking of archive failed on file /usr/lib64/;4fe0ebff: cpio: read

    So it looks like f19391b04c7d071414b5be4ddc00217b and b29ab3948c42f09bc846834a2d88eb23 are bad versions on public-repo-1



    It looks like the rpm that you downloaded is corrupt. Im able to download and install the rpm from the public repo successfully.

    Could you please tell me how you are downloading the rpm?
    Also could you paste the output for ” yum list libganglia ” ?


    Mark Philpot

    I just tried re-downloading the rpm and I still get the b29xxx version. I’m wondering if there is a cache somewhere in between.

    yum list libganglia
    Available Packages
    libganglia.x86_64 3.2.0-99 HDP-

    I’ll keep trying to get it and hopefully get the correct version.




    Sorry that you are hitting this issue. Could you please try cleaning your yum cache and re-try?
    yum clean all – should help


The forum ‘HDP on Linux – Installation’ is closed to new topics and replies.

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.