Home Forums HDP on Linux – Installation Error on starting Ambari service – Installation on Laptop

This topic contains 6 replies, has 2 voices, and was last updated by  Sasha J 1 year, 5 months ago.

  • Creator
    Topic
  • #11319

    I am using CentOS 6.3. I am very new to linux and I am struggling from last two weeks to get the HDP installed on my laptop. I am following the page http://incubator.apache.org/ambari/install-0.9.html for my installation. Today I have managed to reach upto the section ‘How to run Ambari’ and I am stuck h ere. Would anyone help me in completing this installation. My objective is to review it myself before planning for a POC for my company.

    [root@black certs]# sudo service ambari start
    Starting Ambari Installer
    Starting httpd: Syntax error on line 35 of /etc/httpd/conf.d/puppetmaster.conf:
    SSLCertificateFile: file ‘/var/lib/puppet/ssl/certs/black.centos.mydsldomain.pem’ does not exist or is empty
    [FAILED]
    Failed to start Ambari

Viewing 6 replies - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #11359

    Sasha J
    Moderator

    I did not suggest to set it like this.
    I suggest to set /etc/hosts to point to the address provided to your system by your ISP and to the name provided by your ISP.

    Collapse
    #11356

    I have changed the /etc/host file as you suggested as below:

    127.0.0.1 black.centos.mydsldomain black.centos

    Currently i haven’t provided any IP address specifically anywhere.

    Collapse
    #11355

    Yes, the hostname -f command result is as like below. But how do I proceed further?

    [divya@black ~]$ hostname -f
    black.centos.MyDslDomain

    Collapse
    #11332

    Sasha J
    Moderator

    No, your fully qualified PC name is black.centos.mydsldomain.
    you should check it by “hostname -f” command.
    Many ISPs adding domain name extensions explicitly to you host name.
    And you should put something like this in your /etc/hosts file:

    x.x.x.x black.centos.mydsldomain black.centos

    where x.x.x.x is your currently provided IP address.

    Collapse
    #11330

    No. My pc name is black.centos which i have provided during the installation of CentOS. The /etc/host file have like the below:

    127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4
    ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6

    Collapse
    #11325

    Sasha J
    Moderator

    This means that your fully qualified host name is not matching your settings in the /etc/hosts file.
    your full name should be black.centos.mydsldomain, and it should be listed in your /etc/hosts file exactly.

    Collapse
Viewing 6 replies - 1 through 6 (of 6 total)