Home Forums Hue Fail to import data

This topic contains 4 replies, has 2 voices, and was last updated by  Stanley Nguyen 5 months, 2 weeks ago.

  • Creator
    Topic
  • #49600

    Stanley Nguyen
    Participant

    Hi,

    I have the latest of everything running on 3 separate machines. There’s no configuration issue when running the check from HUE and everything looks green from Ambari. When I try to import the data from HUE, the table schema is created but it does not import any data. I look @ Job Browser and there’s no error. Can anyone help point me to where I need to check?

    Thanks

    Stan

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #49846

    Stanley Nguyen
    Participant

    Hi Dave,

    It was the permission. The folder was owned by hdfs:hdfs but I logged in as hue. Once I created another account “hdfs” in hue, it works fine. It took me a while to figure out since the log I think was somewhere else. I think probably since I’m new with HDP, debugging the issue is a bit challenge. Like right now, I have an issue with Pig script got stuck in HUE but running successfully from grunt. Can’t find the error anywhere. From your professional experience, what’s the best way to debug in HDP?

    Thanks,

    Stan

    Collapse
    #49843

    Dave
    Moderator

    Hi Stanley,

    Could you let me know what the root cause for this was?
    Was it permissions or configuration?

    Thanks

    Dave

    Collapse
    #49774

    Stanley Nguyen
    Participant

    Resolved!

    Collapse
    #49731

    Stanley Nguyen
    Participant

    I found out that it works if I use Beeswax to create/import data but it fails with HCat. The weird thing is it is able to create the table schema but not to import the data. Not sure where to look for

    Collapse
Viewing 4 replies - 1 through 4 (of 4 total)