Home Forums HDP on Linux – Installation Failed to connect

This topic contains 3 replies, has 3 voices, and was last updated by  Seth Lyubich 1 year, 4 months ago.

  • Creator
    Topic
  • #30637

    Hi,
    I am trying to install hadoop (manual installation) on linux (RHEL5.5) in a single host(Both for Datanode and namenode). After completing the installation I became able to start the namenode, secondarynamenode and datanode. I have configured the file (core-site.xml,hdfs-site.xml,mapred-site.xml,taskcontroller.cfg) and placed them in the proper location. I have edited the host name and placed the hostname into the configuration file too. But when I am trying to run the smoke test by typing http://myhostname:50070 in the browser , it replies failed to connect everytimes. Please help me to sort the problem as early as possible.
    Thanx
    Marshal

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #32492

    Seth Lyubich
    Keymaster

    Hi Marshal,

    Please make sure that you setup http address property correctly in hdfs-site.xml. Please see below for example.

    [root@sandbox conf]# grep -B1 -A2 50070 hdfs-site.xml
    dfs.http.address
    sandbox:50070

    Hope this helps,

    Thanks,
    Seth

    Collapse
    #31742

    No firewall is not running on the node and I have restarted processes after changing the hostname.
    Thanx
    Marshal

    Collapse
    #30668

    Sasha J
    Moderator

    Do you have firewall running on your node?
    Also, did your restart processes after changing hostname?

    Thank you!
    Sasha

    Collapse
Viewing 3 replies - 1 through 3 (of 3 total)