Home Forums HDP on Linux – Installation Failed to connect

This topic contains 5 replies, has 3 voices, and was last updated by  Sasha J 8 months, 3 weeks ago.

  • Creator
    Topic
  • #29931

    Hi,
    After completing the installation and configuring part and starting the namenode, secondarynamenode and datanode when I am trying the smoke test using browser by typing http://myhostname:50070 every time it replies
    “Failed to Connect
    Firefox can’t establish a connection to the server at myhostname:50070
    —————————–
    —————————-”
    I would be very grateful to you if you help me to sort the problem as soon as possible.
    Thanx
    Marshal

Viewing 5 replies - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #30326

    Sasha J
    Moderator

    Marshal,
    first of all, you should have your hosts file configured on your client machine (from which you run firefox).
    You should be able to ping your hadoop box.
    Also, you should disable all firewalls on your hadoop box.
    As of passwordless ssh setup, take a look here:

    http://osxdaily.com/2012/05/25/how-to-set-up-a-password-less-ssh-login/

    Thank you!
    Sasha

    Collapse
    #30172

    Hi Ted,
    The contents of /etc/hosts file are

    # Do not remove the following line, or various programs
    #that require network functionality will fail.
    127.0.0.1 localhost
    192.168.20.116 myhostname

    and would you mind to help me how to set up passwordless ssh.

    Thanx
    Marshal

    Collapse
    #30030

    tedr
    Moderator

    HI Marshall,

    What are the contents of your /etc/hosts file? Did you make sure to set up passwordless ssh? (yes this is necessary even on a single node cluster – Hadoop uses ssh to communicate)

    thanks,
    Ted.

    Collapse
    #30008

    Hi Ted,
    Yes the namenode and datanode processes are running and this is from the manual install and HDP 1.3 on linux.
    Thanx
    Marshal

    Collapse
    #29937

    tedr
    Moderator

    Hi Marshal,

    Did you make sure that the namenode and datanode processes are still running? Is this from a manual install? Is it HDP 1.3 on linux or HDP on windows?

    Thanks,
    Ted.

    Collapse
Viewing 5 replies - 1 through 5 (of 5 total)