Home Forums Hortonworks Sandbox file upload error

This topic contains 3 replies, has 2 voices, and was last updated by  tedr 1 year, 4 months ago.

  • Creator
    Topic
  • #22622

    hello all,

    i am attempting the first tutorial, first step, ie uploading a file.

    i see the following error in the logs:

    [19/Apr/2013 14:20:14 +0000] access WARNING 192.168.56.1 sandbox – “GET /logs HTTP/1.0″
    [19/Apr/2013 14:20:13 +0000] access INFO 192.168.56.1 sandbox – “GET /debug/check_config_ajax HTTP/1.0″
    [19/Apr/2013 14:20:12 +0000] models ERROR Permission object not available. Was syncdb run after installation?
    Traceback (most recent call last):
    File “/home/sandbox/hue/apps/useradmin/src/useradmin/models.py”, line 102, in has_hue_permission
    perm = self._lookup_permission(app, action)
    File “/home/sandbox/hue/apps/useradmin/src/useradmin/models.py”, line 97, in _lookup_permission
    return HuePermission.objects.get(app=app, action=action)
    File “/home/sandbox/hue/build/env/lib/python2.6/site-packages/Django-1.2.3-py2.6.egg/django/db/models/manager.py”, line 132, in get
    return self.get_query_set().get(*args, **kwargs)
    File “/home/sandbox/hue/build/env/lib/python2.6/site-packages/Django-1.2.3-py2.6.egg/django/db/models/query.py”, line 341, in get
    % self.model._meta.object_name)
    DoesNotExist: HuePermission matching query does not exist.
    [19/Apr/2013 14:20:12 +0000] access INFO 192.168.56.1 sandbox – “GET /about/ HTTP/1.0″
    [19/Apr/2013 14:20:12 +0000] middleware DEBUG No desktop_app known for request.

    should i try to run synchdb? if so, how do i do that?

    thanks,
    delbert

Viewing 3 replies - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #22942

    tedr
    Moderator

    Hi Delbert,

    It’s good to hear that you’ve found that the file upload works in Chrome. What is your host platform? if it is Mac something that may cause IE to croak while uploading a file is the setting to automatically uncompress gzipped files. We have seen the bit with the vidoes freezing at about two minutes in, we weren’t aware yet that the problem was only seen in Chrome. I’ll add that bit of information to the bug I logged about the video issue. A work around that some folks have done for the freezing videos is to extract the videos from the Sandbox to their desktop (instruction for this can be found in other threads in this forum).

    Thanks,
    Ted.

    Collapse
    #22720

    hi Ted,

    i tried a few times last night. i restarted the vm today, from scratch and tried again. from IE, i get the same error, whether i set compatibility mode on or off. but it *does* work from Chrome. oddly enough, i started out the tutorials using Chrome, but Chrome croaks after about 1 minute of running any of the videos, where IE works just fine. i’ll bounce between browsers and i should be fine.

    thanks,
    delbert

    Collapse
    #22629

    tedr
    Moderator

    Hi Delbert,

    Hmm, I’ve not seen this one before. I’ll see if I can replicate. But I don’t think you should need to run syncdb. Have you tried uploading the file again?

    Thanks,
    Ted.

    Collapse
Viewing 3 replies - 1 through 3 (of 3 total)