Home Forums Sqoop Flume: Importing Twitter data not working

This topic contains 2 replies, has 2 voices, and was last updated by  Venkatesh Bodapati 6 months ago.

  • Creator
    Topic
  • #46930

    Venkatesh Bodapati
    Participant

    Hi I’m unable to get twitter streaming data by using flume.

    I’m getting no error messages and no twitter streaming data or tweets.
    When I run flume i’m getting the following message–

    some lines about loading api and then
    “”"”"—–org.apache.flume.node.Application -f /etc/flume/conf/flume.conf -n TwitterAgent
    2014-01-17 18:55:52,307 [lifecycleSupervisor-1-0] INFO poc.hortonworks.flume.source.twitter.TwitterSource (TwitterSource.java:124) – Setting up Twitter sample stream using consumer key {} and access token {}
    2014-01-17 18:55:52,388 [lifecycleSupervisor-1-0] INFO poc.hortonworks.flume.source.twitter.TwitterSource (TwitterSource.java:138) – Starting up Twitter filtering…..”"”"”

    I waited for 3 hours but no data recieved and then I closed.

    Steps which I followed

    Step1: Downloaded Sentiment files from following website
    “http://hortonworks.com/hadoop-tutorial/how-to-refine-and-visualize-sentiment-data/

    Step 2: unzip file
    Step3: copied flume-custom-source-1.0.0-SNAPSHOT.jar file to local in centos. This file is inside downloaded “Sentiment files”

    Step 4: I have configured log4j.properties file, setting SNAPSHOT jar file in flume path and all flume configuration properties with source as “poc.hortonworks.source.twitter.TwitterSource”
    which is provided in snapshot jar file.
    All my configurations are according to “SentimentFiles” only.

    Step5: And ran flume-ng agent –conf /etc/flume/conf/ -f /etc/flume/conf/flumetwitter.conf -Dflume.root.logger=DEBUG,console -n TwitterAgent

    And then waiting…

    Even when I keep wrong twitter credentials wrong it is not informing anything and the output is same in both cases, waiting for long period.

    I tried with different access levels of twitter app- read only, read and write

    I’m using Sandbox 1.2.
    In another case tried with source as “exec” but i need to set “command” property for it which i don’t know.

    Is there anything wrong with “TwitterSource” ? or where can I find updated twitter source?
    Is there any other things to be considered?
    please inform me.

Viewing 2 replies - 1 through 2 (of 2 total)

The topic ‘Flume: Importing Twitter data not working’ is closed to new replies.

  • Author
    Replies
  • #47632

    Venkatesh Bodapati
    Participant

    We need to synchronize time externally by NTP in Cent OS or OS installed for sandbox.
    And then working fine.

    Collapse
    #46935

    Robert Molina
    Moderator

    Hi Venkatesh,
    I will probably need to test the conf file to see if it works on my side. On your side, as a test, can you try to putting a netcat source instead of the twitter source and just test data can flow through?

    Regards,
    Robert

    Collapse
Viewing 2 replies - 1 through 2 (of 2 total)