The Hortonworks Community Connection is now live. A completely rebuilt Q&A forum, Knowledge Base, Code Hub and more, backed by the experts in the industry.

You will be redirected here in 10 seconds. If your are not redirected, click here to visit the new site.

The legacy Hortonworks Forum is now closed. You can view a read-only version of the former site by clicking here. The site will be taken offline on January 31,2016

HDP on Linux – Installation Forum

ganglia-gmond-3.5.0-99 package not available

  • #37223
    Vikas Madaan
    Member

    Hi,

    I am trying to install HDP 1.3.2 I installed the amabari server using the documentation for HDP 1.3.2 installation. it went well. now i am trying to create a cluster in the ambari Web Console. Everything seems to install except Ganglia monitor. Below is the log from the web console.

    I guess the issue : Execution of ‘/usr/bin/yum -d 0 -e 0 -y install ganglia-gmond-3.5.0-99’ returned 1: Error: Nothing to do”

    has some faced a similar issue
    notice: /Stage[1]/Hdp::Snappy::Package/Hdp::Snappy::Package::Ln[32]/Hdp::Exec[hdp::snappy::package::ln 32]/Exec[hdp::snappy::package::ln 32]/returns: executed successfully
    err: /Stage[2]/Hdp-ganglia::Monitor/Hdp::Package[ganglia-monitor]/Hdp::Package::Process_pkg[ganglia-monitor]/Package[ganglia-gmond-3.5.0-99]/ensure: change from absent to present failed: Execution of ‘/usr/bin/yum -d 0 -e 0 -y install ganglia-gmond-3.5.0-99’ returned 1: Error: Nothing to do

    notice: /Stage[2]/Hdp-ganglia::Monitor/Hdp::Package[ganglia-monitor]/Hdp::Package::Process_pkg[ganglia-monitor]/Anchor[hdp::package::ganglia-monitor::end]: Dependency Package[ganglia-gmond-3.5.0-99] has failures: true
    warning: /Stage[2]/Hdp-ganglia::Monitor/Hdp::Package[ganglia-monitor]/Hdp::Package::Process_pkg[ganglia-monitor]/Anchor[hdp::package::ganglia-monitor::end]: Skipping because of failed dependencies
    notice: /Stage[2]/Hdp-ganglia::Monitor/Hdp::Package[ganglia-gmond-modules-python]/Hdp::Package::Process_pkg[ganglia-gmond-modules-python]/Anchor[hdp::package::ganglia-gmond-modules-python::begin]: Dependency Package[ganglia-gmond-3.5.0-99] has failures: true
    warning: /Stage[2]/Hdp-ganglia::Monitor/Hdp::Package[ganglia-gmond-modules-python]/Hdp::Package::Process_pkg[ganglia-gmond-modules-python]/Anchor[hdp::package::ganglia-gmond-modules-python::begin]: Skipping because of failed dependencies
    notice: /Stage[2]/Hdp-ganglia::Monitor/Hdp::Package[ganglia-gmond-modules-python]/Hdp::Package::Process_pkg[ganglia-gmond-modules-python]/Package[ganglia-gmond-modules-python-3.5.0-99]: Dependency Package[ganglia-gmond-3.5.0-99] has failures: true
    warning: /Stage[2]/Hdp-ganglia::Monitor/Hdp::Package[ganglia-gmond-modules-python]/Hdp::Package::Process_pkg[ganglia-gmond-modules-python]/Package[ganglia-gmond-modules-python-3.5.0-99]: Skipping because of failed dependencies
    notice: /Stage[2]/Hdp-ganglia::Monitor/Hdp::Package[ganglia-gmond-modules-python]/Hdp::Package::Process_pkg[ganglia-gmond-modules-python]/Hdp::Java::Package[ganglia-gmond-modules-python]/Anchor[hdp::java::package::ganglia-gmond-modules-python::begin]: Dependency Package[ganglia-gmond-3.5.0-99] has failures: true
    warning: /Stage[2]/Hdp-ganglia::Monitor/Hdp::Package[ganglia-gmond-modules-python]/Hdp::Package::Process_pkg[ganglia-gmond-modules-python]/Hdp::Java::Package[ganglia-gmond-modules-python]/Anchor[hdp::java::package::ganglia-gmond-modules-python::begin]: Skipping because of failed dependencies

  • Author
    Replies
  • #37224
    Vikas Madaan
    Member

    below is my yum repolist

    [root@localhost zookeeper]# yum repolist
    Loaded plugins: fastestmirror, security
    Loading mirror speeds from cached hostfile
    * base: mirror.thelinuxfix.com
    * epel: mirror.seas.harvard.edu
    * extras: mirrors.liquidweb.com
    * updates: mirrors.serveraxis.net
    repo id repo name status
    AMBARI-1.x Ambari 1.x 5
    HDP-1.3.2 HDP 124
    HDP-UTILS-1.1.0.15 Hortonworks Data Platform Utils Version – HDP-UTILS-1.1.0.15 53
    base CentOS-6 – Base 6,381
    epel Extra Packages for Enterprise Linux 6 – x86_64 9,644
    extras CentOS-6 – Extras 13
    updates CentOS-6 – Updates 1,250

    #37228
    Dave
    Moderator

    Hi Vikas,

    My repolist is:

    repo id repo name status
    HDP-1.3.2 HDP 63
    HDP-1.x Hortonworks Data Platform Version – HDP-1.x 53
    HDP-UTILS-1.1.0.16 Hortonworks Data Platform Utils Version – HDP-UTILS-1. 61
    Updates-HDP-1.x HDP-1.x – Updates 124
    Updates-ambari-1.x ambari-1.x – Updates 40
    ambari-1.x Ambari 1.x 5
    base CentOS-6 – Base 6,381
    extras CentOS-6 – Extras 13
    updates CentOS-6 – Updates 1,280
    repolist: 8,020

    Also what do you get if you run:

    yum whatprovides ganglia*

    It looks like you have abad repo setup (what resides in your /etc/yum.repos.d/ directory?)

    Thanks

    Dave

    #37229
    Vikas Madaan
    Member

    how can i update it to HDP-UTILS-1.1.0.15

    [root@localhost ~]# yum whatprovides ganglia*
    Loaded plugins: fastestmirror, security
    Loading mirror speeds from cached hostfile
    epel/metalink | 14 kB 00:00
    * base: mirror.thelinuxfix.com
    * epel: mirror.seas.harvard.edu
    * extras: mirrors.liquidweb.com
    * updates: mirrors.serveraxis.net
    AMBARI-1.x | 951 B 00:00
    HDP-1.3.2 | 2.9 kB 00:00
    HDP-UTILS-1.1.0.15 | 951 B 00:00
    base | 3.7 kB 00:00
    extras | 3.4 kB 00:00
    updates | 3.4 kB 00:00
    updates/primary_db | 4.4 MB 00:06
    ganglia-gmetad-python-3.2.0-99.x86_64 : Ganglia Meta daemon in Python http://ganglia.sourceforge.net/
    Repo : HDP-UTILS-1.1.0.15
    Matched from:
    Other : ganglia-monitor-core = 3.2.0
    Other : ganglia-gmetad-python(x86-64) = 3.2.0-99
    Other : ganglia-gmetad-python = 3.2.0-99
    Other : ganglia-monitor-core-gmetad = 3.2.0
    ganglia-devel-3.2.0-99.x86_64 : Ganglia static libraries and header files http://ganglia.sourceforge.net/
    Repo : HDP-UTILS-1.1.0.15
    Matched from:
    Other : ganglia-devel = 3.2.0-99
    Other : ganglia-devel(x86-64) = 3.2.0-99
    ganglia-gmond-modules-python-3.2.0-99.x86_64 : Ganglia Monitor daemon DSO/Python metric modules support
    http://ganglia.sourceforge.net/
    Repo : HDP-UTILS-1.1.0.15
    Matched from:
    Other : ganglia-gmond-modules-python(x86-64) = 3.2.0-99
    Other : ganglia-gmond-modules-python = 3.2.0-99
    ganglia-gmond-3.2.0-99.x86_64 : Ganglia Monitor daemon http://ganglia.sourceforge.net/
    Repo : HDP-UTILS-1.1.0.15
    Matched from:
    Other : ganglia-gmond(x86-64) = 3.2.0-99
    Other : ganglia-monitor-core-gmond = 3.2.0
    Other : ganglia-gmond = 3.2.0-99
    Other : ganglia-monitor-core = 3.2.0
    ganglia-gmetad-3.2.0-99.x86_64 : Ganglia Meta daemon http://ganglia.sourceforge.net/
    Repo : HDP-UTILS-1.1.0.15
    Matched from:
    Other : ganglia-monitor-core = 3.2.0
    Other : ganglia-monitor-core-gmetad = 3.2.0
    Other : ganglia-gmetad = 3.2.0-99
    Other : ganglia-gmetad(x86-64) = 3.2.0-99
    ganglia-debuginfo-3.2.0-99.x86_64 : Debug information for package ganglia
    Repo : HDP-UTILS-1.1.0.15
    Matched from:
    Other : ganglia-debuginfo(x86-64) = 3.2.0-99
    Other

    #37230
    Vikas Madaan
    Member

    this is what i have in /etc/yum.repo.d

    [root@localhost yum.repos.d]# ls -ltra
    total 48
    -rw-r–r–. 1 root root 1056 Nov 5 2012 epel-testing.repo
    -rw-r–r–. 1 root root 957 Nov 5 2012 epel.repo
    -rw-r–r– 1 root root 3664 Feb 25 2013 CentOS-Vault.repo
    -rw-r–r– 1 root root 630 Feb 25 2013 CentOS-Media.repo
    -rw-r–r– 1 root root 638 Feb 25 2013 CentOS-Debuginfo.repo
    -rw-r–r– 1 root root 1926 Feb 25 2013 CentOS-Base.repo
    -rw-r–r–. 1 root root 539 Apr 3 20:57 ambari.repo
    -rw-r–r–. 1 root root 922 Sep 20 00:06 HDP.repo
    drwxr-xr-x. 121 root root 12288 Sep 20 07:17 ..
    drwxr-xr-x. 2 root root 4096 Sep 20 08:51 .
    [root@localhost yum.repos.d]# vi HDP.repo
    #
    #
    # Licensed to the Apache Software Foundation (ASF) under one
    # or more contributor license agreements. See the NOTICE file
    # distributed with this work for additional information
    # regarding copyright ownership. The ASF licenses this file
    # to you under the Apache License, Version 2.0 (the
    # “License”); you may not use this file except in compliance
    # with the License. You may obtain a copy of the License at
    #
    # http://www.apache.org/licenses/LICENSE-2.0
    #
    # Unless required by applicable law or agreed to in writing,
    # software distributed under the License is distributed on an
    # “AS IS” BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
    # KIND, either express or implied. See the License for the
    # specific language governing permissions and limitations
    # under the License.
    #
    #
    #
    [HDP-1.3.2]
    name=HDP
    baseurl=http://public-repo-1.hortonworks.com/HDP/centos6/1.x/updates/1.3.2.0
    path=/
    enabled=1
    gpgcheck=0

    Let me know how can i get it to update to utilities 16 instead of 15.

    #37233
    Vikas Madaan
    Member

    this is how i got my yum.repos.d

    wget http://public-
    repo-1.hortonworks.com/AMBARI-1.x/
    repos/centos6/ambari.repo

    cp ambari.repo /etc/yum.repos.d

    this was mentioned in the install document on horton works website.

    #37236
    Vikas Madaan
    Member

    These are the contect of ambari.repo

    [AMBARI-1.x]
    name=Ambari 1.x
    baseurl=http://public-repo-1.hortonworks.com/AMBARI-1.x/repos/centos6
    gpgcheck=1
    gpgkey=http://public-repo-1.hortonworks.com/AMBARI-1.x/repos/centos6/RPM-GPG-KEY/RPM-GPG-KEY-Jenkins
    enabled=1
    priority=1

    [HDP-UTILS-1.1.0.15]
    name=Hortonworks Data Platform Utils Version – HDP-UTILS-1.1.0.15
    baseurl=http://public-repo-1.hortonworks.com/HDP-UTILS-1.1.0.15/repos/centos6
    gpgcheck=0
    gpgkey=http://public-repo-1.hortonworks.com/HDP-UTILS-1.1.0.15/repos/centos6/RPM-GPG-KEY/RPM-GPG-KEY-Jenkins
    enabled=1
    priority=1

    #37239
    Dave
    Moderator

    Hi Vikas,

    It looks like you have the incorrect repo.
    The repo from the HDP 1.3.2 should be:

    wget http://public-repo-1.hortonworks.com/ambari/centos6/1.x/GA/ambari.repo

    You will need to remove your repos, clean the repos up and remove the software. If you have a snapshot I would revert back to that as it will be easier than trying to install over the top.

    Thanks

    Dave

    #37242
    Vikas Madaan
    Member

    I am able to fix it thanks.

The forum ‘HDP on Linux – Installation’ is closed to new topics and replies.

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.