Hortonworks Sandbox Forum

Ganglia metrics not visible on Ambari dashboard

  • #30362

    “I have installed Hortonworks sandbox 1.3 virtual machine +RC6 at my windows7 64 bit machine.
    All services are running fine after start of Ambari . I followed HDP guide to follow complete instructions to install and configure this virtual machine at my local.

    Problem is that I am not getting any metrics visible under any of the services like HDFS, MapReduce, HBase etc on dashboard. It’s saying that “No Data, There was no data available. Possible reasons include inaccessible Ganglia service.” I have checked that ganglia is also running perfectly and I can see the metrics for any of the service through ganglia browser but not on ambari dashboard though ambari is using ganglia internally.

    Please help me on this.

to create new topics or reply. | New User Registration

  • Author
  • #30452
    Peter Rudenko

    Try to restart VM. Ambari and ganglia should start on boot, thus metrics should be seen on ambari dashboard.


    Using the same configuration.
    When trying to use Ambari I see the following:
    1. From Dashboard tab, I see cluster metrics
    2. Under Services tab when I click HDFS, MapReduce, or HBase, the metric data shows:

    No Data There was no data available. Possible reasons include inaccessible Ganglia service.

    ..for all of the services mentioned above.

    I’ve rebooted and still the same thing :(

    If I go to http://sandbox/ganglia/ , data graphs appears to display so it seems like a problem with Ambari. (just guessing)

    Any help greatly appreciated.
    Any tips would be greatly appreciated. ,


    After re-start same problem . I am not seeing any metrics of any service on Ambari dashboard UI.
    Is there any time lag that it reflects?


    Try to restart only Ganglia services. From Ambari Web UI: Dashboard -> Ganglia -> Service Actions -> Restart All.
    I had the same problem and this worked for me.

You must be to reply to this topic. | Create Account

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.