The Hortonworks Community Connection is now live. A completely rebuilt Q&A forum, Knowledge Base, Code Hub and more, backed by the experts in the industry.

You will be redirected here in 10 seconds. If your are not redirected, click here to visit the new site.

The legacy Hortonworks Forum is now closed. You can view a read-only version of the former site by clicking here. The site will be taken offline on January 31,2016

HDP on Linux – Installation Forum

Getting a 404 after install

  • #46964
    Jim Whiteman

    Hi there –

    Just installed HDP 1.3 on a single VM; we’re working on a proof of concept at the moment – not anything that will go to production.

    After running the installer and going to port 8080 I get a 404;

    HTTP ERROR: 404

    Problem accessing /notify-Notify-Uncategorized. Reason:

    Not Found
    Powered by Jetty://

    I couldn’t see anything in the logs that suggested an error or an exception.

    Any ideas on where to start?

    Thanks –

  • Author
  • #46979
    Jeff Sposetti


    What version of Ambari are you using? “yum info ambari-server” or “ambari-server –version”? And your operating system + version?


    Jim Whiteman

    Hi Jeff –

    > yum info ambari-serverInstalled Packages
    Name : ambari-server
    Arch : noarch
    Version :
    Release : 1
    Size : 59 M
    Repo : installed
    From repo : Updates-ambari-
    Summary : Ambari Server
    License : 2012, Apache Software Foundation
    Description : Maven Recipe: RPM Package.

    > operating system + version
    CentOS release 6.4 (Final)


    Kenny Zhang

    Hi Jim,

    Could you please confirm you have run the following commands first?
    # ambari-server setup
    # ambari-server start

    If yes, can you issue the below command from the ambari-server host and share the output with us?

    # curl -u admin:admin http://<ambari-server hostname>:8080/api/v1/clusters/


    Jim Whiteman

    Hi Kenny –

    Verified that the commands you listed were run; here is the output from the curl.

    [root@ambari ~]# curl -u admin:admin http://ambari.local:8080/api/v1/clusters/
    “href” : “http://ambari.local:8080/api/v1/clusters/”,
    “items” : [ ]

    We’re trying to install everything on a single VM, just as a POC. Looks like the clusters array is completely empty. I’d guess it should have 1 item in there. Did I miss a configuration step perhaps?


    Kenny Zhang

    Hi Jim,

    This is expected. I guess you haven’t login to the Ambari WebUI once yet due to this issue, so you are not able to setup the cluster. Then the blank item filed is expected. The purpose to run the curl command from ambari-server host is to test whether ambari-server is up and running correctly. From the output result, you are able to access ambari-server at port 8080 from the localhost.

    So could you please run the exact same command from the host that you encounter the issue?
    If it returns different result, please make sure you can telnet the port 8080 from this host.


    Jim Whiteman

    Hi Kenny –

    Thanks for the clarification. I was able to curl from the host I was having trouble with. Everything looked as it should have.

    It’s a little embarrassing to say, but I think this issue was because we were trying to access the Ambari server with IE (it’s mandatory that we do our work on provided WIndows laptops, but that’s another story). When using Chrome we had no problems accessing the login screen.

    I’d consider this issue resolved at this point.

    Thanks for your patience –

    Kenny Zhang

    Thanks Jim for letting us know this is resolved. But I think Ambari-server support IE 9 and higher. Could you please confirm which version of IE you were using?


    Jim Whiteman

    The version most of us were using was IE 8.

    Oddly enough, some people on my team say they are successful logging in with IE 8 and still others can’t login with Chrome – they still get the 404.
    Maybe they are running into caching issues with their browsers or perhaps are mistaken about the version numbers they are using.

    We’ll continue forward. If we run into more errors that seem to be related, we will post them here.

    Thanks again –

    Jim Whiteman

    So this error has returned; this time it doesn’t seem to matter what browser I use.

    Oddly enough, other members of my team can still access the login screen.

    I was in initially, and then ultimately couldn’t get back. Here are the steps I took:

    #1. I logged in
    #2. I gave a name to the cluster
    #3. I chose HDP 1.3
    #4. I entered a single host along with a private key
    #5. I went to the next step to confirm the host, but it failed.
    #6. I pressed the back button all the way to the beginning.
    #7. I logged out.

    After that point, whenever I tried to go back, I got the 404. Even if I delete all cookies or tmp files, or even use a different browser, it doesn’t seem to matter.
    Perhaps there is some state being saved in the DB that is pegged to my IP? Maybe my actions broke the state machine that the wizard was using and it’s
    trying to forward me to something that’s breaking it?

    Thanks –

The forum ‘HDP on Linux – Installation’ is closed to new topics and replies.

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.