Home Forums HBase hadoo nodes are not started…

This topic contains 1 reply, has 2 voices, and was last updated by  tedr 1 year, 3 months ago.

  • Creator
    Topic
  • #19380

    eli vani
    Member

    Thank you larry…i installed hadoop 0.20.2….ya i was added some jar …after adding jar that error is cleared….but now i am having the following error…the hadoop nodes itself not started….Help me to clear this…

    hduser@ubuntu:~$ cd /usr/local/hadoop/bin/
    hduser@ubuntu:/usr/local/hadoop/bin$ start-all.sh
    starting namenode, logging to /usr/local/hadoop/bin/../logs/hadoop-hduser-namenode-ubuntu.out
    localhost: starting datanode, logging to /usr/local/hadoop/bin/../logs/hadoop-hduser-datanode-ubuntu.out
    localhost: Exception in thread “main” java.lang.NoClassDefFoundError: org/mortbay/jetty/Connector
    localhost: Caused by: java.lang.ClassNotFoundException: org.mortbay.jetty.Connector
    localhost: at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
    localhost: at java.security.AccessController.doPrivileged(Native Method)
    localhost: at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
    localhost: at sun.misc.Launcher$ExtClassLoader.findClass(Launcher.java:229)
    localhost: at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
    localhost: at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
    localhost: Could not find the main class: org.apache.hadoop.hdfs.server.datanode.DataNode. Program will exit.
    localhost: starting secondarynamenode, logging to /usr/local/hadoop/bin/../logs/hadoop-hduser-secondarynamenode-ubuntu.out
    starting jobtracker, logging to /usr/local/hadoop/bin/../logs/hadoop-hduser-jobtracker-ubuntu.out
    localhost: starting tasktracker, logging to /usr/local/hadoop/bin/../logs/hadoop-hduser-tasktracker-ubuntu.out
    hduser@ubuntu:/usr/local/hadoop/bin$ jps
    3914 Jps
    2104 SecondaryNameNode
    hduser@ubuntu:/usr/local/hadoop/bin$

Viewing 1 replies (of 1 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #19384

    tedr
    Member

    Hi Eli,

    It looks to me like this is a continuation of the following thread http://hortonworks.com/community/forums/topic/class-not-found-error-2/
    I have answered there.

    Thanks,
    Ted.

    Collapse
Viewing 1 replies (of 1 total)