Home Forums Ambari Having trouble with agent/server version mismatch

This topic contains 1 reply, has 1 voice, and was last updated by  M F 9 months, 3 weeks ago.

  • Creator
    Topic
  • #33714

    M F
    Member

    I’ve had a working ambari deployment on a longstanding Amazon EC2 cluster for about a month now. Recently I went to add new hosts to the cluster, and received the following error message in the logs:

    SEVERE: The exception contained within MappableContainerException could not be mapped to a response, re-throwing to the HTTP container
    org.apache.ambari.server.AmbariException: Cannot register host with non compatible agent version, hostname=ip-10-165-2-215.ec2.internal, agentVersion=1.2.5.17, serverVersion=1.3.0

    The unfortunate thing is no matter how hard I look I can’t seem to find a way to upgrade the agent version to 1.3.0 so that I don’t see this problem. Does anybody know where I can either find the source for compile? For instance, looking through my yum list | grep ambari I only see 1.2.5.17 versions. Updating doesn’t reveal a 1.3.0.

    Thanks in advance.

Viewing 1 replies (of 1 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #33729

    M F
    Member

    Any mod that sees this can close the topic. I figured out what’s going on:

    Looking at the /var/lib/ambari-server/data directory reveals a “version” file. This was reporting 1.3 to me on the slave nodes (ones running a DataNode and JobTracker). Given that the error above says the server version is 1.3, that matched up and made sense to me.

    It turned out that ambari-agent and ambari-server were *actually* 1.2.4.9-1, and this was revealed doing a yum list installed | grep ambari

    So once I realized this, I was able to downgrade the new node and it added to the cluster properly. This caused a new problem, but that problem is not relevant to this thread.

    Collapse
Viewing 1 replies (of 1 total)