Home Forums HBase HBASE Regions Server Warning

This topic contains 4 replies, has 2 voices, and was last updated by  tedr 1 year, 5 months ago.

  • Creator
    Topic
  • #12016

    Laurentiu
    Member

    Hi,
    While running HDP 1.1 (HDFS version, 1.0.3.16. HBASE version: 0.92.1.15)

    I am seeing this warning in my region server log files:
    2012-11-13 13:41:21,334 WARN org.apache.hadoop.hdfs.DFSClient: BlockReaderLocal: Removing blk_-3202046197278941888_18303 from cache because local file /hadoop/hdfs/data/sdi1/current/subdir14/blk_-3202046197278941888 could not be opened.
    2012-11-13 13:41:21,334 WARN org.apache.hadoop.hdfs.DFSClient: Failed to connect to /XX.XX.XX.XXX:50010 for file /apps/hbase/data/-ROOT-/70236052/info/e32228437cb341e1bba3f321e8e7a67e for block blk_-3202046197278941888_18303:java.io.FileNotFoundException: /hadoop/hdfs/data/sdi1/current/subdir14/blk_-3202046197278941888 (Permission denied)

    The ls -l command shows this:
    -rw-r—–. 1 hdfs hdfs 1107 Nov 12 14:17 /hadoop/hdfs/data/sdi1/current/subdir14/blk_-3202046197278941888

    The id command for the hbase user shows:
    uid=492(hbase) gid=491(hbase) groups=491(hbase),504(hadoop)

    The questions are: why am i seeing this warning and what can I do to make it go away ?

Viewing 4 replies - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #12068

    tedr
    Member

    Hi Laurentiu,

    Thanks for letting us know.

    Ted

    Collapse
    #12038

    Laurentiu
    Member

    Sorry Ted but just fixing the limits did not fix the issue. My issue is exactly the same as the one described on the cloudera forum: https://groups.google.com/a/cloudera.org/forum/?fromgroups=#!topic/cdh-user/R1vGqj-HQT4.
    I have changed the primary group for the hdfs user to hadoop. It seems to be fine now.

    Collapse
    #12033

    tedr
    Member

    Hi Laurentiu,

    This again looks like it is caused by http://hortonworks.com/community/forums/topic/too-many-open-files-rs-logs/
    Once that is corrected for this will probably go away.

    Ted.

    Collapse
    #12025

    Laurentiu
    Member

    Could the solution be setting dfs.datanode.data.dir.perm to 755 in hdfs-site.xml ?

    Collapse
Viewing 4 replies - 1 through 4 (of 4 total)