Home Forums Hortonworks Sandbox Hbase Root Dir

Tagged: ,

This topic contains 8 replies, has 6 voices, and was last updated by  Murali Adari 8 months, 4 weeks ago.

  • Creator
    Topic
  • #27620

    Guys, I am sorry for the stupid questions, but does anybody know where hbase-site.xml property actually points in the directory via SSH?

    hbase.rootdir
    hdfs://sandbox:8020/apps/hbase/data

    i would like to monitor that directory while i insert data into hbase table.

    Thank you.

Viewing 8 replies - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #29806

    Murali Adari
    Member

    Hi Sasha,
    Can certainly do that. The change was made because it wouldn’t work to begin with. Nonetheless I will heed your suggestion and download a fresh image. Hope that will help. Thanks for your response.

    Regards,

    Collapse
    #29779

    Sasha J
    Moderator

    Murali,
    the best you can do is download fresh copy of Sandbox and use it.
    NEVER touch anything in the sandbox configuration, it not suppose to be modified by end user.

    Thank you!
    Sasha

    Collapse
    #29746

    Murali Adari
    Member

    Hi Abdelrahman,
    Sorry for the late reply. Have been on extended vacation.. My HDFS has several log files not sure what I should be looking at. Here is a snippet of server log from the Hue Admin page :
    [21/Jul/2013 10:07:31 +0000] access WARNING 192.168.1.7 hue – “GET /logs HTTP/1.0″
    [21/Jul/2013 10:07:28 +0000] access INFO 192.168.1.7 hue – “GET /debug/check_config_ajax HTTP/1.0″
    [21/Jul/2013 10:07:27 +0000] resource DEBUG GET Got response: {“systemMode”:”NORMAL”}
    [21/Jul/2013 10:07:27 +0000] http_client DEBUG GET http://sandbox:11000/oozie/v1/admin/status?timezone=America%2FLos_Angeles&user.name=hue&doAs=hue
    [21/Jul/2013 10:07:27 +0000] http_client DEBUG GET http://sandbox:50111/templeton/v1/status?user.name=hue
    [21/Jul/2013 10:07:27 +0000] views ERROR Error in config validation by liboozie:
    Traceback (most recent call last):
    File “/usr/lib/hue/desktop/core/src/desktop/views.py”, line 338, in _get_config_errors
    error_list.extend(validator())
    File “/usr/lib/hue/desktop/libs/liboozie/src/liboozie/conf.py”, line 77, in config_validator
    message=_(‘Oozie Share Lib not installed in default location.’)))
    File “/usr/lib/hue/desktop/core/src/desktop/lib/conf.py”, line 626, in validate_path
    if path is None or not fs.exists(path):
    File “/usr/lib/hue/desktop/libs/hadoop/src/hadoop/fs/webhdfs.py”, line 221, in exists
    return self._stats(path) is not None
    File “/usr/lib/hue/desktop/libs/hadoop/src/hadoop/fs/webhdfs.py”, line 209, in _stats
    raise ex
    WebHdfsException:
    [21/Jul/2013 10:07:27 +0000] http_client DEBUG GET http://sandbox:50070/webhdfs/v1/user/oozie/share/lib?op=GETFILESTATUS&user.name=hue&doas=hue
    [21/Jul/2013 10:07:27 +0000] resource DEBUG GET Got response: {“systemMode”:”NORMAL”}
    [21/Jul/2013 10:07:27 +0000] http_client DEBUG GET http://sandbox:11000/oozie/v1/admin/status?timezone=America%2FLos_Angeles&user.name=hue&doAs=hue
    [21/Jul/2013 10:07:27 +0000] thrift_util DEBUG Thrift call .getRuntimeInfo returned in 1ms: RuntimeInfo(freeMemory=65374192, maxMemory=1052770304, totalMemory=194183168)
    [21/Jul/2013 10:07:27 +0000] thrift_util DEBUG Thrift call: .getRuntimeInfo(args=(RequestContext(confOptions={‘effective_user’: ‘webui’}),), kwargs={})
    [21/Jul/2013 10:07:27 +0000] webhdfs INFO WebHdfs at http://sandbox:50070/webhdfs/v1/ — Validation error:
    [21/Jul/2013 10:07:27 +0000] http_client DEBUG GET http://sandbox:50070/webhdfs/v1/?op=GETFILESTATUS&user.name=hue&doas=hdfs
    [21/Jul/2013 10:07:27 +0000] webhdfs ERROR Failed to determine superuser of WebHdfs at http://sandbox:50070/webhdfs/v1/:
    Traceback (most recent call last):
    File “/usr/lib/hue/desktop/lib

    Collapse
    #28808

    abdelrahman
    Moderator

    Hi Murali,

    Have you checked the namenode log in /var/log/hadoop/hdfs to see why HDFS services are not started?

    Thanks
    -Abdelrahman

    Collapse
    #28807

    Murali Adari
    Member

    Hi Yi,
    After some changes to the hostname in the hosts file and restarting I finally managed to see the Hue Web page as also the services in the Ambari Web admin page. However unable to start the HDFS service. And there is an alert in the Hue home page indicating ” Potential misconfiguration detected. Fix and restart Hue.

    hadoop.hdfs_clusters.default.webhdfs_url Current value: http://sandbox:50070/webhdfs/v1/
    Failed to access filesystem root

    What else should be done to fix ? Thanks for your response.

    Thanks,
    Murali

    Collapse
    #28796

    Yi Zhang
    Moderator

    Hi Murali,

    If you go to Ambari/ Hosts, what are the actions available there?
    Also, are the services running or not? Can you log in the terminal, run as hdfs, ‘hadoop dfsadmin -safemode get’?

    Thanks,
    Yi

    Collapse
    #28792

    Murali Adari
    Member

    How can I start services from the Ambari admin page ? All my services are yellow and the Maintenance, start and Stop buttons are disabled. Also what is the URL to get to the Hue Web admin page ?

    Thanks,
    Murali

    Collapse
    #27650

    tedr
    Moderator

    Hi Marat,

    As mentioned in the thread in the HBase forum of the same topic, this directory is in HDFS and needs to be monitored with the hadoop commands or web ui.

    Thanks,
    Ted.

    Collapse
Viewing 8 replies - 1 through 8 (of 8 total)