Home Forums HBase hbase test failed when deployment

This topic contains 1 reply, has 2 voices, and was last updated by  Sasha J 1 year, 11 months ago.

  • Creator
    Topic
  • #8296

    wang yinna
    Member

    when i deploy the cluster use ambari, the hbase test always failed, I try to fix the error, but also failed. Do you know the reasons? Thank you for your help.
    “”Tue Aug 14 10:35:51 +0800 2012 /Stage[2]/Hdp-hbase::Hbase::Service_check/File[/tmp/hbaseSmoke.sh]/ensure (notice): defined content as ‘{md5}a4e08d5388577f1767eb5f8ea8c4a267′”",
    “”Tue Aug 14 10:35:51 +0800 2012 /Stage[2]/Hdp-hbase::Hbase::Service_check/File[/tmp/hbaseSmoke.sh] (debug): The container Class[Hdp-hbase::Hbase::Service_check] will propagate my refresh event”",
    “”Tue Aug 14 10:35:51 +0800 2012 /Stage[2]/Hdp-hbase::Hbase::Service_check/Exec[/tmp/hbaseSmoke.sh]/returns (debug): Exec try 1/3″”,
    “”Tue Aug 14 10:35:51 +0800 2012 Exec[/tmp/hbaseSmoke.sh](provider=posix) (debug): Executing ‘su – ambari_qa -c ‘hbase –config /etc/hbase/conf/ shell /tmp/hbaseSmoke.sh””",
    “”Tue Aug 14 10:35:51 +0800 2012 Puppet (debug): Executing ‘su – ambari_qa -c ‘hbase –config /etc/hbase/conf/ shell /tmp/hbaseSmoke.sh””",
    “”Tue Aug 14 10:40:51 +0800 2012 /Stage[2]/Hdp-hbase::Hbase::Service_check/Exec[/tmp/hbaseSmoke.sh]/returns (err): change from notrun to 0 failed: Command exceeded timeout at /etc/puppet/agent/modules/hdp-hbase/manifests/hbase/service_check.pp:46″”,
    “”Tue Aug 14 10:40:51 +0800 2012 /Stage[2]/Hdp-hbase::Hbase::Service_check/Hdp-hadoop::Exec-hadoop[hbase::service_check::test]/Hdp::Exec[hadoop --config /etc/hadoop/conf fs -test -e /apps/hbase/data/usertable]/Anchor[hdp::exec::hadoop --config /etc/hadoop/conf fs -test -e /apps/hbase/data/usertable::begin] (notice): Dependency Exec[/tmp/hbaseSmoke.sh] has failures: true”",
    “”Tue Aug 14 10:40:51 +0800 2012 /Stage[2]/Hdp-hbase::Hbase::Service_check/Hdp-hadoop::Exec-hadoop[hbase::service_check::test]/Hdp::Exec[hadoop --config /etc/hadoop/conf fs -test -e /apps/hbase/data/usertable]/Anchor[hdp::exec::hadoop --config /etc/hadoop/conf fs -test -e /apps/hbase/data/usertable::begin] (warning): Skipping because of failed dependencies”",
    “”Tue Aug 14 10:40:51 +0800 2012 /Stage[2]/Hdp-hbase::Hbase::Service_check/Hdp-hadoop::Exec-hadoop[hbase::service_check::test]/Hdp::Exec[hadoop --config /etc/hadoop/conf fs -test -e /apps/hbase/data/usertable]/Exec[hadoop --config /etc/hadoop/conf fs -test -e /apps/hbase/data/usertable] (notice): Dependency Exec[/tmp/hbaseSmoke.sh] has failures: true”",
    “”Tue Aug 14 10:40:51 +0800 2012 /Stage[2]/Hdp-hbase::Hbase::Service_check/Hdp-hadoop::Exec-hadoop[hbase::service_check::test]/Hdp::Exec[hadoop --config /etc/hadoop/conf fs -test -e /apps/hbase/data/usertable]/Exec[hadoop --config /etc/hadoop/conf fs -test -e /apps/hbase/data/usertable] (warning): Skipping because of failed dependencies”",
    “”Tue Aug 14 10:40:51 +0800 2012 /Stage[2]/Hdp-hbase::Hbase::Service_check/Hdp-hadoop::Exec-hadoop[hbase::service_check::test]/Hdp::Exec[hadoop --config /etc/hadoop/conf fs -test -e /apps/hbase/data/usertable]/Anchor[hdp::exec::hadoop --config /etc/hadoop/conf fs -test -e /apps/hbase/data/usertable::end] (notice): Dependency Exec[/tmp/hbaseSmoke.sh] has failures: true”",
    “”Tue Aug 14 10:40:51 +0800 2012 /Stage[2]/Hdp-hbase::Hbase::Service_check/Hdp-hadoop::Exec-hadoop[hbase::service_check::test]/Hdp::Exec[hadoop --config /etc/hadoop/conf fs -test -e /apps/hbase/data/usertable]/Anchor[hdp::exec::hadoop --config /etc/hadoop/conf fs -test -e /apps/hbase/data/usertable::end] (warning): Skipping because of failed dependencies”",
    “”Tue Aug 14 10:40:51 +0800 2012 /Stage[2]/Hdp-hbase::Hbase::Service_check/Anchor[hdp-hbase::hbase::service_check::end] (notice): Dependency Exec[/tmp/hbaseSmoke.sh] has failures: true”",
    “”Tue Aug 14 10:40:51 +0800 2012 /Stage[2]/Hdp-hbase::Hbase::Service_check/Anchor[hdp-hbase::hbase::service_check::end] (warning): Skipping because of failed dependencies”",

Viewing 1 replies (of 1 total)

The topic ‘hbase test failed when deployment’ is closed to new replies.

  • Author
    Replies
  • #8351

    Sasha J
    Moderator

    Can you provide a bit more details about your environment?
    Most likely you hit known bug, which will be fixed in future release: incorrect calculation heap size for HBase Region Server. Heap calculated is too small and Region server could not be started, as a result HBase smoke check failed.
    When you run installer, please make sure you have Region Server heap size set to, at least, 1024 Mb.

    So, the steps are:
    yum -y erase hmc puppet
    yum -y install hmc
    service hmc start

    then connect to UI and start installation.

    Thank you!
    Sasha

    Collapse
Viewing 1 replies (of 1 total)