Home Forums Hive / HCatalog Hcatalog JMS Notification not working

Tagged: 

This topic contains 0 replies, has 1 voice, and was last updated by  Sunil Kumar 6 months ago.

  • Creator
    Topic
  • #52297

    Sunil Kumar
    Participant

    Hi,
    I am trying HCatalog Notification to integrate Hcatalog and Oozie workflow for my exploration and done configuration based on the Wiki page (https://cwiki.apache.org/confluence/display/Hive/HCatalog+Notification ) but nothing coming means no topic getting created in the Active MQ. I am creating some hive table and altering/adding partitions to the tbales bot no notification send to Active MQ by Hcatlog. I have done following configuration in the hive-site.xml

    <property>
    <name>hive.exec.scratchdir</name>
    <value>/var/lib/hadoop_data/hive/scratchdir</value>
    <description>Scratch space for Hive jobs</description>
    </property>

    <property>
    <name>hive.exec.local.scratchdir</name>
    <value>/var/lib/hadoop_data/hive/scratchdir</value>
    <description>Local scratch space for Hive jobs</description>
    </property>

    <property>
    <name>hive.metastore.schema.verification</name>
    <value>true</value>
    </property>

    <property>
    <name>hive.server2.enable.doAs</name>
    <value>false</value>
    <description>Setting this property to true will have hive server2 execute hive operations as the user making the calls to it.</description>
    </property>

    <property>
    <name>hive.metastore.uris</name>
    <value>thrift://localhost:9083</value>
    </property>

    <property>
    <name>hive.metastore.event.expiry.duration</name>
    <value>300L</value>
    <description>Duration after which events expire from events table (in seconds)</description>
    </property>

    <property>
    <name>hive.metastore.event.clean.freq</name>
    <value>360L</value>
    <description>Frequency at which timer task runs to purge expired events in metastore (in seconds).</description>
    </property>

    <property>
    <name>msgbus.brokerurl</name>
    <value>tcp://localhost:61616</value>
    <description></description>
    </property>

    <property>
    <name>msgbus.username</name>
    <value></value>
    <description></description>
    </property>

    <property>
    <name>msgbus.password</name>
    <value></value>
    <description></description>
    </property>

    Please let me know if am missing anything??

You must be logged in to reply to this topic.