Home Forums HDP on Linux – Installation HDFS test failed

This topic contains 11 replies, has 4 voices, and was last updated by  Wu Shixian 1 year, 10 months ago.

  • Creator
    Topic
  • #11828

    Wu Shixian
    Member

    Dear all,
    I am trying to install hmc in 3 nodes cluster with all services. During the deploy, HDFS test fails.
    the hmc.log said:
    [2012:11:05 03:43:18][INFO][PuppetInvoker][PuppetInvoker.php:336][waitForResults]: 0 out of 1 nodes have reported for txn 3-63-55
    [2012:11:05 03:43:23][INFO][PuppetInvoker][PuppetInvoker.php:336][waitForResults]: 0 out of 1 nodes have reported for txn 3-63-55
    [2012:11:05 03:43:28][INFO][PuppetInvoker][PuppetInvoker.php:336][waitForResults]: 1 out of 1 nodes have reported for txn 3-63-55
    [2012:11:05 03:43:29][INFO][PuppetInvoker][PuppetInvoker.php:237][createGenKickWaitResponse]: Response of genKickWait:
    Array
    (
    [result] => 0
    [error] =>
    [nokick] => Array
    (
    )

    [failed] => Array
    (
    [0] => slave2.hadoop
    )

    [success] => Array
    (
    )

    [timedoutnodes] => Array
    (
    )

    )

    [2012:11:05 03:43:29][INFO][Service: HDFS (hortonworks)][Service.php:466][smoke]: Persisting puppet report for smoke testing HDFS
    [2012:11:05 03:43:30][ERROR][Service: HDFS (hortonworks)][Service.php:473][smoke]: Service smoke check failed with Array
    (
    [result] => 0
    [error] =>
    [nokick] => Array
    (
    )

    [failed] => Array
    (
    [0] => slave2.hadoop
    )

    [success] => Array
    (
    )

    [timedoutnodes] => Array
    (
    )

    )

    [2012:11:05 03:43:30][INFO][OrchestratorDB][OrchestratorDB.php:610][persistTransaction]: persist: 3-63-55:FAILED:HDFS test:FAILED

    And I have upload the system check file to the ftp named Doug.checkResult.txt. The check result shows that is one node puppet failed:
    Mon Nov 05 11:43:11 +0800 2012 /Stage[2]/Hdp-hadoop::Hdfs::Service_check/Hdp-hadoop::Exec-hadoop[hdfs::service_check::create_file]/Hdp::Exec[hadoop --config /etc/hadoop/conf fs -rm /tmp/ida8c00c01_date420512; hadoop fs -put /etc/passwd /tmp/ida8c00c01_date420512]/Exec[hadoop --config /etc/hadoop/conf fs -rm /tmp/ida8c00c01_date420512; hadoop fs -put /etc/passwd /tmp/ida8c00c01_date420512]/returns (err): change from notrun to 0 failed: hadoop –config /etc/hadoop/conf fs -rm /tmp/ida8c00c01_date420512; hadoop fs -put /etc/passwd /tmp/ida8c00c01_date420512 returned 255 instead of one of [0] at /etc/puppet/agent/modules/hdp/manifests/init.pp:255
    Can anyone help me ?

Viewing 11 replies - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #12147

    Wu Shixian
    Member

    Jinsong:

    I did not solve it directory. I have reinstall the system of my hmc server. And I have created a mirror server for installation. I find the poor bandwidth may cause some problem.

    Wu

    Collapse
    #12125

    Jinsong Yin
    Member

    Wu Shixian:
    I came across the same error that MapReduce test error, and I want to know how did you work it out, thx.

    Jinsong Yin

    Collapse
    #11947

    tedr
    Member

    Thanks for letting us know.

    Collapse
    #11945

    Wu Shixian
    Member

    Sasha & Ted,

    Thank you very much for helping me with the cluster, I have already installed the cluster successfully.

    Wu.

    Collapse
    #11943

    Wu Shixian
    Member

    Ted,
    Yes I have tried what Sasha suggested. NTP now is running on all nodes. and I have created a /usr/local/hdp for the mount point.
    I have reinstalled the cluster. And I found that the namespaceID on slave nodes is different to the one in master node. So I remove the directory /usr/local/hdp on all slave nodes. And reinstall. This time HDFS test is OK.But MapReduce test is failed.
    Can you tell me if I want to reinstall what I need to pay attention to?
    Wu.

    Collapse
    #11925

    tedr
    Member

    Wu,

    Also make sure that when you get to the point in the install where you are asked which mount points to use, you uncheck the default mount point and put in at least one mount point in the textbox. There is a bug in the installer that chooses a device not a mount point for installation.

    Ted.

    Collapse
    #11923

    tedr
    Member

    Wu,

    Have you tried what Sasha suggested, the most important part of it would be to make sure that NTP is on on all computers in the cluster. If NTP is not enabled on all boxes it can look like one of them is taking too long and you’ll get a puppet kick timeout.

    Ted.

    Collapse
    #11920

    Wu Shixian
    Member

    Hi Ted,
    My hostdetail.txt contents:
    master.hadoop
    slave2.hadoop
    slave3.hadoop

    Collapse
    #11838

    tedr
    Member

    Wu,

    Also what is the content of the hostdetail.txt file?

    Ted.

    Collapse
    #11837

    Sasha J
    Moderator

    Wu,

    It looks like you need to do a few of things:
    1, Enable NTP on slave2 and slave3
    2, then execute the following on all nodes: ‘yum erase hmc puppet’
    3, then on the master node run: ‘yum install hmc’
    4, then also on the master node run: ‘service hmc start’
    and then point your browser at hmc on your master node with "http://<masternode>/hmc/html " and rerun the installation. Replace ‘<masternode>’ with the hostname or ip of your master node.

    Thank you,
    Sasha.

    Collapse
    #11834

    Sasha J
    Moderator

    Wu,

    We are analyzing your logs and will get back to you soon.

    Sasha

    Collapse
Viewing 11 replies - 1 through 11 (of 11 total)