HDP on Windows – Installation Forum

HDP 1.3 for windows Installation on Azure Win Server 2012 fails

  • #34382

    Hi I’m trying to install HDP 1.3 on a windows 2012 server on Azure but getting an installation error.

    Product: Hortonworks Data Platform for Windows — Installation failed. Please see installation log for details: D:\HadoopInstallFiles\HadoopSetupTools\hdp-

    I can’t use the D drive so changed everything to point to C drive

    I’ve got the prerequisites install and the command I’m using is

    C:\HadoopInstall>msiexec /i “hdp-” /lv “hdp.log” HDP_LAYOUT=”C:\HadoopInstall\clusterproperties.txt” HDP_DIR=”C:\hadoop” DESTROY_DATA=”yes”

    In my clusterproperties.txt file i also changed the directories to point to C drive

    #Log directory

    #Data directory

    I’m doing this as an evaluation and hope someone can help me get to the bottom of this.



to create new topics or reply. | New User Registration

  • Author
  • #34403

    Hi Vinny,
    Please specify full path for the log. You mentioned /lv “hdp.log” , it should be something like c:\hdp.log. Please give that a try.



    Hi Robert

    I tried your suggestion but still get the same issue

    C:\HadoopInstall> msiexec /i “hdp-” /lv “c:\hadoopinstall\hdp.log” HDP_LAYOUT=”clusterproperties.txt” HDP_DIR=”C:\hadoop” DESTROY_DATA=”yes”

    Burt Harris

    Now try looking at the log file the dialog box directs you to: … hdp-

    You may have some luck by searching for the string “WINPKG FAILURE”, what appears just before it?

    E.g. My install is currently failing with this. I’d be interested if you are seeing the same thing.

    OOZIE: Calling Setup script to add Hadoop libs to the generated oozie.war file
    OOZIE FAILURE: Unable to execute ‘jar uvf’. Error (1)
    At C:\hdp\oozie-\oozie-win-distro\bin\oozie-setup.ps1:153 char:9
    + throw “Unable to execute ‘jar uvf’. Error ($LASTEXITCODE)”
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    WINPKG FAILURE: OOZIE: Logging to existing log C:\HadoopInstallFiles\HadoopSetupTools\hdp- OOZIE: Logging to C:


    Hi Everyone. I managed to get my master node up and running. My issue was that I missed the environment variable for python. I couldn’t see this in the error.log but stepped through this link again which got me up and running. Now to try and set up a slave node…..

    Seth Lyubich

    Hi Vinny,

    Thanks for letting us know that you resolved the issue.



    I’m having the same issue:
    OOZIE FAILURE: Unable to execute ‘jar uvf’. Error (1) At E:\hdp\oozie-\oozie-win-distro\bin\oozie-setup.ps1:153 char:14
    + throw <<<< "Unable to execute 'jar uvf'. Error ($LASTEXITCODE)"

    Were you able to resolve this issue? Can someone please let me know how to overcome this issue during install?

    Thank you very much in advance.


    In my case, the environment variable for Path is set for Python and I’m able to test Python from command prompt. Is there anything else I need to check?

    Seth Lyubich

    Hi Chandra,

    Can you please check to make sure that your environmental variable JAVA_HOME point to correct location?

    Please let me know if this is helpful.


    Bill Kindel

    I tripped over a problem that seems to be closely related to the OOZIE_FAILUREs reported by Chandra and Burt.
    It appears the script is attempting to use jar as a command, though there is no jar.exe in the JRE distribution.
    I copied jar.exe from the JDK on my workstation, and now it installs.

    Seth Lyubich

    Hi Bill,

    I saw similar issue happen if JAVA_HOME is not defined correctly. Please see http://docs.hortonworks.com/HDPDocuments/HDP1/HDP-Win-1.3.0/bk_installing_hdp_for_windows/content/win-getting-ready-2-3-2.html .


    Manish Sharma

    Hi Vinny,

    Are you using Power Shell Command to install HDP on windows or Command Line. I think you should use Windows Power Shell to execute this command and run power shell using “Run As Administrator”.


    Seth Lyubich

    Hi all,

    All issues in this thread seem to be resolved. Let’s discuss all new issue in new thread.


You must be to reply to this topic. | Create Account

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.