Home Forums HDP on Windows – Installation HDP 1.3 for windows Installation on Azure Win Server 2012 fails

This topic contains 12 replies, has 7 voices, and was last updated by  Seth Lyubich 6 months, 1 week ago.

  • Creator
    Topic
  • #34382

    Hi I’m trying to install HDP 1.3 on a windows 2012 server on Azure but getting an installation error.

    Product: Hortonworks Data Platform 1.3.0.0 for Windows — Installation failed. Please see installation log for details: D:\HadoopInstallFiles\HadoopSetupTools\hdp-1.3.0.0.winpkg.install.log

    I can’t use the D drive so changed everything to point to C drive

    I’ve got the prerequisites install and the command I’m using is

    C:\HadoopInstall>msiexec /i “hdp-1.3.0.0.winpkg.msi” /lv “hdp.log” HDP_LAYOUT=”C:\HadoopInstall\clusterproperties.txt” HDP_DIR=”C:\hadoop” DESTROY_DATA=”yes”

    In my clusterproperties.txt file i also changed the directories to point to C drive

    #Log directory
    HDP_LOG_DIR=c:\hadoop\logs

    #Data directory
    HDP_DATA_DIR=c:\hdp\data

    I’m doing this as an evaluation and hope someone can help me get to the bottom of this.

    Thanks

    Vinny

Viewing 12 replies - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.

  • Author
    Replies
  • #46664

    Seth Lyubich
    Keymaster

    Hi all,

    All issues in this thread seem to be resolved. Let’s discuss all new issue in new thread.

    Thanks,
    Seth

    Collapse
    #46439

    Manish Sharma
    Participant

    Hi Vinny,

    Are you using Power Shell Command to install HDP on windows or Command Line. I think you should use Windows Power Shell to execute this command and run power shell using “Run As Administrator”.

    Thanks
    MANISH

    Collapse
    #45325

    Seth Lyubich
    Keymaster

    Hi Bill,

    I saw similar issue happen if JAVA_HOME is not defined correctly. Please see http://docs.hortonworks.com/HDPDocuments/HDP1/HDP-Win-1.3.0/bk_installing_hdp_for_windows/content/win-getting-ready-2-3-2.html .

    Thanks,
    Seth

    Collapse
    #44034

    Bill Kindel
    Member

    I tripped over a problem that seems to be closely related to the OOZIE_FAILUREs reported by Chandra and Burt.
    It appears the script is attempting to use jar as a command, though there is no jar.exe in the JRE distribution.
    I copied jar.exe from the JDK on my workstation, and now it installs.

    Collapse
    #38971

    Seth Lyubich
    Keymaster

    Hi Chandra,

    Can you please check to make sure that your environmental variable JAVA_HOME point to correct location?

    Please let me know if this is helpful.

    Thanks,
    Seth

    Collapse
    #38396

    In my case, the environment variable for Path is set for Python and I’m able to test Python from command prompt. Is there anything else I need to check?

    Collapse
    #38364

    I’m having the same issue:
    OOZIE FAILURE: Unable to execute ‘jar uvf’. Error (1) At E:\hdp\oozie-3.3.2.1.3.0.0-0380\oozie-win-distro\bin\oozie-setup.ps1:153 char:14
    + throw <<<< "Unable to execute 'jar uvf'. Error ($LASTEXITCODE)"

    Were you able to resolve this issue? Can someone please let me know how to overcome this issue during install?

    Thank you very much in advance.

    Collapse
    #35625

    Seth Lyubich
    Keymaster

    Hi Vinny,

    Thanks for letting us know that you resolved the issue.

    Thanks,
    Seth

    Collapse
    #34518

    Hi Everyone. I managed to get my master node up and running. My issue was that I missed the environment variable for python. I couldn’t see this in the error.log but stepped through this link again which got me up and running. Now to try and set up a slave node…..

    Collapse
    #34479

    Burt Harris
    Member

    Now try looking at the log file the dialog box directs you to: … hdp-1.3.0.0.winpkg.install.log

    You may have some luck by searching for the string “WINPKG FAILURE”, what appears just before it?

    E.g. My install is currently failing with this. I’d be interested if you are seeing the same thing.

    OOZIE: Calling Setup script to add Hadoop libs to the generated oozie.war file
    OOZIE FAILURE: Unable to execute ‘jar uvf’. Error (1)
    At C:\hdp\oozie-3.3.2.1.3.0.0-0380\oozie-win-distro\bin\oozie-setup.ps1:153 char:9
    + throw “Unable to execute ‘jar uvf’. Error ($LASTEXITCODE)”
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    WINPKG FAILURE: OOZIE: Logging to existing log C:\HadoopInstallFiles\HadoopSetupTools\hdp- 1.3.0.0.winpkg.install.log OOZIE: Logging to C:

    Collapse
    #34469

    Hi Robert

    I tried your suggestion but still get the same issue

    C:\HadoopInstall> msiexec /i “hdp-1.3.0.0.winpkg.msi” /lv “c:\hadoopinstall\hdp.log” HDP_LAYOUT=”clusterproperties.txt” HDP_DIR=”C:\hadoop” DESTROY_DATA=”yes”

    Collapse
    #34403

    Robert
    Participant

    Hi Vinny,
    Please specify full path for the log. You mentioned /lv “hdp.log” , it should be something like c:\hdp.log. Please give that a try.

    Regards,
    Robert

    Collapse
Viewing 12 replies - 1 through 12 (of 12 total)