The Hortonworks Community Connection is now live. A completely rebuilt Q&A forum, Knowledge Base, Code Hub and more, backed by the experts in the industry.

You will be redirected here in 10 seconds. If your are not redirected, click here to visit the new site.

The legacy Hortonworks Forum is now closed. You can view a read-only version of the former site by clicking here. The site will be taken offline on January 31,2016

Hortonworks Sandbox Forum

HDP 2 Sandbox, Yarn and Ambari

  • #39388

    Hi there,
    I’m using the VMWare Sandbox with HDP 2.0.
    I’m monitoring my cluster with Ambari, and eveything is healty except the YARN Ressource Manager und the YARN Datanode. If I’m trying to start those services, they will be started without exceptions in Ambari and shown as healty, but after 20 seconds they are red dotted again und stopped. What’s wrong there ?

  • Author
  • #39441

    Hi Benjamin,

    Without any logs then it is difficult to understand what is happening.
    Could you attach the errors from the appropriate logs here?




    After researching a little bit by myself (in the log files) I found out that YARN can’t start because both the resource Manager and the node manager were trying to register a port which is already in use. So i searched for the corresponding process and killed them. After killing those 2 processes I could succussfully start the YARN – Service with Ambari. The problem is solved but it’s persisting after restarting the VM. So I think anything could be wrong in the startup script or sth ? Perhaps is sth starting too early and so the port is alreday in use? Or is this only happening in my VM Sandbox ?


    PS: Ports were 8088 and 45454


    Hi Benjamin,

    Which programs were using these ports?
    I don’t have the issue on my Sandbox, so I’m interested to find what is different on yours (or how you are running it)




    I’m using the VMWare – Version, and i thing i’m using it just normal… I expanded the disc to 100 GB and resized the volume group accordingly to work with a greater data volume. But aside of this i did any special configurations or sth with my vm. Just using the beeswax or the shell to execute queries on my data.

    I think the ressource manager tries to register port 8088. This is in use by the java process with the pid 1657, which seems to be sth from the resource manager itself. As well the port 45454 is used by another java process with the pid 1657 and seems to be a process from the nodemanager itself.
    Could it possibly be that those services are started correctly and only ambari is displaying them stopped ? Interestingly displays Ambari in the dashboard YARN red dotted and shown as stopped but displays the Nodemanager as live. Switching in Ambari to the Hosts perspective shows both the ressource manager and the node manager red dotted and stopped. So I tried to start them and after a short period of a green dot they always switched back to red. Then i started to check the logs and found those errors. It seems after failing to register those ports the shutted themselfes down again.


    The second PID for the Port 45454 is of course not the same as the one for 8088 but 1453, So the two PIDs are 1657 and 1453


    Hi Benjamin,

    Yes, if they can’t register that port they will not start. Can you check for them on a ps -ef | grep $service and then use this pid to see what port it uses.
    I dont understand what you mean by sth ?
    Giving the PIDs here will not help me, you will need to give me the binary or executable.

    Ambari may not be seeing the correct PID, so you will need to kill it off and start it from within ambari itself,



    Jitu kumar

    Hi Dave, please help me. im not able to restart my yarn or Mapreduce2. I don’t know what is the issue. All my components are fine except Yarn. following below is the log file

    2015-11-02 09:23:43,655 – Error while executing command ‘restart’:
    Traceback (most recent call last):
    File “/usr/lib/python2.6/site-packages/resource_management/libraries/script/”, line 214, in execute
    File “/usr/lib/python2.6/site-packages/resource_management/libraries/script/”, line 371, in restart
    File “/var/lib/ambari-agent/cache/common-services/YARN/”, line 59, in start
    File “/var/lib/ambari-agent/cache/common-services/YARN/”, line 59, in service
    File “/usr/lib/python2.6/site-packages/resource_management/core/”, line 148, in __init__
    File “/usr/lib/python2.6/site-packages/resource_management/core/”, line 152, in run
    self.run_action(resource, action)
    File “/usr/lib/python2.6/site-packages/resource_management/core/”, line 118, in run_action
    File “/usr/lib/python2.6/site-packages/resource_management/core/providers/”, line 274, in action_run
    raise ex
    Fail: Execution of ‘ls /var/run/hadoop-yarn/yarn/ >/dev/null 2>&1 && ps -p cat /var/run/hadoop-yarn/yarn/ >/dev/null 2>&1′ returned 1.

The forum ‘Hortonworks Sandbox’ is closed to new topics and replies.

Support from the Experts

A HDP Support Subscription connects you experts with deep experience running Apache Hadoop in production, at-scale on the most demanding workloads.

Enterprise Support »

Become HDP Certified

Real world training designed by the core architects of Hadoop. Scenario-based training courses are available in-classroom or online from anywhere in the world

Training »

Hortonworks Data Platform
The Hortonworks Data Platform is a 100% open source distribution of Apache Hadoop that is truly enterprise grade having been built, tested and hardened with enterprise rigor.
Get started with Sandbox
Hortonworks Sandbox is a self-contained virtual machine with Apache Hadoop pre-configured alongside a set of hands-on, step-by-step Hadoop tutorials.
Modern Data Architecture
Tackle the challenges of big data. Hadoop integrates with existing EDW, RDBMS and MPP systems to deliver lower cost, higher capacity infrastructure.